Forum général.cherche-matériel Lecteur de code barre (douchette)

Posté par .
Tags : aucun
1
17
mai
2007
Bonjour,
Est-il possible d'utiliser un lecteur de code barre sous X. Il fonctionne très bien sous windows, mais n'écrit rien sous linux, quelle que soit la distribution (Ubuntu, Suse, debian...).
Il s'agit d'un lecteur qui emule les touches clavier en Y sur ce dernier de Marque Percon modèle BB Snapshot.
Quelqu'un a t'il déjà eu ce genre de problème??
Merci d'avance.
Bruno
  • # test...

    Posté par . Évalué à 2.

    as-tu essayé de voir avec l'outil xev
    savoir si ton X voit des choses arriver quand tu utilises la douchette.

    sous windows, tu as un driver en plus, ou c'est reconnu d'office ?
    • [^] # Re: test...

      Posté par . Évalué à 1.

      Merci de ta réponse,
      Je n'ai pas essayé l'outil xev, mais je vais tester...
      Sous windows, pas besoin de driver car il envoie des touches clavier, c'est pour cela que ça me semble étrange que linux ne voit rien.
      @+
      • [^] # Re: test...

        Posté par . Évalué à 1.


        Sous windows, pas besoin de driver car il envoie des touches clavier, c'est pour cela que ça me semble étrange que linux ne voit rien

        en effet oui...
      • [^] # Re: test...

        Posté par (page perso) . Évalué à 2.

        Si c'est un périphérique usb, sous linux il fait pareil sauf qu'il faut parfois lire directement le /dev/input/kivabien (ou forcer X à le lire).

        Vérifie au passage dans dmesg que le périphérique a bien été reconnu.
    • [^] # Re: test...

      Posté par . Évalué à 1.

      Je viens de tester xev et les séquences de touche sont bien envoyées, mais X n'affiche rien.
      J'ai aussi testé en mode texte et à la lecture des codes barre, cela s'affiche correctement. C'est a n'y rien comprendre...
      Sous X doit on parametrer quelque chose??
      • [^] # Re: test...

        Posté par . Évalué à 1.


        Posté par peck (page perso, envoyer un message privé) le 17/05/2007 à 11:56. (lien). Évalué à 2.

        Si c'est un périphérique usb, sous linux il fait pareil sauf qu'il faut parfois lire directement le /dev/input/kivabien (ou forcer X à le lire).

        Vérifie au passage dans dmesg que le périphérique a bien été reconnu.



        il faut peut-etre ajouter un peripherique clavier dans ta config de xorg.

        1°) debranche la douchette
        2°) ouvre un terminal et fais tail -f /var/log/messages
        3°) branche la douchette et regarde ce qu'il se passe

        4°) poste ici le resultat ou essaie en ajoutant une section clavier dans ton xorg.
        • [^] # Re: test...

          Posté par . Évalué à 1.

          Pas de réaction à la procédure, surement parce c'est un Y en PS2.

          Je te poste le résultat...


          May 17 17:26:37 Ubuntu kernel: [ 1490.461431] sd 3:0:0:0: Attached scsi generic sg3 type 0
          May 17 17:28:48 Ubuntu gconfd (root-7645): démarrage (version 2.18.0.1), pid 7645 utilisateur « root »
          May 17 17:28:48 Ubuntu gconfd (root-7645): Adresse « xml:readonly:/etc/gconf/gconf.xml.mandatory » résolue vers une source de configuration en lecture seule à la position 0
          May 17 17:28:48 Ubuntu gconfd (root-7645): Adresse « xml:readwrite:/root/.gconf » résolue vers une source de configuration accessible en écriture à la position 1
          May 17 17:28:48 Ubuntu gconfd (root-7645): Adresse « xml:readonly:/etc/gconf/gconf.xml.defaults » résolue vers une source de configuration en lecture seule à la position 2
          May 17 17:28:48 Ubuntu gconfd (root-7645): Adresse « xml:readonly:/var/lib/gconf/debian.defaults » résolue vers une source de configuration en lecture seule à la position 3
          May 17 17:28:48 Ubuntu gconfd (root-7645): Adresse « xml:readonly:/var/lib/gconf/defaults » résolue vers une source de configuration en lecture seule à la position 4
          May 17 17:43:18 Ubuntu -- MARK --
          May 17 17:52:48 Ubuntu gconfd (root-7645): Le serveur GConf n'est pas en cours d'utilisation, arrêt.
          May 17 17:52:48 Ubuntu gconfd (root-7645): Sortie
  • # (re)Initialisé au démarrage X ?

    Posté par . Évalué à 2.

    Essai de démarrer X d'abord et brancher la douchette après.

    J'ai eu un problème similaire, mais pas avec X, la douchette était rendue inactive au lancement d'un soft sous un OS propriétaire, jamais compris pourquoi.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.