Forum général.général Interdire à firefox/iceweasel de vérifier les connexions wifi

Posté par . Licence CC by-sa
2
9
déc.
2017

Salut,

J'ai un problème avec firefox qui commence sérieusement à me taper sur le système, je me connecte souvent via un réseau wifi, et je le désactive souvent selon si j'en ai besoin ou non en fonction de ce que je fais sur mon ordinateur portable, sauf que si je suis déconnecté (automatiquement au bout d'un certain d'inactivité sur internet), firefox vérifie mes connexions et affiche un bandeau me disant qu'il faut que je me connecte à mon réseau en me proposant d'afficher la page de login de ce réseau, et parfois me fait carrément une redirection sans mon consentement (vers la page login wifi) d'une page que j'avais ouverte dans le navigateur et sans pouvoir retourner en arrière, par exemple une page de documentation quelconque que je consulte.
D'autant que j'ai souvent des pages web locales ouvertes dans mon navigateur, donc la connexion réseau wifi j'en ai pas besoin.

Alors oui, je conçois que ce comportement puisse être utile pour les gens ne trouvant pas la page de login d'un réseau wifi, mais moi je ne veux pas de ça, ce que je demande à un navigateur c'est de se connecter à une page web (si la connexion est inactive cela n'impute qu'à moi), pas de pinguer (ou autre façon) sans cesse ma connexion réseau et surtout de ne pas faire de redirection sans mon consentement.

Voilà, je cherche donc un moyen de désactiver définivement ce comportement agaçant de firefox, j'ai farfouillé dans about:config (j'ai déjà viré tout ce qui avait trait à google dedans), et regardé tout ce qui concernait le network, mais rien ne concerne vraiment cela, du moins je en trouve pas comment faire.

Auriez-vous une idée de comment faire ce que je souhaite ?

Merci.

  • # Firefox fautif?

    Posté par (page perso) . Évalué à 2.

    Je n'ai pas de solution à ce problème, mais il ne vient peut être pas de Firefox. Il y a des sites qui s'actualisent tout seul avec des fonctions javascript, pour actualiser des éléments de la page, afficher des publicités, ou à cause de certains traceurs. Concernant la redirection vers la page de login, ça c'est le routeur qui doit le faire (le routeur t'enverra cette page tant que tu n'est pas connecté, peu importe ce que le navigateur demande).

    Enfin, une solution peut-être: installer un bloqueur de pub, et désactiver le Javascipt.

    Un LUG en Lorraine : https://enunclic-cappel.fr

  • # network.portal-captive-service.enabled

    Posté par (page perso) . Évalué à 5.

    Voilà, je cherche donc un moyen de désactiver définivement ce comportement agaçant de firefox, j'ai farfouillé dans about:config (j'ai déjà viré tout ce qui avait trait à google dedans), et regardé tout ce qui concernait le network, mais rien ne concerne vraiment cela, du moins je en trouve pas comment faire.

    Normalement, ce comportement est contrôlé dans about:config par les options network.portal-captive-service.* (notamment enabled, qui l’active ou le désactive) et captivedetect.* (notamment canonicalURL, qui donne la ressource à laquelle Firefox tente d’accéder pour déterminer s’il est en présence d’un portail captif).

    • [^] # Re: network.portal-captive-service.enabled

      Posté par . Évalué à 2. Dernière modification le 10/12/17 à 12:16.

      Merci de vos réponses.

      @ted
      Cela n'a rien à voir avec le javascript des pages que je visite, mais bien du navigateur.
      Et j'ai tout ce qu'il faut en extensions en bloqueur de pub et javascript =)

      @gouttegd
      Malheureusement cela ne fonctionne pas, j'avais déjà désactivé network.portal-captive-service.enabled, mais firefox a toujours continué à vérifier ma connexion.

      Titre de l'image

      J'ai même changé l'url de captivedetect.canonicalURL en mettant une chaine vide ou encore un chenim vers un fichier local (avec "success" dedans) mais pareil, il continue toujours à m'afficher ce bandeau, comme si tous ces paramètres de configuration n'étaient pas pris en compte par firefox.

  • # Cela semble être un bug de firefox

    Posté par . Évalué à 2.

    Après quelques recherches, Je repasse ici pour signaler que c'est, si j'ai bien compris, un bug de firefox.
    (https://bugzilla.mozilla.org/show_bug.cgi?id=1354245)

    Comme j'utilise la version disponible dans mes paquets, la 52 donc, le bug est encore présent, je pense que je vais abandonner la 52 pour installer la dernière version sur le site de mozilla.

    Merci à vous de m'avoir aiguiller pour trouver pourquoi ce paramètre n'était pas pris en compte.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.