Forum général.général Sifflement alimentation sous Debian Wheezy, pas sous WIndows

Posté par (page perso) .
Tags : aucun
1
2
sept.
2012

Bonjour,

J'ai un problème un peu étrange avec mon ordinateur fixe. Depuis peu j'ai un grésillement sous Debian Wheezy dès que mon cpu / gpu tournent un peu.

Je pensais à un problème avec mon alimentation vieillissante qui aurait du mal répondre aux besoins du cpu et du gpu, mais ce qui est étrange c'est que sous Windows, il n'y a pas de sifflements, même lorsque je lance un petit logiciel de benchmark gpu.

CPU : quad-core i7 3GHZ

GPU : AMD HD 5450

PSU : Antec HE 430W

Un bug avec wheezy dans la gestion des i7, vrai problème avec le PSU, autre chose ?

J'ai cherché un peu partout, mais là, je sèche (il n'y aurait pas cette histoire de Windows, j'aurais une idée, mais là…)

  • # grésillement ou sifflement ?

    Posté par (page perso) . Évalué à 2.

    je ne vais pas te faire l'insulte de te demander si tu as débranché tes haut-parleurs…
    mais es tu certain que le sifflement vient bien de l'alimentation et pas d'un autre composant (la carte graphique qui serait plus sollicitée par exemple) ?

    j'ai moi un sifflement (Archlinux, pas de multiboot pour comparer avec Win) qui est apparu avec le temps (ou à la suite d'une màj ?), mais il vient des haut-parleurs,
    alors j'ai essayé de désactiver le chip sonore intégré à la carte mère et d'installer une carte son pci, mais j'ai renoncé (trop compliqué pour moi le son sous GNU/Linux :-(

    Envoyé depuis mon Archlinux

    • [^] # Re: grésillement ou sifflement ?

      Posté par (page perso) . Évalué à 2.

      Oui, les hauts-parleurs sont bien débranchés, j'en suis certains puisque … je n'en ai pas ;) Du moins, pas sur cette machine que j'utilise principalement au casque.

      Peut-être le son provient-il d'un autre composant que l'alim. J'ai pensé au CPU. C'est plus probable que le GPU puisque le grésillement se fait entendre dès le boot de Debian.

      Mais, en fait, il est bien difficile de localiser la provenance de ces bruits. Il me semble qu'ils se situent à l'arrière en haut (alim ou CPU).

  • # gestion ACPI differente sous windows et sous linux

    Posté par . Évalué à 5.

    passé un temps l'ACPI etait sacrement developpé pour windows, parfois buggé
    et sous linux il fallait des patchs pour certaines machines.

    depuis il me semble qu'il y a des systemes un peu plus standard, mais sur ta machine si ca se trouve, l'acpi n'est pas bon,
    et le processeur tourne peut-etre plus vite sous linux que sous windows
    donc il chauffe plus et le ventilo s'enclenche plus tot

    • [^] # Re: gestion ACPI differente sous windows et sous linux

      Posté par . Évalué à 2.

      typiquement si c'est un sifflement à l'alim c'est un condensateur qui est crevé (physiquement)
      il suffit donc effectivement qu'il soit +ou- sollicité entre un OS et l'autre pour qu'il "siffle" que sur l'un et pas l'autre.

      après ça peut être n'importe où sur la mother bord ou sur l'alim ou ailleur, bref sur un composant géré par l'acpi…

      Mais j'aurai tendance à dire l'alim puisque c'est le cas le plus courant.

      • [^] # Re: gestion ACPI differente sous windows et sous linux

        Posté par (page perso) . Évalué à 2.

        La carte mère et le GPU sont neufs, l'alim d'occasion, donc probablement l'alim.

        Un point à souligner : Windows est en 32 bit et linux en 64 bit ce qui fait également que sous Win seul 3G de ram sont gérés contre les 4G sur Linux, ça doit jouer sur la conso.

  • # Problème similaire

    Posté par (page perso) . Évalué à 2.

    Personnellement j'ai remarqué un truc du même genre sur mon laptop, quand il est sur batterie il fait des "clac clac" sous debian sid, aucune idée sous windows, par contre je crois que quand je coupe google-chrome ça ne le fait plus.

    Ça se ressemble même si c'est pas pareil… en tout cas je vais suivre les commentaires si quelque chose en ressort :p

    • [^] # Re: Problème similaire

      Posté par (page perso) . Évalué à 4.

      Le clac-clac sur batterie, c'est le disque dur qui s'arrête ou qui redémarre. Laptop-mode-tools a un réglage assez agressif du disque dur sur batterie, qui fait qu'il s'arrête très souvent. Sachant que la durée de vie d'un disque dur est souvent limité par le nombre de démarrage, j'ai tendance à augmenter un peu le délai d'arrêt du disque dur, quitte à perdre un peu de batterie.

    • [^] # Re: Problème similaire

      Posté par . Évalué à 1.

      Tu as un WD ?

      Regarde si c'est pas un problème de parquage des têtes.

      • [^] # Re: Problème similaire

        Posté par (page perso) . Évalué à 1.

        J'ai un doute pour la marque, je regarde le commentaire d'avant et si c'est pas ça je me renseignerai sur le parquage des têtes

        • [^] # Re: Problème similaire

          Posté par . Évalué à 1.

          Tu peux vérifier le parquage des têtes en regardant
          smartctl -a /dev/sda |grep -i load
          Si tu as plusieurs dizaines de milliers et que ça monte rapidement (plusieurs fois par minute), c'est pas bon.

          Moi j'ai ça dans mon /etc/rc.local :

          # Pour le problème de parquage des têtes
          hdparm -B 255 /dev/sda
          # AAM
          hdparm -M 128 /dev/sda```

          PS : tiens, on peut pas mettre un # à l'intérieur d'un bloc de code (les trois `)

          • [^] # Re: Problème similaire

            Posté par (page perso) . Évalué à 3.

            #si
            
            

            « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

            • [^] # Re: Problème similaire

              Posté par . Évalué à 2.

              Surtout n'indique pas comment tu as fait :p

              • [^] # Re: Problème similaire

                Posté par (page perso) . Évalué à 3.

                Désolé, je croyais que c'était évident, voilà tout le contenu de mon commentaire précédent :

                ```
                #si
                ```
                
                

                « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

                • [^] # Re: Problème similaire

                  Posté par . Évalué à 1. Dernière modification le 08/09/12 à 00:03.

                  Ah possible que ça passe mal la prévisualisation, mais que ça s'affiche correctement une fois posté. Moi en tout cas, en prévisualisant j'avais un titre à la place du commentaire, à cause du #

                  test :

                  # commentaire
                  
                  
                  #commentaire
                  
                  

                  edit : le problème apparait quand on met un espace entre le # et le commentaire.

                  edit2 : damnit, ça marche correctement si on édite le message… rah.

          • [^] # Re: Problème similaire

            Posté par (page perso) . Évalué à 1.

            193 Load_Cycle_Count 0x0032 040 040 000 Old_age Always - 121692

            Et ça bouge pas.

            • [^] # Re: Problème similaire

              Posté par . Évalué à 1.

              120000, ça fait beaucoup. Mais si ça bouge plus, il est possible qu'à l'installation ton système était touché par le problème, puis qu'une mise à jour l'a corrigé ensuite.

  • # Si gestion de l'alimentation : kernel

    Posté par . Évalué à 1.

    quel est la version du kernel que tu utilises ?
    uname -a

  • # Ça le fait même quand la consommation est plus faible ?

    Posté par . Évalué à 3.

    essaie echo low > /sys/class/drm/card0/device/power_profile ; pour faire baisser de quelques watts la consommation électrique de la carte graphique, ou sinon comme dit plus haut powertop, et voir si le sifflement varie.

  • # Résolu

    Posté par (page perso) . Évalué à 3.

    Il s'agissait d'une faiblesse de l'alimentation. Je l'ai remplacé par une alim neuve, et tout va bien.

  • # noapic, nolapic, acpi=off

    Posté par . Évalué à 0.

    Peux-tu tenter ces options de boot du kernel sur ton entrée GRUB/Lilo et voir ce que cela donne ?

    Ensembles et séparément…

    Pour chaque personne qui me plussoie, je frappe un fan de Justin Bieber.

    • [^] # Re: noapic, nolapic, acpi=off

      Posté par . Évalué à 0.

      Ha, j'arrive après la bataille…

      Ma réponse sera pour les autres qui auront le même genre de soucis :)

      Pour chaque personne qui me plussoie, je frappe un fan de Justin Bieber.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.