Forum Linux.debian/ubuntu clavier AZERTY qui retourne en QWERTY

Posté par .
Tags : aucun
1
24
oct.
2010
Chères moules,

Le clavier de ma mère, AZERTY, en vaut deux repasse spontanément en QWERTY. Je lui ai installé Debian Squeeze, dont elle est très contente, mais là, ça fait tache. Pour le moment je lui ai montré comment remettre le clavier en AZERTY (pas de problème pour son mot de passe de session, il est presque QWERTY-transparent). Est-ce que quelqu'un a eu le même problème ? (pas moi, mais mon clavier est en BÉPO). Les debianistes ont-ils une solution qui règle le problème sans risquer de tout recasser par la suite ?
  • # précision

    Posté par . Évalué à 1.

    « spontanément », c'est-à-dire qu'à chaque fois qu'elle ferme sa session ou éteint le PC, son clavier est revenu en QWERTY.
    • [^] # Re: précision

      Posté par . Évalué à 3.

      Regarde dans ta config xorg (/etc/X11/xorg.conf) si tu n'as pas une ligne qui force le clavier US

      corrige le ci besoin, et refait un essai.


      si ca persiste, installes les paquets pour que ton OS soit dans le bon pays.

      ca devrait alors faire en sorte que le clavier soit en francais des le boot.
      au besoin tu vires les paquets de la langue anglaise
      • [^] # Re: précision

        Posté par . Évalué à 1.

        Je vais regarder mais ce serait bizarre, ça marchait très bien jusque-là et je n'ai jamais touché à son xorg.conf. Je soupçonne une mise à jour d'avoir modifié quelque chose qu'il ne fallait pas.
      • [^] # Re: précision

        Posté par . Évalué à 1.

        Hum, virer les packets de la langue anglaise, je ne m'y risquerais pas...
  • # Pilote

    Posté par . Évalué à 2.

    Ça fait ça des fois avec les ".bin" distribués par les fabriquants en guise de pilote de carte graphique. nVidia ou Ati.

    T'aurais pas utilisé un de ces trucs, voire un script qui re-force le pilote proprio à chaque démarrage et ré-écrit le fichier de conf de Xorg?

    THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

    • [^] # Re: Pilote

      Posté par . Évalué à 2.

      Non, il n'y a pas un bit de pilote propriétaire dans son système. C'est moi qui ai fait monter le PC en choisissant tout dans ce but :-). La puce graphique est du Intel intégré, parfaitement suffisant pour son usage essentiellement bureautique, mais aussi pour Google Earth.
  • # gdm

    Posté par (page perso) . Évalué à 2.

    gdm a le pouvoir de changer le clavier de toute la session. J'ai eu le problème avec l'autologin (parce que du coup on ne peux pas choisir et le choix US est fait par défaut).
    dm (qui
    La solution est de désactiver l'autoogin, de choisir le clavier français dans gdm (qui va enregistrer la préférence) et puis de réactiver l'autologin.

    Vérifie que lors du login, tu as bien choisi un clavier français.
    • [^] # Re: gdm

      Posté par . Évalué à 1.

      Pas d'autologin, elle doit donner son identifiant (enfin, cliquer dessus) et son mot de passe à chaque fois. Mais je vais vérifier ce que dit gdm.
  • # Même problème ici (sid)

    Posté par . Évalué à 1.

    Ça fait quelques temps que je suis obligé de faire un "setxkbmap fr bepo" à chaque fois que je sors de veille. Je n'ai jamais eu le temps de regarder. Si tu trouves fais passer l'info.
  • # Xorg

    Posté par . Évalué à 1.

    Quelle est ta version de Xorg ?
    En 1.8.x et plus il y a un changement au niveau de la detection des periphériques.
    Dans ce cas il faut mettre :
    Section "ServerFlags"
    Option "AutoAddDevices" "off" # default on
    EndSection
    Dans ton xorg.conf
    Aussi regarde (toute version) :
    /etc/hal/fdi/policy/10-keymap.fdi
    (je suis pas sous debian donc verifie où est ce fichier).

    Si tu fais des upgrades régulières de ton systeme verifie bien ce que tu installe à chaque fois.

    De plus sur ton desktop (tu es sous gnome ?) tu dois pouvoir lancer un applet qui gere le type de clavier.
  • # HAL Policy

    Posté par . Évalué à 2.

    Une piste...

    Sur Slackware (à partir de la 13.0), la configuration du clavier n’est plus dans xorg.conf mais vient de Hal. Les configurations par défaut (upstream) contiennent entre autres choses un clavier US donc QWERTY.

    Par exemple sous Slack le fichier de « policy » du clavier est « us » donc querty. Pour remédier au problème il faut rajouter une configuration « locale » du clavier pour Hal (dans /etc/hal/fdi/policy)..

    Il n’est donc pas impossible que Debian pour sa testing n’ait pas encore adapté les outils de configuration à cet automatisme.
    • [^] # Re: HAL Policy

      Posté par . Évalué à 1.

      Effectivement, je pense que c'est une bonne piste. Debian regarde maintenant la configuration du clavier de la console linux (celle sur Alt+F1) pour dire à HAL quel clavier utiliser.

      Peut-être faudrait-il regarder du côté de la commande suivante ?

      dpkg-reconfigure keyboard-configuration

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.