Forum Linux.debian/ubuntu Debian Sid / Transition GCC 5 : est-ce que 'apt-get upgrade' est sûr ?

Posté par . Licence CC by-sa
Tags : aucun
1
31
août
2015

Bonjour,

La transition vers GCC 5 provoque une longue chaîne de paquets cassés dans Debian Sid. Exécuter

apt-get dist-upgrade

est hautement déconseillé pour garder un environnement fonctionnel.

Est-ce que quelqu'un sait si

apt-get upgrade

(qui n'a pas l'air de se plaindre avant confirmation) est sûr à exécuter ?

Merci de vos réponses.

  • # tout est dans le nom de la distrib

    Posté par . Évalué à -1.

    SID : Still In Development
    elle est aussi appelée unstable

    et donc par definition ca peut marcher, mais ca peut aussi tomber en panne

    https://wiki.debian.org/fr/DebianUnstable

    • [^] # Re: tout est dans le nom de la distrib

      Posté par . Évalué à 4.

      Outre le fait que cette remarque n'a rien à voir avec la question, et pour la 50 000ème fois, unstable dans Debian signifie qui change souvent, pas qui plante souvent. Et ceux qui l'utilisent régulièrement savent qu'elle ne casse pas plus que Arch, Suse ou Fedora, sauf périodes spéciales de transition comme en ce moment.

      • [^] # Re: tout est dans le nom de la distrib

        Posté par (page perso) . Évalué à 2.

        Ce qui est rigolo en ce moment, c'est le combo gcc 5 combiné avec kde 5. Mais bon, en serrant les fesses, ça passe (je laisse tranquille gcc et j'en suis à 50% de kde 5 (les autres 50% sont toujours en kde4).

        It's a fez. I wear a fez now. Fezes are cool !

  • # oui

    Posté par . Évalué à 4.

    perso voici ce que je fais pour mettre à jour :

    – apt-get dist-upgrade en règle général. Sauf qu'en ce moment, pas mal de paquets sont en souffrance avec la transition, et donc il veut virer beaucoup de chose… et je ne veux pas.
    – apt-get upgrade en second choix. Il n'installera que ce qui ne casse pas le système, et laissera les paquets problématique en attente.

    Donc je dirais c'est sûr… mais vérifie bien qu'il ne supprime pas de paquet dont tu as besoin. Typiquement en ce moment digikam n'est pas installable en testing/sid, et ce depuis plusieurs semaines.

  • # et apt

    Posté par (page perso) . Évalué à 4.

    Il est assez conservateur d'utiliser "apt".

    apt update
    apt upgrade

    aptitude, en particulier, avait beaucoup de soucis avec la transition gcc5.

    • [^] # Re: et apt

      Posté par (page perso) . Évalué à 3.

      apt et apt-get, c’est la même chose.

      La seule différence c’est que apt est prévu pour les utilisateurs « non-expérimenté » (d’où le coté froufrou du truc).

  • # Et si on testait ?

    Posté par . Évalué à 3.

    On peut toujours essayer pour voir. Mais avant mieux vaut avoir un système de snapshot comme lvm, btrfs, image qcow ou autre.

    On fait un snapshot. On mets à jour. Si tout est cassé, on reviens au snapshot.

  • # Wait & see

    Posté par (page perso) . Évalué à 0.

    Si j'utilisais sid (et ne participais pas aux efforts liés à cette transition), j'attendrais tranquillement la fin de cette transition avant la moindre mise à jour massive.

    Debian Consultant @ DEBAMAX

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.