Forum Linux.debian/ubuntu gestion rétroéclairage clavier sur laptop Toshiba, possible.??

Posté par . Licence CC by-sa
Tags : aucun
1
27
sept.
2017

Hey, salut à tous
je suis nouvelle ici, excusez d'avance si je me trompe de section.

une petite question ou plutot une demande pour une astuce.!!
je suis l'heureuse propriétaire d'un laptop Toshiba p870-338 depuis 4 ans.
sous Debian Sid tout fonctionne à la perfection.
j'ai acheté il y a maintenant 2 ans un clavier neuf rétroéclairé issu d'un Toshiba Qosmio X870 pour le monter sur mon Toshiba (en faite c'est les mêmes pc sauf que le Qosmio est orienté gamer, alors que le mien non).

le clavier s'est adapté sans aucun problème, le rétroéclairage fonctionne au poil.
seulement voilà, il y a un an et demi, j'étais sous w8.1 et w10 en dual boot, et je pouvais gérer le rétroéclairage de mon clavier via le logiciel Toshiba Function Key Utility. logiciel non porté sous Linux évidemment :/

sous Debian (et Linux en général) impossible donc d'éteindre le clavier sauf en passant par le bios qui a une option pour ça (bien pensé Toshiba)

alors je me demandais si il existait sous Debian, un petit utilitaire ou un script ou autre, pour gérer le rétroéclairage sans passer par le bios.??

et que pour l'allumer et l'éteindre sous Windows, c'était la combinaison
FN + W

j'ai vu des posts sur différents forums mais c'était pour des laptops Msi, Asus, Dell, mais pas de Toshiba.
et malgré des recherches par exemple ici
https://askubuntu.com/questions/780176/how-to-make-my-toshiba-u940-laptops-keyboard-backlit-to-work/780184#780184
ou ici
https://wiki.archlinux.org/index.php/Toshiba_Portege_Z30-A
je me rends compte que j'ai pas de dossiers comme eux précisent :/
et en regardant via Synaptic, tous les paquets Acpi ne sont pas installés (source du problème peut-être.?)
Faut t'il les installer d'après vous.?!
Et si oui, lesquels.?!?
voir la capture
https://www.pixenli.com/images/1506/1506502264073217200.png

voilà voilà
si quelqu'un connait un moyen de gérer tout ceci, ça serait cool, ça m'éviterait tous ces passages réguliers dans le bios…
la gestion du clavier c'est pour économiser un peu ma batterie la journée quand je suis en déplacement :)
et quand le soleil brille de mille feux, le rétroéclairage devient superflu ;)

Merci d'avance
en espérant que des Linuxiens se penchent sur ma curiosité '

Debian Sid Cinnamon avec le kernel 4.12.0-2

Melissa.

  • # personne

    Posté par . Évalué à 1 (+0/-0).

    Personne pour m'aider.?!?
    :( :( :(

    C'est stupide ce que je demande.?! :'(

    Désolé si la question est débile mais j'ai beau retourner le web, je trouve pas la réponse à ma question :(
    Je sais que je suis blonde mais quand même pas si idiote.?!
    Si.?!?! :-( :'(

    Comment être insensible face à cette cruauté envers les animaux :'(

    • [^] # Re: personne

      Posté par . Évalué à 4 (+2/-0).

      Personne pour m'aider.?!?
      :( :( :(

      c'est peut-etre juste que tu poses ta question aux heures de bureau
      et comme beaucoup d'entre nous avons un travail remunerateur en dehors de linuxfr (qui est une association sans salarié)
      et bien on repond quand on a le temps de regarder le forum.

      il faut donc parfois attendre le soir pour voir arriver les reponses ;)

      • [^] # Re: personne

        Posté par . Évalué à 1 (+0/-0).

        Ha je sais pas, je vois des posts obtenir des réponses en moins d'une heure, d'où ma question.

        Je bosse aussi mais sur mon pc et a domicile donc forcement j'ai le temps de flaner sur les forums pour essayer de résoudre mon ""problème"" qui devient handicapant au fil des jours…

        Comment être insensible face à cette cruauté envers les animaux :'(

  • # mes notes perso

    Posté par . Évalué à 3 (+2/-0). Dernière modification le 27/09/17 à 17:31.

    Bonjour,

    J'avais eu ce problème avec un clavier usb externe dit "gamer".
    J'ai retrouvé mes notes sur la solution que j'avais glanée et qui fonctionnait à l'époque.
    Je te la livre en brut

    Il faut créer un fichier nommé keyb_switch_light dans le dossier usr/bin

    dans un terminal :

    cd usr/bin
    touch keyb_switch_light
    chmod +x keyb_switch_light
    sudo gedit keyb_switch_light

    mettre dans le fichier créé les lignes suivantes

    #!/bin/bash
    if [ -f /tmp/keyboard_light ]; then
    xset -led 3 && rm /tmp/keyboard_light
    else
    xset led 3 && touch /tmp/keyboard_light
    fi
    Ensuite, aller dans le Sytème-> Préférences->Raccourcis claviers, et rajouter sous le raccourcis que tu veux la commande : "/usr/bin/keyb_switch_light".

    • [^] # Re: mes notes perso

      Posté par . Évalué à 1 (+0/-0).

      bonjour @lolonene

      je viens de faire tes manip en suivant les étapes de A à Z
      mais hélas ça ne fonctionne pas..

      surement du au faite que toi c'était un clavier usb, alors que le mien est un clavier de pc portable, ça doit peut-être différé..!!!

      en tout cas, c'est + complexe que ce que je pensais.
      si seulement le logiciel fournit par Toshiba, avait été porté sous Linux, ça aurait le top du top

      Comment être insensible face à cette cruauté envers les animaux :'(

  • # A tester

    Posté par . Évalué à 1 (+0/-0).

    Hello melissa6969,

    j'ai trouvé cette information xset led on ici, plus d'infos sur xset ici

    Une autre information qui parlerai d'ajouter l'option acpi dans le grub ici (tout en bas)

    Souvent 99% fonctionne sans bidouilles et des fois, il faut persévérer longtemps dans ses recherches pour finir par trouver la configuration qui marche pour le 1%.

    Ce que tu as demandé est une situation peu rencontrée et comme ton post était bien renseigné, il fallait prendre le temps de lire toutes les informations que tu as données pour ne pas te donner les même :-)

    Courage et bonne chance, dis nous quand tu trouves.

    Julien_c'est_bien (y'a pas que Seb)

  • # j'ai essayé

    Posté par . Évalué à 1 (+0/-0). Dernière modification le 27/09/17 à 23:10.

    hello Julien-jo6

    merci pour ta réponse.
    alors pour résumer.
    xset led on me bloque le pavé numérique du clavier donc impossible de m'en servir malgré que la Led du Verr Num soit actif.
    xset led off déverouille le pavé numérique, donc je peux taper des chiffres..
    bizarre que xset agisse sur le pavé numérique chez moi….

    l'option "quiet splash acpi_osi=" dans le grub n'a hélas aucun effet sur le pc.
    j'ai évidemment mis à jour le grub, rebooter, mais pas moyen d'allumer ou éteindre le clavier…

    je fais partie des 1% qui galèrent pour trouver une solution alors ;)
    je sais qu'on est peu nombreux à avoir des Toshiba sous Linux et avec un clavier rétroéclairé on est encore moins nombreux, mais les peu de posts que j'ai vu, ont jamais été résolu, ou la personne n'a jamais donné la réponse, du coup on reste à chercher partout sans y arriver..

    c'est dommage de savoir qu'un raccourci fonctionne sous w$ et pas sous Linux, c'est la seule chose que je regrette de w$, et je pense que la solution pour y arriver doit vraiment être complexe.. :(

    Comment être insensible face à cette cruauté envers les animaux :'(

  • # À tenter

    Posté par . Évalué à 2 (+1/-0).

    depuis ce site

    Peux tu faire
    ls /sys/class/leds

    et

    cat /sys/class/leds/toshiba::illumination/brightness

    et nous donner le résultat de chaque commande.

    Sur le lien fourni, JeremyB semble avoir réussi avec la commande:

    echo 1 | sudo tee /sys/class/leds/toshiba::illumination/brightness pour l'éclairage

    echo 0 | sudo tee /sys/class/leds/toshiba::illumination/brightness pour l'extinction

    • [^] # Re: À tenter

      Posté par . Évalué à 1 (+0/-0). Dernière modification le 28/09/17 à 13:54.

      alors quand je fais
      ls /sys/class/leds

      j'obtiens ceci
      input0::capslock input0::numlock input0::scrolllock phy0-led

      quand je fais
      cat /sys/class/leds/toshiba::illumination/brightness

      ça me dit ça ceci
      cat: '/sys/class/leds/toshiba::illumination/brightness': Aucun fichier ou dossier de ce type

      et forcément les deux commandes que se sert Jeremy B ne fonctionnent pas chez moi, vu que le fichier toshiba::illumination/brightness n'existe pas.

      je peux le créer, mais, je mets quoi dedans.??
      rien je le laisse vide.??

      Comment être insensible face à cette cruauté envers les animaux :'(

      • [^] # Re: À tenter

        Posté par . Évalué à 1 (+0/-0).

        phy0-led semble être un répertoire. Peux-tu le lister avec cette commande?

        ls -la /sys/class/leds/phy0-led/

        Regarde aussi si tu as la possibilité d'installer fnfxd qui semble être le paquet qui gère l'ACPI et les touches de fonction (Fn) pour les laptops Toshiba

        • [^] # Re: À tenter

          Posté par . Évalué à 1 (+0/-0).

          alors pour le retour de
          ls -la /sys/class/leds/phy0-led/

          ça me dit ceci
          total 0
          drwxr-xr-x 3 root root 0 sept. 28 18:55 .
          drwxr-xr-x 3 root root 0 sept. 28 18:54 ..
          -rw-r--r-- 1 root root 4096 sept. 28 18:55 brightness
          lrwxrwxrwx 1 root root 0 sept. 28 18:55 device -> ../../../0000:08:00.0
          -r--r--r-- 1 root root 4096 sept. 28 18:55 max_brightness
          drwxr-xr-x 2 root root 0 sept. 28 18:55 power
          lrwxrwxrwx 1 root root 0 sept. 28 18:54 subsystem -> ../../../../../../class/leds
          -rw-r--r-- 1 root root 4096 sept. 28 18:55 trigger
          -rw-r--r-- 1 root root 4096 sept. 28 18:54 uevent

          à en croire les fichiers et dossiers, c'est en rapport avec la luminosité de l'écran, ou je me trompe.??

          et le paquet fnfxd, il est introuvable dans Synaptic, et en cherchant à cette adresse
          https://packages.debian.org/sid/utils/fnfxd
          si tu regardes en bas de page, c'est un paquet pour les architectures en 32bits.
          je l'ai téléchargé quand même et j'ai tenté de l'installé avec dpkg, mais ça me dit que l'architecture n'est pas la même donc impossible de l'installer…

          Comment être insensible face à cette cruauté envers les animaux :'(

          • [^] # On continue

            Posté par . Évalué à 1 (+0/-0).

            Que te réponds
            grep ^CONFIG_ACPI_TOSHIBA /boot/config-$(uname -r)

            lsmod|grep toshiba_acpi

            • [^] # Re: On continue

              Posté par . Évalué à 1 (+0/-0).

              alors la commande
              grep CONFIG_ACPI_TOSHIBA /boot/config-$(uname -r)

              me renvoie ceci
              CONFIG_ACPI_TOSHIBA=m

              et la commande
              lsmod|grep toshiba_acpi

              me donne ça comme résultat
              toshiba_acpi 45056 0
              industrialio 65536 1 toshiba_acpi
              sparse_keymap 16384 1 toshiba_acpi
              rfkill 24576 5 toshiba_bluetooth,toshiba_acpi,cfg80211
              wmi 16384 1 toshiba_acpi
              video 40960 2 toshiba_acpi,i915

              voilà voilà, si ça te parle, merci de ton aide en tout cas ;)

              Comment être insensible face à cette cruauté envers les animaux :'(

              • [^] # Re: On continue

                Posté par . Évalué à 1 (+0/-0).

                Ça me parle!

                Ça nous montre que ton noyau Linux a bien chargé les modules nécessaires pour ton laptop, en particulier l'ACPI.
                Par contre, je ne vois aucun module qui semble concerner le rétro-éclairage de ton clavier (sparse_keymap correspond aux fonctions avec la touche Fn). J'ai un peu de temps aujourd'hui, je vais regarder de plus prés sur mon laptop MSI comment c'est géré…

                • [^] # Re: On continue

                  Posté par . Évalué à 1 (+0/-0).

                  Oui ça donne l'impression que les modules pour le rétroéclairage du clavier n'existent pas.
                  Peut-être que le modèle de mon pc est pas pris en charge par le kernel pour ce qui est du rétroéclairage.

                  Parce que par exemple le.raccourci Fn+F4 qui permet d'activer ou désactiver le touchpad ne fonctionne pas sous Linux.
                  C'est pas handicapant je me sers de touchpad-indicator.

                  Mais le logiciel Toshiba function key utility sous w$ gerait le rétroéclairage du clavier et le touchpad, les deux sont liés visiblement.

                  Comment être insensible face à cette cruauté envers les animaux :'(

                  • [^] # Re: On continue

                    Posté par . Évalué à 1 (+0/-0).

                    Salut Mélissa,

                    J'ai regardé sur mon MSI, le rétro-éclairage du clavier fonctionne avec des blobs (binaires propriétaires). Le reste du système ne ressemble pas du tout au différentes réponses que tu as déjà donné. Malheureusement, ton problème semble aller bien au delà de mes compétences. Peut-être quelqu'un d'autre ici. Si je puis te conseiller d'envoyer le retour de la commande dmesg, ceci donnera des infos complémentaires à plus compétent que moi.

                    • [^] # Re: On continue

                      Posté par . Évalué à 1 (+0/-0).

                      cc désolé pour la réponse tardive, débordée par le boulot.
                      c'est gentil quand même d'avoir essayé de m'aider merci ;)
                      à mon avis Toshiba a configuré le rétro-éclairage pour qu'il fonctionne uniquement avec le logiciel Toshiba Function Key Utility, donc uniquement sous w$.
                      peut-être pour ça la présence de l'option du rétroéclairage dans le bios, pour les OS alternatifs..

                      j'envoies le retour de dmesg dès que j'ai finis mon taf sur Archlinux.
                      j'y mets dans un lien externe, j'arrive pas à faire fonctionner les balises codes sur le fofo, je comprends pas pourquoi :/

                      Comment être insensible face à cette cruauté envers les animaux :'(

                      • [^] # Re: On continue

                        Posté par . Évalué à 1 (+0/-0).

                        voilà le dmesg complet de Debian Sid.
                        tout frais de maintenant
                        je mets le lien de pastebin, vu que les balises codes fonctionnent pas avec moi, enfin que je sais pas faire je pense plutot…..

                        https://pastebin.com/raw/20xmta13

                        bonne lecture :p

                        Comment être insensible face à cette cruauté envers les animaux :'(

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.