Forum Linux.debian/ubuntu installation de qgis : problème de paquets garder en état

Posté par . Licence CC by-sa
Tags :
0
5
oct.
2017

Salut, je suis sur Debian 9 je veux installer QGIS (un logiciel de SIG)

1 j'ai ajouté les sources à ma sources.list
2 j'ai fait un update
3 j'ai lancé l'installation et voici le résultat :
apt install qgis python-qgis qgis-plugin-grass
Lecture des listes de paquets… Fait
Construction de l'arbre des dépendances

Lecture des informations d'état… Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
python-qgis : Dépend: python-qt4-sql mais il n'est pas installable
Dépend: python-qgis-common (= 1:2.18.13+13jessie) mais ne sera pas installé
Dépend: python-psycopg2 mais il n'est pas installable
Dépend: python-qscintilla2 mais il n'est pas installable
Dépend: python-jinja2 mais il n'est pas installable
Dépend: python-pyproj mais il n'est pas installable
Dépend: python-pyspatialite mais il n'est pas installable
Dépend: python-owslib mais il n'est pas installable
Dépend: libqgispython2.18.13 mais ne sera pas installé
Dépend: libfcgi0ldbl mais il n'est pas installable
Dépend: libgdal1h (>= 1.8.0) mais il n'est pas installable
Dépend: libgeos-c1 (>= 3.4.2) mais il n'est pas installable
Dépend: libproj0 (>= 4.8.0) mais il n'est pas installable
Dépend: libqgis-analysis2.18.13 mais ne sera pas installé
Dépend: libqgis-core2.18.13 mais ne sera pas installé
Dépend: libqgis-gui2.18.13 mais ne sera pas installé
Dépend: libqgis-networkanalysis2.18.13 mais ne sera pas installé
Dépend: libqgis-server2.18.13 mais ne sera pas installé
Dépend: libqscintilla2-11 mais il n'est pas installable
Dépend: libqwt6 mais il n'est pas installable
Dépend: libspatialindex3 (>= 1.8.1) mais il n'est pas installable
Dépend: libspatialite5 (>= 2.4.0) mais il n'est pas installable
Dépend: sip-api-11.1 mais il n'est pas installable
Recommande: liblwgeom-dev mais il n'est pas installable
qgis : Dépend: libgdal1h (>= 1.8.0) mais il n'est pas installable
Dépend: libgeos-c1 (>= 3.4.2) mais il n'est pas installable
Dépend: libgsl0ldbl (>= 1.9) mais il n'est pas installable
Dépend: libproj0 (>= 4.8.0) mais il n'est pas installable
Dépend: libqgis-analysis2.18.13 mais ne sera pas installé
Dépend: libqgis-app2.18.13 mais ne sera pas installé
Dépend: libqgis-core2.18.13 mais ne sera pas installé
Dépend: libqgis-gui2.18.13 mais ne sera pas installé
Dépend: libqgis-networkanalysis2.18.13 mais ne sera pas installé
Dépend: libqscintilla2-11 mais il n'est pas installable
Dépend: libqwt6 mais il n'est pas installable
Dépend: libspatialindex3 (>= 1.8.1) mais il n'est pas installable
Dépend: libspatialite5 (>= 2.4.0) mais il n'est pas installable
Dépend: qgis-providers (= 1:2.18.13+13jessie) mais ne sera pas installé
Dépend: qgis-common (= 1:2.18.13+13jessie) mais ne sera pas installé
Recommande: qgis-provider-grass mais ne sera pas installé
qgis-plugin-grass : Dépend: qgis-provider-grass (= 1:2.18.13+13jessie) mais ne sera pas installé
Dépend: libgdal1h (>= 1.8.0) mais il n'est pas installable
Dépend: libgeos-c1 (>= 3.4.2) mais il n'est pas installable
Dépend: libproj0 (>= 4.8.0) mais il n'est pas installable
Dépend: libqgis-analysis2.18.13 mais ne sera pas installé
Dépend: libqgis-app2.18.13 mais ne sera pas installé
Dépend: libqgis-core2.18.13 mais ne sera pas installé
Dépend: libqgis-gui2.18.13 mais ne sera pas installé
Dépend: libqgisgrass6-2.18.13 mais ne sera pas installé
Dépend: libqscintilla2-11 mais il n'est pas installable
Dépend: libqwt6 mais il n'est pas installable
Dépend: libspatialindex3 (>= 1.8.1) mais il n'est pas installable
Dépend: libspatialite5 (>= 2.4.0) mais il n'est pas installable
Dépend: grass-core mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

J'ai aussi essayé avec synaptique, même erreur. S'il vous plaît aidez moi

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.