Forum Linux.debian/ubuntu La souris virtuelle (Maj+NumLock) ne marche plus dans wheezy

Posté par .
Tags : aucun
1
5
juil.
2012

Il y a quelques jours, j'ai mis à jour ma Debian de squeeze vers wheezy. J'ai alors constaté que Maj+NumLock n'active plus la souris virtuelle (déplacer le curseur et cliquer avec le pavé numérique). Google ne m'aide pas sur ce coup.

J'ai des problèmes de dos, donc je passe une partie de la journée bloqué dans un lit. Du coup j'ai besoin de cette fonctionnalité pour être un peu productif. J'utilise principalement le clavier (sans-fil) pour contrôler l'ordi, mais j'ai besoin de la souris virtuelle pour le copier/coller, les fenêtres de préférences et d'autres trucs du même ordre.

Mon système a été installé avec potato et mis à jour depuis. Peut-être qu'il y a un fichier quelque part qui ne devrait pas être là (bien que je purge régulièrement les paquets supprimés).

Mon WM est sawfish. J'utilise une keymap bépo personnalisée (dvorak français). Je l'active à partir de .xinitrc (au passage, chez moi .xsession est un lien symbolique vers .xinitrc). J'ai testé en commentant cette ligne, Maj+NumLock ne fait toujours rien. De plus, autant que je sache les touches Maj ou NumLock ne sont pas redéfinies dans la keymap bépo.

J'ai testé avec kde et la keymap azerty : ah, ça marche. J'ai testé avec kde et la keymap bépo, ça marche également. Donc apparement, ça ne vient pas du bépo.

J'ai aussi testé dans kdm : ça ne marche pas. Auparavant, la souris virtuelle fonctionnait n'importe où dans X, même dans kdm.

J'ai fait mes tests en me loggant sous kdm, et aussi en exécutant startx depuis la console. Dans tous les cas, ça ne marche pas sous sawfish et ça fonctionne sous kde.

Au début, j'ai pensé que la souris virtuelle a été désactivée/supprimée dans Xorg, et réactivée/réimplémentée dans kde. Puis j'ai demandé de l'aide sur la mailing-list Debian User French, et quelqu'un m'a dit qu'il utilise aussi sawfish en wheezy, et ça marche pour lui… Deux autres personnes ont confirmé que chez eux ça marche dans kdm et kde. En dehors de cette info, personne n'a pu m'aider.

J'ai posté un rapport de bug :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=679613
mais je n'ai pas eu de réponse pour l'instant.

Sur la suggestion de reportbug, j'ai mis à jour le paquet xorg, et aussi tous les paquets dont le nom contient xorg, vers leur version sid. Rien n'a changé, la souris virtuelle ne fonctionne toujours pas.

Quelqu'un aurait-il une idée de ce qui pourrait poser problème sur ma machine ? Le raccourci a changé ? Il faut configurer quelque chose quelque part ? Il faut installer un paquet supplémentaire ?

Merci pour toute info :)

  • # wheezy en stable ? depuis quand ?

    Posté par . Évalué à -2.

    bon, un commentaire sans utilité, si ce n'est pour dire que c'est ce qui arrive quand on joue avec les versions de test.

    sauf si wheezy est maintenant la branche stable, auquel cas, je n'ai pas vu passer la depeche.

    • [^] # Re: wheezy en stable ? depuis quand ?

      Posté par . Évalué à 6.

      Eh bien, heureusement que certains jouent avec les versions de tests pour faire des rapports de bug. C'est même ce qui est demandé par toutes les distributions.

    • [^] # Re: wheezy en stable ? depuis quand ?

      Posté par . Évalué à 2.

      c'est ce qui arrive quand on joue avec les versions de test

      1/ Je n'ai pas eu le choix : ma machine est tombée en rade, donc j'ai dû changer de matériel. Et il fallait un noyau et un xorg récents pour le support des cartes graphique et réseau intégrées.

      2/ Même si depuis un moment j'ai tendance à rester en stable pour me simplifier la vie (je peux pas rester des masses de temps devant l'ordi), je n'ai pas indiqué que je /voulais/ être en stable. Je préfère testing pour une machine de bureau, à condition d'avoir un minimum de temps pour jouer avec reportbug / le cache d'apt / la version sid en cas de soucis.

      3/ Comme l'indique Axone, il faut bien que certains utilisent les versions de test. Sinon, le processus de test lui-même perdrait une bonne partie de son intérêt. Au final, ce seraient les utilisateurs de stable qui deviendraient les testeurs ;-)

      Bon sinon, y'a pas grand monde qui utilise la souris virtuelle de Xorg, apparement :-/

  • # Réparé

    Posté par . Évalué à 3.

    En cherchant « xorg shift numlock » (plutôt que « xorg wheezy virtual mouse », qui ne m'avait donné aucune piste), j'ai trouvé une solution à mon problème. Et j'ai appris que les anglophones appellent ça « mouse keys ».

    En fait freedesktop a décidé de supprimer cette fonction par défaut. Et debconf ne m'a pas prévenu… et du coup je pige pas pourquoi ça marchait sous kdm et sous sawfish chez certains utilisateurs de la ML Debian User French. Mystère et boule de gomme.

    Pour la réactiver j'ai mis ça dans xorg.conf :

    Section "InputClass"
    Identifier "Keyboard Defaults"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "fr"
    Option "XkbVariant" "bepo7"
    Option "XkbOptions" "keypad:pointerkeys,terminate:ctrl_alt_bksp"
    EndSection

    Je vais leur demander de mettre un message dans debconf, comme pour la suppression de Ctrl Alt Backspace.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.