Forum Linux.debian/ubuntu lancer un script au démarrage (ok) et écriture hfs+ versatile

Posté par . Licence CC by-sa
Tags : aucun
1
25
oct.
2013

Bonjour :). J'ai un petit soucis pour lancer un script au démarrage sur mon ubuntu. C'est un petit script d'une mini-ligne que voici :

#!/bin/bash
xmodmap ~/.xmodmap

Il inverse avec succès les touches ctrl et cmd de mon clavier (cette méthode est donnée sur la page de doc ubuntu macbook pro 7.1). Sauf que j'aimerai ne pas avoir à le lancer manuellement à chaque démarrage. Ok je n'ai qu'à double-cliquer dessus, oui, je suis un peu paresseuse. Mais c'est le boulot d'un ordi de faire les choses automatiquement non ^ ?

Ce que j'ai déjà essayé :
_claquer le fichier script dans l'application qui gère les applications au démarrage
_claquer la ligne de commande dans l'application qui gère les applications au démarrage
_claquer le script dans /etc/init.d
_claquer le script dans ~/.config/autostart
_je ne sais plus j'ai l'impression d'avoir essayé tant de choses -.-

Je comprends vraiment pas ce qui ne fonctionne pas :/.

(je suis un peu novice, si vous avez des conseils, essayez d'être explicites au possible :/)

  • # syntaxe

    Posté par . Évalué à 4. Dernière modification le 25/10/13 à 16:40.

    je crois que pour mettre ce script dans les applications au demarrage de ta session graphique,
    il faut le mettre dans ~/.config/autostart,
    mais y a un formalisme a respecter

    exemple chez moi le lancement d'orca est géré par un fichier qui s'appelle
    orca.desktop
    et qui contient

    [Desktop Entry]
    Type=Application
    Name=Orca screen reader
    Exec=orca --enable speech,braille
    NoDisplay=false
    AutostartCondition=GSettings org.gnome.desktop.a11y.applications screen-reader-enabled
    X-GNOME-AutoRestart=true
    #X-GNOME-Autostart-Phase=Initialization
    OnlyShowIn=GNOME;Unity;
    X-Ubuntu-Gettext-Domain=orca
    X-GNOME-Autostart-enabled=false

    dans ton cas il faudrait faire un fichier similaire, par exemple xmodmap.desktop, eventuellement simplifié, mais qui contiendrait :

    [Desktop Entry]
    Type=Application
    Name=Ma correction de clavier
    Exec=xmodmap ~/.xmodmap
    NoDisplay=false
    OnlyShowIn=GNOME;Unity;
    X-GNOME-Autostart-enabled=true
  • # Avec l'outil "applications au démarrage"

    Posté par . Évalué à -1. Dernière modification le 26/10/13 à 15:41.

    Salut,

    Quand tu dis que tu as essayé ça :
    _claquer le fichier script dans l'application qui gère les applications au démarrage
    Si tu parles du machin que tu trouves en haut à droite puis "applications au démarrage", bah ça devrait marcher, en tout cas chez moi ça marche. Précisément, qu'as tu fait ? Est-ce que ton script dispose bien des droits d'execution ? (Je suppose que oui). Et quelle est la commande que tu as tenté d'inscrire ?

    Supposons que ton script s'appelle mapchange.sh et qu'il soit dans un dossier /home/nomutilisateur/scripts. Ce qu'il faut que tu fasses :
    1) Donner des droits d'execution à ton script : dans un terminal, tu fais

    chmod +x /home/nomutilisateur/scripts/mapchange.sh
    

    (Ou sinon, avec l'explorateur de fichiers, clic droit, propriétés, tu coches les droits d'execution)

    Si c'est bon, depuis un terminal, une fois dans ton dossier scripts, si tu fais

    ./mapchange.sh
    

    Ça devrait executer le script.

    2) Dans le machin des applications au démarrage, tu fais Ajouter, puis parcourir, tu choisis ton script, tu donnes un nom, le tour est joué.


    Je viens de tester chez moi, avec ça comme script :

    #!/bin/bash
    
    touch /home/moi/scripts-etc/cboncamarche.youpi
    

    Qui crée à chaque démarrage un fichier cboncamarche.youpi. Ben ça marche.

  • # victory

    Posté par . Évalué à -1.

    Il semblerai que ça ai marché. J'ai essayé les deux méthodes ici proposée (la deuxième en désespoir de cause, ayant déjà essayé plusieurs fois) et miracle, ça marche. J'ai l'impression que cet ordi est un peu versatile (hier il ne voulait plus écrire dans le hfs+, ce matin, ça lui est passé), il y a des choses que j'ai du mal à expliquer :/. Il doit être contrarié d'avoir un os inconnu dans le bide.
    Merci pour l'aide :).

    • [^] # Re: victory

      Posté par . Évalué à 0. Dernière modification le 26/10/13 à 18:01.

      EN parlant de l’écriture hfs +, ça vient de recommencer, pas moyen d'enregistrer quoi que ce soit, il me raconte que le système de fichier est en écriture simple (je veux bien l'entendre mon grand, lui dis-je, mais tu écrivais dedans y'a 2 heures, tu va pas me la faire.)

      Si vous avez une idée …

      Les trois paquets/drivers hfs sont installés, la partition n'est pas journalisé, ça n'est pas un problème de permissions et ça marche parfaitement ou pas du tout. J'ai pas encore compris ce qui faisait switcher entre l'état all-good et l'état tout-bugué-nan-j'écrirai-pas … Je suis absolument désespérée …

      • [^] # Re: victory

        Posté par . Évalué à 2.

        parfois les partitions ont comme option remount=ro qui force la partition à se remonter en lecture seule si y a des erreurs sur le disque.

        du coup ca marche un moment, puis y a des erreurs, hop, ca repasse en lecture seule.

        faudrait regarder dans les logs de ta distribution si tu as une trace d'evenements liés à ton disque dur.

        • [^] # Re: victory

          Posté par . Évalué à 0. Dernière modification le 26/10/13 à 20:15.

          Ah, on a un debut d'explication pour le hop çamarchepu. J'ai hâte qu'on trop le hop ça marche ;).
          Quand tu dis les log de ma distrib, c'est ce qu'il y a dans /var/log ?
          Voilà les noms des fichiers que j'y ai trouvé :

          cecile@Alfred:/var$ cd log
          cecile@Alfred:/var/log$ ls
          alternatives.log
          dmesg.1.gz
          samba
          ankama-dbus-transition_23-10-13-2325.log
          dmesg.2.gz
          speech-dispatcher
          apport.log
          dmesg.3.gz
          syslog
          apport.log.1
          dmesg.4.gz
          syslog.1
          apport.log.2.gz
          dpkg.log
          syslog.2.gz
          apport.log.3.gz                           
          faillog           
          syslog.3.gz
          apt                                       
          fontconfig.log    
          udev
          auth.log                                  
          fsck              
          ufw.log
          boot                                      
          gdm               
          unattended-upgrades
          boot.log                                  
          hp                
          upstart
          bootstrap.log                             
          installer        
          wtmp
          btmp                                      
          kern.log          
          Xorg.0.log
          ConsoleKit                                
          lastlog           
          Xorg.0.log.old
          cups                                      
          mail.err          
          Xorg.1.log
          dist-upgrade                              
          mail.log          
          Xorg.1.log.old
          dmesg                                     
          news
          dmesg.0                                   
          pm-powersave.log

          La partition problématique s’appelle sac (sinon c'est /dev/sda3 de ce que j'ai compris), j'ai peine à trouver le rapport. Je ne suis peut être pas au bon endroit.

          Bon, en tout cas, actuellement l'écriture remarche mais j'aimerai bien trouver une solution qui dure :). Ce remount=ro est il indispensable à la sécurité ou on peut le désactiver et supprimer ce problème sans faire tout sauter é.è ?

          • [^] # Re: victory

            Posté par . Évalué à 2.

            pour savoir quel disque il faut surveiller, c'est la commande mount ou df -h qui va te dire quelle partition est montée et ou.

            ensuite c'est bien dans /var/log qu'il faut chercher,
            mais il faut ouvrir le fichier messages.log ou syslog

            • [^] # Re: victory

              Posté par . Évalué à 0.

              Je n'ai pas trouvé de messages.log dans mon repertoire, en revanche, voilà ce qu'il y avait en rapport avec /dev/sda3 dans le fichier syslog :

              Oct 26 17:41:55 Alfred udisksd[1684]: Cleaning up mount point /media/cecile/sac (device 8:3 is not mounted)
              Oct 26 17:41:55 Alfred udisksd[1684]: Unmounted /dev/sda3 on behalf of uid 1000
              Oct 26 17:41:57 Alfred kernel: [ 2781.501837] hfs: Filesystem was not cleanly unmounted, running fsck.hfsplus is recommended. mounting read-only.
              Oct 26 17:41:57 Alfred udisksd[1684]: Mounted /dev/sda3 at /media/cecile/sac on behalf of uid 1000
              Oct 26 17:42:02 Alfred udisksd[1684]: Cleaning up mount point /media/cecile/sac (device 8:3 is not mounted)
              Oct 26 17:42:02 Alfred udisksd[1684]: Unmounted /dev/sda3 on behalf of uid 1000
              Oct 26 17:42:03 Alfred kernel: [ 2788.177021] hfs: Filesystem was not cleanly unmounted, running fsck.hfsplus is recommended. mounting read-only.
              Oct 26 17:42:03 Alfred udisksd[1684]: Mounted /dev/sda3 at /media/cecile/sac on behalf of uid 1000
              Oct 26 17:42:29 Alfred kernel: [ 2813.563708] hfs: write access to a journaled filesystem is not supported, use the force option at your own risk, mounting read-only.
              Oct 26 17:42:29 Alfred udisksd[1684]: Mounted /dev/sda2 at /media/cecile/apple on behalf of uid 1000
              Oct 26 17:42:33 Alfred udisksd[1684]: Cleaning up mount point /media/cecile/apple (device 8:2 is not mounted)
              Oct 26 17:42:33 Alfred udisksd[1684]: Unmounted /dev/sda2 on behalf of uid 1000

              Je pense que ça retrace le moment où je l'ai monté/démonté à une ou deux reprises dans l'espoir que ça change quelque chose.

              Concernant la partition, c'est donc le sac, alias /dev/sda3 (/dev/sda3, c'est la partition de macosx, je me moque un peu de ne pas pouvoir écrire dedans), le point de montage c'est /media/cecile/sac.

              • [^] # Re: victory

                Posté par . Évalué à 2.

                je vois surtout des "unmounted" suivi d'un mount mais il considere que le disque n'est pas propre

                Oct 26 17:41:57 Alfred kernel: [ 2781.501837] hfs: Filesystem was not cleanly unmounted , running fsck.hfsplus is recommended. mounting read-only.

                tu as aussi

                Oct 26 17:42:29 Alfred kernel: [ 2813.563708] hfs: write access to a journaled filesystem is not supported , use the force option at your own risk, mounting read-only.

                donc faut verifier si tu as un systeme HFS journalisé sur ton OSX, supprimer eventuellement la journalisation,
                ou peut-etre lui dire de ne pas monter cette partition.

                apparement tu as 2 partitions sur le disque
                /dev/sda3 -> sac
                /dev/sda2 -> apple

                • [^] # Re: victory

                  Posté par . Évalué à 0. Dernière modification le 26/10/13 à 23:00.

                  Comme je le disais, la partition apple est celle d'osx. Mon disque est coupé en 3. Une partition pour ubuntu, une partition pour osx et une partition de stockage, le sac.
                  la partition d'osx, apple (dev/sda2 donc) est en hfs+ journalisé. Je n'ai pas l'intention d'écrire dessus depuis ubuntu donc on s'en moque. La partition sac (/dev/sda3) est en hfs+ non journalisé, parce que je veux pouvoir écrire dedans depuis ubuntu et que ce dernier a du mal avec le hfs journalisé.

                  Y'a une solution à tout ça :/ ? C'est vraiment très épisodique, parfois pas le moindre soucis, parfois impossible d'écrire dans la partition sac. Par quel moyen je peux rendre la partition sac définitivement "propre" aux yeux d'ubuntu et virer ce petit machin radom ?

                  (je viens de relire les messages des logs, lorsque ça parle de journalisation c'est à propos de la partition apple. Donc pas la peine de s'en occuper)

                  • [^] # Re: victory

                    Posté par . Évalué à 2.

                    pour la partition SAC, ca te dit que le system de fichier n'a pas été ejecté proprement.

                    quand tu passes d'OSX à Linux, tu le fais par un reboot ? un arret complet et un demarrage à froid ?
                    car passé un temps on avait un probleme similaire avec un dualboot windows/linux ou windows ne faisait pas un vrai arret mais plutot une mise en veille prolongée.

                    du coup le disque n'etait pas "propre" au demarrage de linux

                    • [^] # Re: victory

                      Posté par . Évalué à 0. Dernière modification le 26/10/13 à 23:45.

                      Pour passer de l'un à l'autre j'utilise "redémarrer" plutôt que "éteindre". Es ce que utiliser "éteindre" puis rallumer soi même corrigerai le problème ? Ou bien il faut que je m'assure de démonter le sac avant de redémarrer ?

                      • [^] # Re: victory

                        Posté par . Évalué à 2.

                        je penses qu'il n'y a pas 50 manieres de faire, donc à toi les essais :

                        • le redemarrage comme tu le fais actuellement => lecture seule aleatoire
                        • demonter le volume avant le redemarrage => ???
                        • faire un arret complet puis un boot vers linux => ???
                        • demonter avant l'arret complet puis le boot vers linux => ???

                        dis nous ce qui marche le mieux.

                        • [^] # Re: victory

                          Posté par . Évalué à 0.

                          Eh bien, pour le premier essai (éteindre puis rallumer au lieu de redémarrer), chat marche :). Je vous tiens au courant !

                          • [^] # Re: victory

                            Posté par . Évalué à 0.

                            Je ne rencontre plus de problème depuis :). Merci beaucoup !

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.