Forum Linux.debian/ubuntu Partage de fichiers

Posté par . Licence CC by-sa
Tags : aucun
0
17
juil.
2017

Bonjour les linuxiens !

J'ai un petit soucis que j’espère que vous pourrez résoudre.

Je m'explique, j'ai deux machines un pc portable sur W10 et une machine linux sur base Debian.

Je voulais sur mon réseau local instaurer un partage de fichier pour cela sur la machine linux j'ai configurer un serveur samba jusque la pas de soucis, j'ai bien accès aux dossiers partager sur linux depuis ma machine W10 .

Par contre je n'arrive pas à accéder à l'inverse depuis ma machine linux aux dossiers partager de W10, ça me demande éternellement un ID, un domaine, un MDP. j'ai tout essayer cela ne correspond jamais impossible d’accéder aux fichiers.

Je précise que j'ai tout les droits d'administration sur les machines.

quelqu'un as une idée ?

Cordialement

  • # cifs-utils

    Posté par . Évalué à 1 (+0/-0).

    Bonjour,

    Le paquet cifs-utils fournit des utilitaires pour monter les montages samba depuis w10 vers debian, dans ton dépot habituel…

    Par défaut, le domaine doit-être WORKGROUP (le domaine par défaut de windows), l'utilisateur le proprio du partage.

    Bon courage !

    • [^] # Re: cifs-utils

      Posté par . Évalué à 1 (+0/-0).

      le paquet est bien installer j'ai déjà tenter de mettre login Admin domaine WORKGROUP (j'ai bien fait attention à la casse) et en mdp le mdp qui est fournis lorsqu'on fait un reseau de partage par windows rien a faire ca me refuse l'acces il me redemande les logs… d'où mon problème

  • # Utilisateur SAMBA créé comme il faut ?

    Posté par . Évalué à 1 (+0/-0).

    Hello,

    Si je ne me trompe pas, disons que sur ton windows tu aies un compte "toto" et sur ton linux également un compte "toto", il faut que tu créés en plus ce compte toto dans SAMBA via l'utilitaire smbpassword ce lien pourra t'aider si c'est bien ce problème.
    Tu me diras si c'est bien ça ?

    Julien_c'est_bien (y'a pas que Seb)

    • [^] # Re: Utilisateur SAMBA créé comme il faut ?

      Posté par . Évalué à 1 (+0/-0).

      merci de ta reponse apparement non ce n'est pas ca :/

      de plus impossible de creer un compte nommer admin avec smbpasswd
      retour de la console: Failed to add entry for user admin…

      • [^] # Re: Utilisateur SAMBA créé comme il faut ?

        Posté par . Évalué à 1 (+0/-0).

        Tu peux essayer de monter le dossier à la main en faisant un
        mount -t smbfs -o username="utilisateur",password="mdp" //nom-netbios_ou-adresse-IP/nom-du-partage /le-point/de-montage/linux" dans un terminal ça te donneras certainement un message plus explicite pour faire tes recherches par la suite.

        Julien_c'est_bien (y'a pas que Seb)

        • [^] # Re: Utilisateur SAMBA créé comme il faut ?

          Posté par . Évalué à 1 (+0/-0).

          mount -t cifs -o username="admin",password="Fh7H7Vg2gt" //192.168.1.14/Vidéos/ /root/partage/
          ```réponse du terminal
              Mount error (13): Permission denied
              Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
          
          Mot de passe et utilisateurs sont correct...
          je ne vois pas 
          
          • [^] # Re: Utilisateur SAMBA créé comme il faut ?

            Posté par . Évalué à 1 (+0/-0).

            … quelques bonnes pratiques:

            • Monter les dossiers distants dans le dossier /media
            sudo mkdir /media/partage
            sudo mount -t cifs -o username=foo,password=bar,domain=WORKGROUP //192.168.1.14/Videos /media/partage

            Le dossier media sert à ça !

            L'utilisateur qui fait le mount a le droit d'écrire dans ton dossier ?

            Courage !

            • [^] # Re: Utilisateur SAMBA créé comme il faut ?

              Posté par . Évalué à 1 (+0/-0).

              Même message d'erreur,

              Je détient les deux machines chez moi je suis administrateurs des deux machines aussi sur l'une comme sur l'autre j'aimerai configurer les droits d’écriture lecture et modifications enfin droits total de faire ce que je veux depuis les machines.

          • [^] # Re: Utilisateur SAMBA créé comme il faut ?

            Posté par . Évalué à 1 (+0/-0).

            En effet il faut s'assurer que l'utilisateur à bien les droits nécessaires.

            Dans ce forum, il est indiqué de spécifier les nom de domaine ou si pas de domaines, le nom de la machine comme ça :

            Most of people got this Permission Denied access when mounting a
            Windows Shared folder

            following mounting ->

            usually : mount -t cifs /// /mnt/Shared -o username=,password=
            give you error 13.

            correct : mount -t cifs /// /mnt/Shared -o username=/,password=

            Yes! the only deference is "domain name:" is missing. In case of No Domain try to put your there.
            cifs does not locate domain itself (I guess).

            Julien_c'est_bien (y'a pas que Seb)

  • # Nouvelle idée, nouveau sujet !

    Posté par . Évalué à 1 (+0/-0).

    Est-ce que tu peux démarrer sur une distribution live (via un CD ou une clé USB) et tenter de te connecter à ton partage de cette manière.

    Ça permettra de voir d'où vient le problème. Si ça persiste depuis un live, ça voudra dire qu'il faut chercher du côté de Windows, si ça marche, ça voudra dire qu'il faut chercher du côté de Linux et de ta configuration de Samba.

    Julien_c'est_bien (y'a pas que Seb)

    • [^] # Solution

      Posté par . Évalué à 1 (+0/-0).

      Problème résolu en me documentant beaucoup sur internet je me suis rendu compte que contrairement a windows pour le coup Linux a un problème au niveau de la case.

      Je m'explique:
      Ma session de mon PC se nomme admin et mon ordinateur DESKTOP-Admin

      probleme sous Linux il a falut que je note pour monter mes fichiers DESKTOP-ADMIN Linux desire tout en majuscules par contre la bizarrerie est pouraquoi cela ne fonctionnais pas en notant l'ip local du PC

      • [^] # Re: Solution

        Posté par . Évalué à 1 (+0/-0).

        Merci pour le retour, je n'y ai pas pensé et je n'aurais jamais été cherché de ce côté (pourtant la casse c'est classique que ça pose des problèmes).
        En effet, c'est bizarre que ça n'ait pas fonctionné avec l'IP.

        Julien_c'est_bien (y'a pas que Seb)

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.