Forum Linux.debian/ubuntu Présence aléatoire des disques durs

Posté par . Licence CC by-sa
Tags : aucun
1
29
oct.
2014

Bonjour à tous !
Je me présente: Je suis un vieil amateur d'informatique (75 balais !)
Sur ma machine (un PC de bureau) j'utilise Win 7 sur son propre D.D. et Ubuntu, lui aussi sur son propre D.D.
Je boot donc sur l'un ou l'autre à l'invite du Grub.
Tout ça fonctionne bien sauf que parfois mes D.D. sont absents de la barre du lanceur d'Ubuntu.
J'ai donc plusieurs D.D.:
Un disque de 500 Go sur Sata 1 (sdb2 chez Ubuntu) pour Win 7
Un disque de 500 Go sur SATA 4 (sdc) pour mes médias.
Un Disque de 320 Go sur IDE (sda1) pour Ubuntu
Un disque externe de 1 To USB (sdd1) pour les sauvegardes
Un lecteur-graveur ATAPI
Voila pour le Hard.
Au lancement, le BIOS reconnaît tout le monde et, parfois le lancement d'Ubuntu est très long. Dans ce cas lorsque l'OS est chargé, aucun de mes disques n'est présent dans le lanceur.
Par contre si je lance l'outil "Disques" d'Ubuntu ils sont bien reconnus.
Je n'ai pas ce pb. sous Win.
Il suffit alors de rebooter et il se peut qu'ils apparaissent….
Curious isn't it ?
Ce n'est pas la cata, mais c'est gênant.
J'ai posté sur deux forums dont celui d'Ubuntu sans réponses.
Auriez vous un avis.
Merci.

  • # IDE+SATA

    Posté par . Évalué à 1.

    Le problème vient sûrement du disque IDE qui empêche le bon fonctionnement du SATA ( déjà rencontrer ),
    débranche le pour voir ci le problème persiste.

    Il y a peut être une mise a jour du bios a faire avec PRUDENCE.

    Merci aux personnes qui mon aidé a trouvé des solutions pour essayer d’écrire sans faute d’orthographe.

    • [^] # Re: IDE+SATA

      Posté par . Évalué à 1.

      Hello,
      Ubuntu étant sur IDE, si il débranche IDE, il débranche Ubuntu et ne peut donc démarrer sous Ubuntu, ors c'est là que se situe le problème si j'ai bien compris.

      Diamant40, le problème de DD non visible se présente uniquement qu'en cas de démarrage long ?
      Est-ce qu'Ubuntu procède à une vérification des disques dur dans ce cas ?

      Julien_c'est_bien (y'a pas que Seb)

  • # Linux peux être bavard, si besoins

    Posté par . Évalué à 1.

    Bonjour,

    Il faudrait localiser le probleme.

    -Au niveau de grub: modifier la config de grub pour avoir des logs

    -Lors du demarrage avec l'initramfs: il est aussi possible d'avoir des logs, par option ou configuration et update-initramfs -u

    -lors du démarrage de ta distribution, voir les log dans /var/log. Il est aussi possible d'avoir des logs supplementaire en mettant des options de demarrage au niveau grub

    et dmesg te donne-t-il des infos pertinante ?

    Tient nous au courant

  • # en effet

    Posté par . Évalué à 1.

    J'ai rencontré un problème similaire il y a 3 ans sur mon pc, mais je ne retrouve plus le lien source de la solution…

    En gros, lorsque du SATA et de l'IDE se mélangent sur la carte mère, Ubuntu (ou grub ?) re-numérote les disques à chaque boot: une fois tu auras le disque sata1 nommé sdb, une autre fois sda, etc.

    Si tu déclares les partitions à monter au démarrage dans fstab en utilisant "/dev/sda1/", il ne retrouvera pas nécessairement le bon disque et ne montera rien du tout. Il faut dans ce cas utiliser le uuid du disque à la place de son nom sdX.

    (désolé de ne pas savoir être plus complet, mais ça devrait déjà au moins te mettre sur la bonne piste)

    L'acacia acajou de l'académie acoustique est acquitté de ses acrobaties. Tout le reste prend "acc".

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.