Forum Linux.debian/ubuntu [Resolu] no-ip et ubuntu server 12.04

Posté par .
1
29
mai
2012

Bonjour tous !

expert impatient, passe ton chemin, tu as sous le yeux un post de noob en qwerty…

je me suis installe un ubuntu server 12.04 en LAMP, installe owncloud dessus via apt-get, teste en reseau local, tout nickel.

la prochaine etape etait simple: mettre no-ip dessus et ouvrir le port sur le routeur.

et c'est la que ca coince: le paquet n'existe plus semble-t-il…que ce soit no-ip ou noip2.

Ca parait simple, yaka telecharger depuis le site de no-ip avec wget (comme quoi, j'ai fait mes recherches), cependant j'ai 2 soucis:

  • j'ai la vague impression que les DNS ne sont pas configures sur ce serveur, et quand je veux editer le fichier /etc/resolv.conf , il est bien note en grand que les changements ne seront pas retenus => que faire ? // sous-probleme: mettre des dns externes, mais alors, il ne se reconnaitra peut-etre plus lui-meme ?
  • pas encore cherche vu que pas encore arrive a cette etape, mais au mieux, je vais me retrouver avec un fichier .tar.gz une fois mon telechargement accompli, si vous pouvez me souffler les commandes pour decompresser et installer…

avec tous mes remerciements pour votre lecture, et votre reponse.

EDIT 31/05/2012: la solution definitive aux probleme de noip2 sous 12.04: sudo apt-get install ddclient :0)

  • # pas de rapport

    Posté par . Évalué à 3.

    j'ai la vague impression que les DNS ne sont pas configures sur ce serveur, et quand je veux editer le fichier /etc/resolv.conf , il est bien note en grand que les changements ne seront pas retenus => que faire ? // sous-probleme: mettre des dns externes, mais alors, il ne se reconnaitra peut-etre plus lui-meme ?

    le /etc/resolv.conf c'est pour que ta machine sache quels serveurs interroger pour ses requetes DNS

    en l'occurence il est rempli lorsque ta machine obtient son IP de ta box, avec surement les DNS de ton FAI

    no-ip c'est pour que quelqu'un en dehors de chez toi puisse venir sur ta connexion internet se connecter à ton serveur

    mais tu peux aussi regarder pour prendre un nom de domaine chez un registrar (ovh, gandi, 1&1, etc), ca va te couter 7euros par an, et tu n'auras plus besoin du client no-ip (sauf si tu es chez un FAI qui change on IP regulierement, et meme ca, je crois que certains regitrar savent le gerer)

    pas encore cherche vu que pas encore arrive a cette etape, mais au mieux, je vais me retrouver avec un fichier .tar.gz une fois mon telechargement accompli, si vous pouvez me souffler les commandes pour decompresser et installer…

    un .tar.gz (ou .tgz) se decompresse en faisant
    tar zxvf lefichier.tar.gz

    ca va te sortir le contenu de l'archive avec les sous-dossiers.

    souvent y a un fichier README ou INSTALL qui explique comment ensuite faire l'installation et la configuration.

    • [^] # Re: pas de rapport

      Posté par . Évalué à 1.

      merci pour les pistes

      j'ai mis une ip fixe afin d'etre coherent avec le role de serveur de la machine, hop, plus de dhcp…
      le client no-ip m'est effectivement necessaire car ma bbox Belge ne gere pas de dyndns en interne, et mon adresse ip change toutes les 36 heures

      j'avance un rien: j'ai quand meme mis 2 lignes nameserver dans resolv.conf, hop, j'ai pu telecharger le client no-ip. Si j'ai bien lu un peu partout, ce parametre sera ecrase au prochain reboot du serveur, donc j'ai tente un chattr +i sur resolv.conf, mais erreur: operation non supportee lors de la lecture des drapeaux sur /etc/resolv.conf

      j'ai maintenant mon fichier de no-ip, je vais donc bouquiner les divers readme et install, et petit a petit me rendre independant de windows… Allez, j'ai reussi ma transition pour le desktop (xubuntu depuis 1 an, avec 2 upgrades de version sans couilles entretemps), je vais bien reussir pour les serveurs :0)

      Peut-etre a dans 1/2h… ou demain soir si Madame en a marre de me voir devant mes ecrans.

      Bonne soiree !

      L'acacia acajou de l'académie acoustique est acquitté de ses acrobaties. Tout le reste prend "acc".

      • [^] # Re: pas de rapport

        Posté par . Évalué à 2.

        j'ai mis une ip fixe afin d'etre coherent avec le role de serveur de la machine, […} j'ai quand meme mis 2 lignes nameserver dans resolv.conf, hop, j'ai pu telecharger le client no-ip. Si j'ai bien lu un peu partout, ce parametre sera ecrase au prochain reboot du serveur,

        => Non, vu que ta machine est en IP fixe, et que tu as desinstallé le client dhcp, le fichier /etc/resolv.conf ne sera pas modifié lors du reboot (facile à verifier, suffit de rebooter le serveur ;) )

        • [^] # Re: pas de rapport

          Posté par . Évalué à -1.

          aurais-je rate une option lors de l'installation ?

          j'ai installe bind9, puis configure les forwarder, et ensuite j'ai pu modifier resolv.conf vers moi-meme et c'est maintenant fonctionnel, je suis fier !

          L'acacia acajou de l'académie acoustique est acquitté de ses acrobaties. Tout le reste prend "acc".

          • [^] # Re: pas de rapport

            Posté par . Évalué à 4.

            si tu installes bind9 sur la machine, tu n'as meme plus besoin de dyndns puisque elle fait elle meme DNS.

            Elle connait donc tondomaine.com et peut le resoudre.
            pour les domaines qu'elle ne connait pas, elle envoie sa demande aux forwarders.

            par contre, je ne pourrais pas venir sur ta machine avec son nom car les DNS du reste du monde n'ont pas connaissance de ton domaine.

            • [^] # Re: pas de rapport

              Posté par . Évalué à 0.

              bon, la suite…

              j'ai donc internet sur ce serveur, j'ai pu telecharger les sources du no-ip, make et make install (ils ne faisaient pas mention d'un configure avant dans le readme)

              ensuite, quand je tape "sudo noip2 -C", ca me cree bien un fichier de config.

              je peux ensuite executer noip2, et ca fonctionne.

              je redemarre le serveur, et la, rien. noip2 ne demarre pas tout seul.

              "Diantre !" me dis-je. Et commence la longue fouille pour trouver le pourquoi…

              je trouve que ca doit apparaitre dans /etc/rc2.d/ sous la forme de S20noip2, or je n'ai rien. Je cree donc un lien de ce nom vers /etc/init.d/noip2 tel que je l'ai lu sur d'autre forums. reboot => tjs rien…

              "Diable !" - la tension monte d'un cran, mais je me resaisis vite. Tiens, con, il n'y a pas de fichier noip2 dans etc/init.d et je le copie donc direct dedans.
              Au reboot suivant, j'ai bien le temps de voir qu'il y a un message d'erreur a son sujet, mais pas le temps de le lire qu'il passe a l'ecran de logon. Et bien sur, toujours pas de noip active seul.

              "Pu*** !" - fallait qu'il sorte… Mais maintenant ?
              - comment voir le message d'erreur lors du boot ? ou se toruverait le fichier log du demarrage ?
              - le binaire noip2, il est ou en fait apres le make install ? celui que j'ai copie dans init.d etait fourni dans le fichier tar.gz de base (d'ou l'absence d'un .configure a effectuer ?)
              - je dois trouver un moyen de faire un "sudo noip2" via mon lien present dans rc2.d ?

              c'est juste con pour les noobs comme moi que le apt-get ne trouve pas encore le paquet dans les depots de 12.04, je suis sur que ca aurait ete tout seul…

              Yen a bien un qui va me lacher mauvaise distro, change de distro ? :0)
              c'est ptet idiot, mais je place mes espoirs sur xubuntu pour le desktop et ubuntu server pour le reste afin "prouver" a mon entourage que c'est viable, sur, et tellement bien… C'est pas le moment de changer.

              L'acacia acajou de l'académie acoustique est acquitté de ses acrobaties. Tout le reste prend "acc".

              • [^] # Re: pas de rapport

                Posté par . Évalué à 0.

                se connecter en root : sudo su
                Creer le script ( noip2 ) suivant sous : /etc/init.d (faire un chmod +x noip2)
                puis cd /etc/rc2.d;ln -s ../init.d/noip2 S20noip2

                #! /bin/sh
                # . /etc/rc.d/init.d/functions  # décommentez/modifiez vers killproc
                case "$1" in
                    start)
                    echo "Démarrage de noip2."
                    /usr/local/bin/noip2
                    ;;
                    stop)
                    echo -n "Arrêt de noip2."
                    killproc -TERM /usr/local/bin/noip2
                    ;;
                    *)
                    echo "Usage: $0 {start|stop}"
                    exit 1
                esac
                exit 0
                
                
                • [^] # Re: pas de rapport

                  Posté par . Évalué à 2.

                  Creer le script ( noip2 ) suivant sous : /etc/init.d (faire un chmod +x noip2)

                  oui

                  puis cd /etc/rc2.d;ln -s ../init.d/noip2 S20noip2

                  par contre y a plus simple que de creer les liens à la main :

                  update-rc.d noip2 defaults

                  pour activer noip2 dans les niveaux par defaut au demarrage et à l'arret de la machine
                  ca va te renvoyer les messages suivants :

                  update-rc.d noip2 defaults
                  Adding system startup for /etc/init.d/noip2 …
                  /etc/rc0.d/K20noip2 -> ../init.d/noip2
                  /etc/rc1.d/K20noip2 -> ../init.d/noip2
                  /etc/rc6.d/K20noip2 -> ../init.d/noip2
                  /etc/rc2.d/S20noip2 -> ../init.d/noip2
                  /etc/rc3.d/S20noip2 -> ../init.d/noip2
                  /etc/rc4.d/S20noip2 -> ../init.d/noip2
                  /etc/rc5.d/S20noip2 -> ../init.d/noip2

  • # Perl

    Posté par (page perso) . Évalué à 2.

    http://fanal.fr/

    J'ai écrit ça pour un besoin pro.
    Depuis personne d'autre ne l'a utilisé :)

    • [^] # Re: Perl

      Posté par . Évalué à 0.

      Merci pour le lien, je vais ptet finir par abandonner ce foutu noip2, mais en meme temps, j'ai tellement l'impression d'etre pas loin de la solution…

      L'acacia acajou de l'académie acoustique est acquitté de ses acrobaties. Tout le reste prend "acc".

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.