Forum Linux.débutant Read only

Posté par . Licence CC by-sa
Tags : aucun
2
3
déc.
2013

Linuxien hyper débutant, je dois utiliser linux pour la première fois afin d'accéder à l'ordinateur de mon fils décédé.Pour passer outre le mot de passe Windows, je dois changer le mode du fichier Utilman.exe afin de le renommer.
Je ne trouve rien sur le web ou alors les solutions proposées ne marchent pas.
J'utilise bien chmod 777 Utilman.exe mais il ne se passe rien. Y a-t-il des espaces à respecter ? des slash ou crochets à placer ?
Merci pour votre aide.
Jean-Claude

  • # Quel est le message d'erreur ?

    Posté par (page perso) . Évalué à 3.

    Bonjour,
    la syntaxe est correcte, il faut donc plus d'informations sur le problème final.
    «Il ne se passe rien» signifie généralement sous linux «tout s'est bien passé» en faisant la commande 'ls -l' vous devriez voir une ligne qui ressemble à :
    -rwxrwxrwx […] Utilman.exe

    rwxrwxrwx signifie 777, tout le monde a tous les droits sur le fichiers. r-------- signifie 400 où il n'y a qu'un accès lecture seule, il faut donc toutes les lettres pour être sûr que la commande est passée.

    pour le renommer, il suffit de faire une commande du genre :
    mv Utilman.exe Utilman.old

    • [^] # Re: Quel est le message d'erreur ?

      Posté par . Évalué à 2.

      message d'erreur : changing permissions of "Utilman.exe": Read-only file system
      j'avais déjà utilisé ls -l : sa réponse invariable : -r------- 2 root root 1402880

  • # Consultez

    Posté par (page perso) . Évalué à 6.

    Remplacer un mot de passe Windows est une opération faisable, mais non triviale, surtout pour un novice en unixeries. Et ce n'est probablement pas la méthode la plus simple pour accéder aux données contenues sur l'ordinateur.

    Je vous conseillerais donc plutôt de consulter quelqu'un qui connaisse ce genre d'opération. Je sais qu'il existe des experts pour ce genre de tâches, mais un simple libriste habitué devrait pouvoir le faire : si vous avez un groupe d'utilisateurs de GNU/Linux dans votre région, je vous conseille de vous adresser à eux.

  • # Renommage

    Posté par (page perso) . Évalué à 3.

    Pour info, renommer un fichier ne nécessite aucun droit sur ce fichier, mais seulement un droit d'écriture sur le répertoire où il se trouve. Et ce n'est faisable que si le système de fichier est monté en lecture-écriture.

    • [^] # Re: Renommage

      Posté par . Évalué à 1.

      OK
      D'après mes recherches monter (que je ne comprends pas bien) ou remonter un répertoire serait une commande du type mount :
      voici celle que j'ai déjà utilisé :
      mount -o remount,rw /dev/sda1
      je ne sais pas si j'atteins le bon répertoire qui est Windows/System32
      Merci

      • [^] # Re: Renommage

        Posté par . Évalué à 2.

        j'ai fait cette manipulation sur une disque contenant un windows 8. En regardant sur Internet, on voit que la manipulation est la meme sur W7. Il s'agit de remplacer utilman.exe par command.exe ; on prendra soin avant de faire cette manipulation de faire une sauvegarde du (des) fichiers. Voici les commandes à passer (modulo les majuscules éventuelles sur les noms de fichiers) ; pour cela on peut monter soit booter sur une clé USB Linux, soit monter la partition Windows via une autre machine.

        # montage 
        mount /dev/sdaX /mnt 
        
        # atteindre le bon répertoire :
        cd /mnt/Window/System32
        
        # faire un backup du fichier qui va être écrasé
        cp Utilman.exe Utilman.exe.sav
        
        # remplacer par "le terminal Windows"
        cp Cmd.exe Utilman.exe
        
        # démonter le disque :
        cd / ; umount /mnt
        
        # reboot ou arret, c'est selon
        init 0
        

        pour le reste, a voir sur les sites dédiés à Windows. Salutations.

  • # erreur d'enoncé

    Posté par . Évalué à 6.

    Pour passer outre le mot de passe Windows,

    depuis linux tu accedes à l'ensemble du disque windows, tu n'as donc plus besoin de ce mot de passe pour en copier le contenu

    je dois changer le mode du fichier Utilman.exe afin de le renommer.

    je fais du windows et du linux depuis des années, je ne savais pas qu'il suffisait de renommer utilman.exe
    pour qu'il n'y ait plus besoin de mot de passe pour utiliser le windows.

    je dois me faire vieux ;)

    • [^] # Re: erreur d'enoncé

      Posté par . Évalué à 1.

      D'après mes recherches, Utilman est ensuite remplacé par cmd.exe et en relançant Windows on se retrouve en mode initial et on redonne un nouveau mot de passe. D'après ce que j'ai trouvé sur le net. Mais auparavant il faut renommer Utilman.exe qui est en read only et c'est cela qui ne fonctionne pas.

  • # Chntpw

    Posté par . Évalué à 9.

    Linuxien hyper débutant, je dois utiliser linux pour la première fois afin d'accéder à l'ordinateur de mon fils décédé.

    Je ne pense qu'on ne m'en voudra pas trop de parler au nom du groupe mais nous t'apportons tout notre soutien et notre sympathie dans cette épreuve qui doit être extrêmement difficile.

    Ça fait un bon moment que je n'utilise plus Windows également mais je pense que « chmod 777 utilman.exe » ne peut pas fonctionner. La gestion des droits Windows est différente de celle d'UNIX. Il existe en revanche chntpw (« Change NT Password ») qui est livré de série avec plusieurs distributions (mais qui nécessite peut-être d'installer explicitement le package). Ça permet de déverrouiller les machines Windows récentes et je m'en sers pour débloquer les PC des voisins qui me demandent de l'aide (et depuis que les machines deviennent massivement portable, j'ai collé une Knoppix sur une carte SD et la trimballe dans mon portefeuille).

    Il faut trouver le bon fichier *.SAM en dessous de « C:\Windows » (il ne devrait y en avoir que quelques uns) puis lancer la commande « chntpw -i LeFichierEnQuestion ». L'option « -i » signifie « interactive » : le programme te posera alors une liste de questions et tu n'auras qu'à te laisser guider.

    Bon courage.

    • [^] # Re: Chntpw

      Posté par . Évalué à 3.

      Chntpw est inclus dans le CD bootable systemrecuecd www.sysresccd.org/‎ il n'est pas très difficile à utiliser, mais il faut bien lire les indications à l'écran (en anglais) car de mémoire il y a des trucs pas super intuitifs pour un a-lingue comme moi (du type double négation ou je ne sais plus quoi)

  • # ma procédure

    Posté par . Évalué à 4.

    Pour réinitialiser un mot de passe windows, je fais comme ceci :
    – démarrer avec un live-CD du type systemrescueCD
    – monter le système avec NTFS-3g (sinon c'est en lecture seule) : mount -t ntfs-3g /dev/sda1 /tmp/lol
    – aller dans Windows/System32/config : cd /tmp/lol/Windows/System32/config
    – lancer la commande : chntpw -l SAM (ça doit afficher les utilisateurs
    – lancer : chntpw -u Utilisateur SAM, puis remplacer par un mot de passe vierge quand le programme le demande.
    – démonter la partition : umount /tmp/lol
    – redémarrer, et remettre un mot de passe

    Peut-être que ton erreur Read Only est du au fait que tu montes la partition, mais pas avec ntfs-3g ?

    • [^] # Re: ma procédure

      Posté par . Évalué à 1.

      Parmi tous mes essais, jai utilisé la commande
      mount -t ntfs-3g /dev/sda1
      réponse : can't find /dev/sda1 in /etc/fstab
      j'ai également essayé ensuite
      mount -t ntfs-3g /dev/sda1 /mnt/Windows/System32
      réponse : failed : no such file or directory

      Merci pour votre aide

      • [^] # Re: ma procédure

        Posté par . Évalué à 3.

        pas mal, t'y est presque.

        la commande mount prend un peripherique /dev/sda1
        pour le "monter" dans un dossier /mnt/Windows/System32

        mais le dossier n'existe pas.

        pour creer le dossier
        sudo mkdir /mnt/Windows

        puis pour activer le disque dans le dossier
        sudo mount -t ntfs-3g /dev/sda1 /mnt/Windows

      • [^] # Re: ma procédure

        Posté par . Évalué à 3.

        Re-bonjour,

        mount -t ntfs-3g /dev/sda1
        réponse : can't find /dev/sda1 in /etc/fstab

        Il faut passer à mount deux paramètres : la partition à monter (le /dev) et l'endroit où tu veux la monter. Si tu n'en passes qu'un seul, « mount » va considérer que c'est un volume qu'il est censé déjà connaître et va le chercher dans le fichier /etc/fstab.

        j'ai également essayé ensuite
        mount -t ntfs-3g /dev/sda1 /mnt/Windows/System32
        réponse : failed : no such file or directory

        C'est ça qu'il faut faire mais le répertoire /mnt/Windows/System32 doit probablement ne pas encore exister. À la limite, ne t'embêtes pas trop à respecter le nom exact. Assure-toi que tu travailles en root puis tapes « cd /mnt », puis « mkdir partition », puis « mount /dev/sda1 /mnt/partition ». Pas la peine de spécifier « -t ntfs-3g » car cela sert à indiquer le format de la partition lorsque mount ne parvient pas à le détecter seul (ce qui est une anomalie avec les systèmes de fichiers répandus). Si tu forces le type à utiliser de cette façon, mount va se plaindre si ça ne correspond pas exactement à ce qu'il voit.

        • [^] # Re: ma procédure

          Posté par . Évalué à 1.

          OK, je vais essayer, mais je ne sais pas comment m’assurer que je travaille en root

          • [^] # Re: ma procédure

            Posté par . Évalué à 1.

            J'ai trouvé comment aller en root (réminiscences DOS).
            J'ai effectué la suite de la procédure, malheureusement la dernière commande
            mount /dev/sda& /mnt/partition me renvoie
            Mount is denied becausethe NFST volume is already exclusively opened

            c'était trop beau :(

            • [^] # Re: ma procédure

              Posté par . Évalué à 3.

              ta partition doit être montée quelque part. Tu peux le voir avec la commande « mount », sans argument.

              Dans ce cas, il faudra la démonter (umount /dev/sda), puis refaire la procédure.

              • [^] # Re: ma procédure

                Posté par . Évalué à 2.

                Dans ce cas, il faudra la démonter (umount /dev/sda), puis refaire la procédure.

                Pas forcément : il n'y a qu'à se rendre directement dans le répertoire où elle est déjà montée.

  • # But de la manoeuvre

    Posté par . Évalué à 5.

    Si je comprends bien tu souhaites accéder à l'environnement Windows, et il te manque un mot de passe.

    Linux ne va pas remplacer un mot de passe Windows par rien. Enfin, pas simplement du tout.

    Comme le précise NeoX, tu peux d'ores et déjà (en lecture seule) accéder à l'ensemble des données du disque, sans mot de passe. Et certainement les données que tu souhaites: c'est dans C:\Users[nom de l'utilisateur]\ (ou sous XP C:\Documents and Settings[nom de l'utilisateur] que tu trouveras les documents, images, videos, musiques.

    Je suppose que tu parles d'utilman.exe parce que tu suis ce tutoriel http://tssibrive.over-blog.com/pages/Comment_reinitialiser_un_compte_administrateur_ou_un_mot_de_passe_perdu_sous_Windows_7-4024242.html
    mais en réalité tu fais pire: tu vas créer un nouvel utilisateur qui n'aura pas accès directement aux documents auquels tu souhaites accéder.

  • # MERCI

    Posté par . Évalué à 3.

    Merci à tous, je crois que ça marche.
    A+
    Jean-Claude

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.