Forum Linux.général Corruption graphique avec les drivers ATI

Posté par .
Tags : aucun
3
27
oct.
2009
Bonjour,

depuis longtemps j'ai des soucis avec les drivers ATI libres: lorsque je scroll dans n'importe quelle application, il m'arrive souvent d'avoir de la corruption, qui se traduit par une "ligne" de la fenêtre qui se retrouve sur une autre. Par exemple, dans Konsole, je fais mon travail, je tape une commande et là l'affichage de la commande se met sur la commande précédente, il manque donc un bout de l'affichage. Et le truc c'est que si je scroll un peu dans tous les sens quand ça m'arrive, ça me remet l'affichage correctement...

Ça m'arrive dans toutes les applications, Firefox, Arora, Kopete, Konsole, etc..

Le seul indice que j'ai c'est ces erreurs dans dmesg:
[drm:radeon_cp_indirect] *ERROR* sending pending buffer 14

En cherchant sur Google j'ai pas trouvé grand chose de convaincant, à part des logs IRC qui m'aident pas vraiment.

Je précise que j'ai ce problème avec le driver radeonhd ET radeon. J'ai trouvé le code qui génère l'erreur de dmesg, mais j'y connais rien en drm donc ça m'aide pas.

Si quelqu'un a une idée, ça m'aiderait beaucoup :)
Merci.
  • # Quelle est ta version de X ?

    Posté par . Évalué à 2.

    Moi aussi j'ai eu des problèmes de corruption (surtout dans les applis gtk), jusqu'à ce que je passe à xorg 7.4 (server 1.6). Maintenant j'ai d'autres problèmes (lenteur, config clavier avec bugs aléatoires), mais plus de corruption. Peut-être que xorg 7.5 server 1.7 est encore mieux, mais j'ose pas tester pour l'instant.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.