Forum Linux.général Forcer la résolution d'un écran

Posté par . Licence CC by-sa
Tags : aucun
3
6
juil.
2015

Bonjour,

nous travaillons actuellement avec des écrans HD (1920x1080) sur nos machines.

Nous avons eu des cas où des écrans ne répondaient par sur le canal DDC, résultat un affichage 800x600.

En tapant xrandr, on voit bien que l'écran ne peut que faire du 800x600.

J'ai essayé de forcer la résolution via les commandes classiques xrandr :
- cvt 1920 1080
- xrandr --newmode …
- xrandr --addmode
- xrandr --output … --mode …

Mais rien à faire. Impossible de forcer la résolution.

Un test intéressant est que si je branche un écran qui répond bien, que l'affichage se fait bien en 1920x1080, que je débranche cet écran et branche l'écran défectueux, et bien ce dernier m'affiche bien du 1920x1080. Le problème vient juste de la détection au démarrage du PC via ce fameux canal DDC.

Voilà pourquoi nous essayons de forcer la résolution au moment du .xinitrc

Merci de votre aide
Sylvain

  • # Xorg.0.log

    Posté par (page perso) . Évalué à 2.

    Des infos ?

    Désactiver le module dcc ?

    Système - Réseau - Sécurité Open Source

  • # SAV

    Posté par (page perso) . Évalué à 3.

    Si vos écrans défectueux sont encore sous garantie, c'est peut-être le plus simple (et pérenne).

    Python 3 - Apprendre à programmer en Python avec PyZo et Jupyter Notebook → https://www.dunod.com/sciences-techniques/python-3

    • [^] # Re: SAV

      Posté par . Évalué à 1.

      Sauf que le but ici est de proposé une solution rapide qui permette l'utilisation de la machine en attendant un nouvel écran

  • # Mes deux centimes

    Posté par . Évalué à 2.

    Alors je suis peut-être totalement à côté de la plaque mais j’ai appris il y a peu concernant les câbles DVI qu’il y a des « single link » et des « dual link ». Nos écrans 30 pouces nécessitent un câble dual link (sinon ils sont limités en « résolution ») alors qu’un écran plus petit se contente d’un single link… Tu as bien utilisé un dual link à chaque fois pour tes tests ?

    • [^] # Re: Mes deux centimes

      Posté par . Évalué à 1.

      Ça ne doit pas venir de ça car le single link permet d'envoyer du 1920*1200 à 60Hz (donc plus que le débit demandé).
      D'ailleurs l'écran ne gère probablement pas le dual link (ça couterait plus cher à fabriquer).
      Par contre, un faux-contact sur les fils qui gèrent le DDC est toujours possible.
      Où alors un problème dans l'écran.

      • [^] # Re: Mes deux centimes

        Posté par . Évalué à 1.

        Je pense que le problème vient de la … que la gestion du DDC ne fonctionne plus sur cet écran.

        Je voudrais donc m'affranchir de ce problème

        • [^] # Re: Mes deux centimes

          Posté par . Évalué à 1.

          Sur certains écrans le DDC est désactivable dans le menu de config

    • [^] # Re: Mes deux centimes

      Posté par . Évalué à 1.

      Pas un problème de câble … puisque l'écran fonctionnait très bien avant (bon fonctionnement pendant 1 an)

  • # le KMS c'est bien, ou pas

    Posté par . Évalué à 2.

    ca me fait penser au Kernel Mode Settings
    en gros c'est le noyau qui cause à l'ecran lors du boot pour en determiner la resolution,

    l'option pour desactiver ca serait nomodeset sur la meme ligne que quiet splash

    • [^] # Re: le KMS c'est bien, ou pas

      Posté par . Évalué à 1.

      J'y ai pensé aussi. C'est même la première chose que j'ai fais avant d'essayer xrandr … mais ça change rien.

      J'ai bien essayé aussi de mettre les modes video dans le fichier /etc/X11/xorg.conf

      Mais pas mieux …

  • # Pourquoi Windows y arrive ?

    Posté par . Évalué à 1.

    J'ai testé mon écran avec un PC sous Windows … oui je sais, pas bien.

    Et bien mon Windows 7 arrive très bien à s'afficher en résolution max de 19620x1080.

    j'ai essayé d'autres distribution live avec cet écran, elles crashent toutes au moment du chargement du driver écran.
    Même SystemRescue crashe … c'est que c'est grave.

    Quelqu'un pourrait-il me dire ce que vérifie Linux de plus que Windows ? On va partir du principe que linux fait plus de vérification matériel avant de se lancer.

    Parce que j'ai tout essayé, du "nomodeset", "nofb" ou autre paramètre noyau, et c'est option xorg aussi :
    Option "UseEDID" "False"
    Option "UseEDIDFreqs" "False"
    Option "ExactModeTimingsDVI" "True"
    Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidModes, NoMaxPClkCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoEdidMaxPClkCheck"
    Option "NoLogo" "True"

    Rien ne change

  • # Réussi mais ...

    Posté par . Évalué à 2.

    Bon, j'ai réussi à faire afficher du 1920x1080 à mon écran.

    Pour cela, j'ai pris un écran identique qui fonctionne, j'ai généré avec nvidia-xconfig un fichier edid (edid.bin).

    Ce fichier edid.bin est utilisé dans ma configuration xorg.conf dans la section Device : Option "CustomEDID" "DP-3:/etc/X11/edid.bin"

    Ça à l'air de bien fonctionner, mais ça me plait pas vraiment.

    Je voudrais vraiment imposer une résolution en 1920x1080 (ou 1680x1050 selon type de machine), EDID ou pas EDID.

    Si quelqu'un à une idée de comment je pourrai faire ça ?

    Sinon, je me débrouillerai avec deux fichiers edid.bin selon le type de machine et ça ira bien.

    Mon problème c'est comme si le driver nvidia n'arrivait pas à récupérer les infos EDID de l'écran.

    QUESTION : est-ce que cela peut être dû au driver nvidia lui-même, à Linux ou autre partie soft ?

    Par cette question j'essaie juste de m'assurer que le problème ne vient pas de mon installation.

    Merci
    Sylvain

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.