Forum Linux.général Probleme avec pm-utils

Posté par . Licence CC by-sa
1
3
mar.
2013

Bonjour,
j'ai un phénomène étrange avec pm-utils :
lorsque je mets en veille avec un pm-suspend, tout semble bien se passer, le réveille est ok, et les logs semblent ne rien rapporter d'anormal (sauf se pleindre de l'absence de vbetool [qui n'est pas proposé dans les packages de ma distrib] )
Le problème survient lors d'une deuxième mise en veille : Si je refait appel à pm-suspend (et même à rtcwake avec l'option "ram" ou "disk") sans avoir au préalable redémaré la machine, la mise en veille se bloque sur l'écran noir de la console. Le fichier pm-suspend.log s'arrete au niveau du "Running hook /usr/lib/pm-utils/sleep.d/00powersave suspend suspend:" et le fichier pm-powersave.log s'arrete au niveau de
"Running hook /usr/lib/pm-utils/power.d/journal-commit false:
Setting journal commit time for / to 0…" (je précise qu'il n'y a pas de "Done" à la fin de cette dernière ligne)
Voilà, j'ai donc l'impression qu'on ne peut pas faire 2 fois de suite un "commit time" sur une partition, mais je ne vois pas pourquoi!
Est-ce que quelqu'un aurait une idée? Peut-être que le problème est ailleur?
Merci pour voter aide

  • # pm suspend hybrid

    Posté par . Évalué à 3.

    je n'ai pas de réponse directe à ta question mais j'utilisais pm-hibernate et suite à des soucis sur mon disque, il ne marchait plus.
    depuis, j'utilise pm-suspend-hybrid qui lui fonctionne très bien. à l'exception prêt qu'il se réveille au bout de 10 minute (ventillo) pour se rendormir immédiatement. je crois que c'est le passage du mode ram au mode disque.
    bref, c'est un contournement.

    • [^] # Re: pm suspend hybrid

      Posté par . Évalué à 0.

      Bonjour,
      j'ai donc testé pm-suspend-hybrid avec malheureusement le même effet. En même temps comme son nom l'indique, le mode hybride met d'abord en RAM puis en cas de faible batterie il met en disque (en tout cas, dans mon cas il n'a pas mis sur disque). Et comme mon ordi est sur secteur, l'hybride marche comme ram…
      Par contre, dans la foulé j'ai testé l'hibernate (pas fait jusqu'alors car prend un poil plus de temps à tester que la ram) et là, miracle cela fonctionne.
      Disons que pour l'instant ce sera un "pis- aller"

  • # J’ai eu le même problème, résolu par upgrade du noyau

    Posté par (page perso) . Évalué à 1.

    J’ai eu à une époque semble-t-il le même problème que celui que tu décris, ou un problème présentant les mêmes symptômes : impossible de mettre en veille deux fois d’affilée.

    Le problème a disparu après une mise à jour du noyau. Malheureusement, je serais bien incapable de dire aujourd’hui quelle était la dernière version du noyau à souffrir de ce problème…

    Je recommanderais de tester le dernier noyau en date.

    • [^] # Re: J’ai eu le même problème, résolu par upgrade du noyau

      Posté par . Évalué à 0.

      Je vais tester la piste du noyau que ce soit en downgrade ou upgrade.
      Je vous tiens au courant

    • [^] # Re: J’ai eu le même problème, résolu par upgrade du noyau

      Posté par . Évalué à 1.

      J'ai donc testé les noyaux 3.4.24, 3.7.6 et 3.7.9 (l'actuel de ma machine) sans grands changements. J'ai plus qu'à attendre que le 3.8.2 apparaisse sur ma distrib (Lunar)…

      Pour info, au cas où ce soit pertinent ce même ordi possède une deuxième distrib (mageia 2) avec le noyau 3.4.24 et je n'ai jamais eu de problèmes de ce genre.
      Maintenant il y a peut-être des options du noyau qui n'ont pas été sélectionnée??

      • [^] # Re: J’ai eu le même problème, résolu par upgrade du noyau

        Posté par (page perso) . Évalué à 1.

        Pour info, au cas où ce soit pertinent ce même ordi possède une deuxième distrib (mageia 2) avec le noyau 3.4.24 et je n'ai jamais eu de problèmes de ce genre.
        Maintenant il y a peut-être des options du noyau qui n'ont pas été sélectionnée??

        C’est possible. Si tu veux essayer de comparer la configuration des noyaux, elle est normalement exportée au format texte (compressé) dans /proc/config.gz.

        Comparer la liste des modules chargés dans chaque distribution (avec lsmod) peut aussi être intéressant.

        • [^] # Re: résolu par recompilation du noyau

          Posté par . Évalué à 0.

          Bonjour,
          Désolé, j'ai oublié de revenir sur le site pour indiquer que le problème était résolu.
          J'ai fait plusieurs choses depuis, donc je ne suis pas sûr, mais il me semble bien que c'est en rajoutant l'option CONFIG_DRM_RADEON_KMS au noyau (pour le mode setting sur les cartes vidéos Radeon).

          Merci encore pour l'aide

  • # nvidia ?

    Posté par . Évalué à 1.

    Autre piste : as-tu une carte graphique nvidia?
    Ça remonte (environ 4 ans), mais j'avais le même soucis sur une tour avec ma nvidia gt220/pilote proprio qui se réveillait mal la seconde fois.
    Par contre, je n'avait pas réussi a résoudre le problème.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.