Forum Linux.général Putain de "modernisation" à la con (ou encore: ouvrir un PDF provenant de gouv.fr)

Posté par (page perso) .
20
27
jan.
2012

Bonjour à tous,

J'enrage, je vais acheter une voiture cet après midi, et je voudrais imprimer la fiche CERFA 13754 (sic) pour faire preuve de la cession du véhicule par le vendeur.

https://www.formulaires.modernisation.gouv.fr/gf/showFormulaireSignaletiqueConsulter.do?numCerfa=13754

Surprise, le PDF ne s'ouvre pas correctement sous ma fedora 15, que ce soit avec Chrome ou avec le lecteur intégré à Fedora.
J'ai un vieux message comme quoi Adobe Reader est requis pour lire ce PDF. Certainement une option à la con que celui qui publie ces formulaires a dû cocher sur son logiciel de génération favori, fermé et anticoncurrentiel.

Voilà la super modernisation à la noix (cf ce qui est marqué dans l'URL du fichier...), qui fait que d'ici ce soir je vais devoir annuler la vente si je ne trouve pas un ordinateur windows avec Adobe© Acrobat© Reader©©© 9.0...

Chier.

Quelqu'un connait une solution?

(désolé mais je suis vraiment énervé, serait temps qu'ils embauchent des gens intelligents chez gouv.fr).

  • # Il faut utiliser Adobe Reader 9 pour linux

    Posté par . Évalué à -2.

    • [^] # Re: Il faut utiliser Adobe Reader 9 pour linux

      Posté par . Évalué à 8.

      Et si on n'accepte pas son CLUF, on est un citoyen de seconde zone ?

      Le RGI ça te dit quelque chose ? PDF est normalisé ISO, ce document ne respecte visiblement pas la norme.

      THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

      • [^] # Re: Il faut utiliser Adobe Reader 9 pour linux

        Posté par (page perso) . Évalué à 2.

        PDF est normalisé ISO, ce document ne respecte visiblement pas la norme.

        Toutafé. Il est complétement impensable qu'il existe un bug ou un manque de fonctionnalité dans Chrome ou le lecteur intégré à Fedora (?) qui ne permette pas d'ouvrir certaines variantes d'un fichier respectant les normes. D'après un autre commentaire il s'agirait en fait de fichiers respectant une norme ISO publiée en 2008, ce qui est apparemment trop récent pour certains lecteurs.

        pertinent adj. Approprié : qui se rapporte exactement à ce dont il est question.

    • [^] # Re: Il faut utiliser Adobe Reader 9 pour linux

      Posté par . Évalué à 5.

      sudo dpkg -i AdbeRdr9.4.7-1_i386linux_enu.deb 
      
      dpkg : erreur de traitement de AdbeRdr9.4.7-1_i386linux_enu.deb (--install) :
       l'architecture du paquet (i386) ne correspond pas à celle du système (amd64)
      Des erreurs ont été rencontrées pendant l'exécution :
       AdbeRdr9.4.7-1_i386linux_enu.deb
      
      
      • [^] # Re: Il faut utiliser Adobe Reader 9 pour linux

        Posté par . Évalué à 3.

        sudo dpkg -i AdbeRdr9.4.7-1_i386linux_enu.deb

        dpkg : erreur de traitement de AdbeRdr9.4.7-1_i386linux_enu.deb (--install) :
        l'architecture du paquet (i386) ne correspond pas à celle du système (amd64)
        Des erreurs ont été rencontrées pendant l'exécution :

        ca semble evident mais il faut installer la version qui va avec ton linux.
        parfois c'est meme empaqueté par ta distribution, le paquet pour ubuntu s'appelle acroread

    • [^] # Re: Il faut utiliser Adobe Reader 9 pour linux

      Posté par (page perso) . Évalué à 9.

      Tu as essayé ? Moi oui : même message avec Adobe Reader pour Linux.

      Ces documents ne sont pas du PDF, mais des trucs lisibles uniquement avec Adobe Reader sous Windows.

      • [^] # Re: Il faut utiliser Adobe Reader 9 pour linux

        Posté par . Évalué à 1.

        Oui, j'ai essayé et je confirme que ça marche très bien sur une Mageia 1 avec la version RPM (AdbeRdr9.4.7-1_i486linux_enu.rpm).

        • [^] # Re: Il faut utiliser Adobe Reader 9 pour linux

          Posté par (page perso) . Évalué à 3.

          oui ca marche avec acroread.

          vdm:
          et je suis bien content (dtc oui) d'avoir raqué 190€ (prix complet) pour passer de co-titualire à titulaire principal sur le certificat d'immat. Merci l'administration francaise.

      • [^] # Re: Il faut utiliser Adobe Reader 9 pour linux

        Posté par . Évalué à 1.

        Bon, si je ne me trompe pas tu es sous Debian avec, peut-être, les paquets acroread* en provenance de debian-multimedia.
        Dans ce cas, pour lire ce formulaire, il faut avoir installé le paquet acroread-plugins !

        Sinon, il me semble bien avoir réussi à remplir des formulaires PDF sous evince, mais je peux me tromper (et ici, c'est clair que ça ne marche pas)

        • [^] # Re: Il faut utiliser Adobe Reader 9 pour linux

          Posté par (page perso) . Évalué à 3.

          Sinon, il me semble bien avoir réussi à remplir des formulaires PDF sous evince, mais je peux me tromper (et ici, c'est clair que ça ne marche pas)

          Oui, je confirme que c'est possible. À condition qu'il s'agisse de formulaires PDF, ce que ces documents de l'administration française ne sont pas. Ce sont des machins pour Adobe Reader, mais pas du PDF.

  • # J'ai eu le même problème

    Posté par . Évalué à 2.

    Bonjour, j'ai eu le même problème, je l'ai alors contourné en ouvrant le PDF avec Gimp ou libre office, je sais plus lequel.

    Please do not feed the trolls

    • [^] # Re: J'ai eu le même problème

      Posté par . Évalué à 1.

      Je suis pris d'un gros doute, je me demande si ça n'avait pas fini avec l'ordinateur de môman sous windows

      Please do not feed the trolls

  • # PDF avec des champs modifiables

    Posté par (page perso) . Évalué à -4.

    Bonjour,

    Il me semble qu'il n'y a qu'adobe reader qui permet de lire des pdf où l'on peut remplir des champs. D'où la restriction.

  • # Okular

    Posté par (page perso) . Évalué à 6.

    Si je ne me trompe pas Okular (lecteur pdf de KDE) permet de remplir un formulaire. Il me semble que c'est un des rares à le faire.

    Après il demande d'installer quelques libs un peut lourdes mais c'est toujours mieux qu'un soft proprio pourri.

    ++

    Si tu ne sais pas demande, si tu sais partage !

    • [^] # Re: Okular

      Posté par . Évalué à 6.

      Oui mais il est pas compatible avec leur PDF de merde.

      THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

  • # webmaster

    Posté par (page perso) . Évalué à 8.

    On envoi un mail au webmaster ou au contact de la page. Normalement, dans ce genre de formulaire, on est sensé je pense utiliser des formats de PDF "stable" (1.2, 1.4...).

  • # Même chose

    Posté par (page perso) . Évalué à 3.

    J'ai connu la même chose avec des documents de la commission Européenne. Je ne sais pas si c'était lié mais ces documents étaient à imprimer (car ils devaient être signés) mais généraient certains champs automatiquement et en validaient d'autres.

    « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

  • # En plus...

    Posté par (page perso) . Évalué à 3.

    On dirait qu'aucun des PDF disponibles sur la page que tu viens de donner n'est accessible sans javascript.

  • # Du pas-PDF de merde

    Posté par . Évalué à 2.

    Voyons voir ....

    Déjà, c'est crée avec un truc de chez adobe :

    xmp:CreatorToolAdobe LiveCycle Designer ES 9.0/xmp:CreatorTool

    Et, non content de déjà pas marcher avec un lecteur PDF normal, si on utilise une vielle version d'Adobe Reader, on se prend des messages comme ceux la :

    "This PDF file requires a newer version of Adobe Reader. Press OK to download the latest version or see your system administrator.";

    C'est très rassurant.

    Le reste, c'est un genre de SVG proprio (du XML en tout cas), qui casse pas trois pattes à un canard, et qui n'a pas l'air très utile. NIH, tout ça ....

  • # Version PDF 1.7

    Posté par . Évalué à 9.

    En faite, c'est encore plus con : l'administration génère des PDF 1.7 maintenant (alors que ce qu'elle met dedans marcherais très bien avec une version 1.6) et ce standard là n'est supporté par aucun lecteur sous Linux.

    Et quand on voit l'état d'avancement du projet GNU-PDF qui a comme objectif la gestion du PDF 1.7 : http://www.gnupdf.org/Main_Page...

    • [^] # Re: Version PDF 1.7

      Posté par (page perso) . Évalué à 4.

      Le mainteneur de GNUPdf est un collègue, donc si vous avez des requêtes particulières, je peux transmettre.

    • [^] # Re: Version PDF 1.7

      Posté par . Évalué à 3.

      Ben ouais, mais c'est pas la version 1.7 qui est un standard ISO justement ? Si c'est ça le problème, on va avoir du mal à reprocher à l'administration française de ne pas être interopérable.
      Maintenant, si c'est du 1.7 + une myriade d'extensions proprios, c'est une autre histoire …

    • [^] # Re: Version PDF 1.7

      Posté par (page perso) . Évalué à 3.

      l'administration génère des PDF 1.7 maintenant

      Pour info, la version affichée par Acrobat Reader dernière version (ouvrant correctement le fichier) est 1.6.
      Google Chrome n'arrive toutefois pas non plus à le lire.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.