Forum Linux.général WPA qui ne fonctionne pas.

Posté par . Licence CC by-sa
Tags : aucun
1
5
oct.
2017

Bonjour,

J'essaie de connecter mon PC portable disposant d'une carte Atheros AR9285 à ma box, mais l'échange de la clé pose toujours problème : le mot de passe n'est pas bon.

Je suis sous Debian Stretch, j'ai essayé wicd, network-manager et une configuration à la main via wpasupplicant.

Si je change le type de sécurité sur ma box (WEP ou WPA-TKIP), cela fonctionne mais je suis obligé d'utiliser du WPA TKIP + AES en raison de la compatibilité d'autres matériels.

Les réseaux sont visibles, mais l'authentification ne réussit jamais.

D'où peut venir le problème ? Merci à vous.

  • # conflits et pilotes

    Posté par . Évalué à 2 (+1/-0).

    J'ai une carte AR5416 sur Jessie qui présentait le même problème d'authentification en WPA. C'était pas le premier truc chelou qu'elle me faisait, j'ai eu de gros problèmes de sensibilité et de déconnexions intempestives en passant de Squeeze à Wheezy.

    J'ai cherché longtemps parce que malgré la sortie de dmesg wpasupplicant n'y était absolument pour rien, et j'ai finalement résolu le problème en deux temps : Déjà faire le ménage dans les interfaces réseau et n'en conserver qu'une pour éviter les conflits (j'ai choisi de purger network-manager) puis passer du pilote wext au pilote nl80211 (préférences paramètres avancées dans wicd gtk ou ncurse).
    Le problème a disparu, du moins pour l'instant puisque cette machine n'est pas encore passée à Stretch. Mais j'ai un portable avec une carte AR928x qui n'a aucun problème sur Stretch (install minimale, i3wm et wicd-curse qui roule depuis Wheezy).

    • [^] # Re: conflits et pilotes

      Posté par . Évalué à 1 (+0/-0).

      Ok, je vais essayer ça. :)
      Merci. :)

    • [^] # Re: conflits et pilotes

      Posté par . Évalué à 1 (+0/-0).

      Bon, rien n'a changé.

      J'avais bon espoir ! :(

      • [^] # Re: conflits et pilotes

        Posté par . Évalué à 1 (+0/-0).

        Mince :/
        Au cas où, tu peux réutiliser iw et wpasupplicant en purgeant tous les gestionnaires de connexion.
        Sinon ça te donne aucune erreur ou warning dans dmesg quand tu recherches ath9k, Atheros ou wpa ?

        • [^] # Re: conflits et pilotes

          Posté par . Évalué à 1 (+0/-0).

          Ça me précise que l'interface a été renommée via la nouvelle norme, c'est tout. :)

          Je vais encore faire quelques tentatives.

          • [^] # Re: conflits et pilotes

            Posté par . Évalué à 1 (+0/-0).

            Ah oui c'est léger comme info,
            Ce problème est arrivé quand exactement ? lors de la mise à niveau vers Stretch ou lors d'une simple MÀJ de noyau ?

            Si ça fonctionne sur une installation autre que Debian, sur une Stretch tout fraiche ou une version avec des logiciels plus récents ça peut sans doute se régler à coup de dpkg-reconfigure ou de config systemd.

            • [^] # Re: conflits et pilotes

              Posté par . Évalué à 1 (+0/-0).

              C'est arrivé lorsque j'ai changé la sécurité de ma box pour la faire fonctionner avec ma nouvelle console. :)

              Depuis, impossible de me connecter sur Jessie/Stretch ou Linuxmint (j'ai testé en liveUSB).

              • [^] # Re: conflits et pilotes

                Posté par . Évalué à 1 (+0/-0).

                essaie de vérifier avec un LiveCD de distro hors de la famille Debian (voir même tenter du BSD, on ne sait jamais) ou de voir avec un Live basé sur Sid.
                Si effectivement ça ne fonctionne pas, tu peux tenter avec un Windows (en Live USB) pour voir si c'est le pilote libre ath9k ou si c'est la puce qui plante en WPA2.

                • [^] # Re: conflits et pilotes

                  Posté par . Évalué à 1 (+0/-0).

                  Je me demande si cela ne vient pas d'un mélange du pilote et de la box.

                  Hier, je change la sécurité de la box, je parviens à me connecter.
                  Je réessaie de me connecter aujourd'hui…Rien, nada, ça ne fonctionne pas, même problème.

                  Ça rend dingue. :|

                  • [^] # Re: conflits et pilotes

                    Posté par . Évalué à 1 (+0/-0).

                    C'est possible que les protocoles du routeur soient un poil stricts par rapport au pilote qui est très permissif au niveau réglages. J'ai lu des personnes qui avaient des problèmes avec certains routeurs et pas d'autres.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.