Forum Linux.gentoo compiz-fusion et maximisation des fenetres

Posté par (page perso) .
Tags : aucun
0
8
nov.
2007
Bonjour

J'ai une petite gentoo d'installé avec un compiz-fusion tout neuf (0.6) qui remplace mon beryl et un écran en 1280x1024 couplé à du xfce4 (notez que tout marchait bien avec beryl)
J'ai un problème lorsque je veux maximiser une fenêtre, tout laisse a penser que compiz-fusion se mêle les pinceaux avec les tailles et me maximise la fenêtre comme si mon écran était en 1024x768 (cas de terminaux par exemple), parfois il me les mets en 1280x1024 (cas de FF et TB par exemple), mais des que je clique sur la fenêtre (qui peut déjà avoir le focus) il la passe de fullscreen à "maximiser" 1024x768

Est ce que quelqu'un connais ce bug ou a une idée de comment le résoudre?

Merci de vos réponse
  • # plus d'info

    Posté par (page perso) . Évalué à 1.

    Alors c'est un écran externe sur un portable.

    Sur l'écran du portable (dont la carte graphique est une Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04) dixit lspci) qui tourne en 1204x768 et bien ça marche normalement.

    Je cherche encore mais je comprend pas..

    Au passage xserver 1.1.3 et xorg 7.2
  • # Peut-être ça...

    Posté par . Évalué à 2.

    Salut,
    Je sais pas si ca peut jouer, mais moi dans :
    "General Option" > "Display settings" > j'ai rajouté dans la liste "Produit" ça : 1280x800+0+0 (c'est ma résolution). J'ai aussi la détection des sorties qui est désactivée au-dessus ;)

    @++
    • [^] # Re: Peut-être ça...

      Posté par (page perso) . Évalué à 2.

      Merci, je sais pas si ça viens de ça ou de mes dernière modif mais ça marche.

      J'ai ça maintenant dans mon .config/xfce4/xinitrc

      LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ \
      LD_PRELOAD=/usr/lib/opengl/xorg-x11/lib/libGL.so \
      LIBGL_ALWAYS_INDIRECT=1 \
      INTEL_BATCH=1 \
      compiz --sm-disable --ignore-desktop-hints ccp &
      emerald --replace &
      exec sh /etc/xdg/xfce4/xinitrc


      et ça dans le .xinitrc
      exec startxfce4 # c'est lui qui appel .config/xfce4/xinitrc


      Ha oui donc, je lance le tout avec un bon vieux startx

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.