Forum Linux.gui Session Gnome 3 figée

Posté par . Licence CC by-sa
2
26
juil.
2014

Bonjour,

Régulièrement Gnome 3 fige et ne réponds plus du tout. J'ai vraiment l'impression d'avoir à faire à un screenshot, la souris bouge, le son continue comme si de rien était mais je ne peux cliquer sur rien, le clavier ne produit aucun effet les "hot-corners" sont inopérants également.
alt-F2 n'affiche pas la fenêtre de dialogue. Rien, rien, rien.

Du coup, je fais un ctrl-alt-F2 pour passer en tty2 et après m'être loggué sous mon compte puis via su - je fais un top ou je vois que gnome-shell est gonflé à l'hélium et prends aux alentours de 100% de temps processeur.
J'ai tenté un gnome-shell --replace mais la session graphique étant lancée dans le tty7, j'obtiens une réponse cohérente qui me dit qu'il n'y a pas de session x dans le tty2 et donc ma commande n'est pas interprétée

Si je fait un telinit 2 puis un telinit 5, la session graphique se relance mais recommence très rapidement à occuper 100% du processeur avant que je n'ai eu le temps de faire quoique ce soit.

J'aimerais savoir si je peux faire un gnome-shell --replace du tty2 vers le tty7 ?
Sinon, quelle commande me permettrait de relancer gnome shell depuis un tty ?
Enfin, comment pourrais-je diagnostiquer mon problème ?
J'ai quelques pistes. Ce problème s'est produit la première fois en lançant gedit depuis un terminal-root. Et j'ai l'impression que le terminal-root à une part dans le déclenchement du bug.

Je ne suis pas sur qu'il soit intéressant de faire un rapport de bug car j'ai installé ma Débian il y a bien 2 ans, je suis passé en testing puis il y a 3 mois, je suis repassé en unstable (je l'ai un peu cherché mais au quotidien, ça bouge pas d`un poil, juste ce bug)

Si quelqu'un peut m'aider, je suis preneur !

Debian GNU/Linux testing/unstable
gnome-session 3.12.1

  • # Mmh

    Posté par . Évalué à 4. Dernière modification le 27/07/14 à 00:08.

    Si tu as accès aux tty c'est déjà ça, normalement avec un simple

    service gdm restart

    tu devrais te retrouver devant une session neuve sans rien avoir à faire.

    Pour le coup du bug si tu as du temps tu peux toujours installer une debian dans une VM et tenter de reproduire.

    Edit : Testing est la pire des versions pour les utilisateurs, reste sur stable ou unstable (qui est bien plus stable que testing).

    • [^] # Re: Mmh

      Posté par . Évalué à 3.

      service gdm restart !

      Mais oui ! Qu'ais-je bête !
      Pourquoi je suis allé me compliquer la vie au lieu de tester ça !
      C'est un peu le problème que j'ai avec GNU/Linux, il y a plein d'outils à ma disposition mais je ne sais pas lequel utiliser et encore moins comment les appeler/ils s'appellent.

      Sinon testing c'était un peu hard et ça commençait à générer pas mal de bug. C'était à l'époque ou Gnome 3.8 était dans testing et 3.6 avait introduit pas mal de régressions, du coup c'était intéressant de passer à Gnome 3.8. Ensuite je suis repassé à Unstable (j'ai inversé dans mon précédent message).
      Et en fait maintenant j'ai un mélange des 2 (une Debian Unstable avec des bouts de Testing) et le pire c'est que ça marche bien ! (même si je penses que le bug vient de là - C'est une Debian Chunk)
      Y'a pas à dire Debian c'est hyper robuste.
      Comparativement, avec ma méthode 200% bourrin-qui-fait-n'imp Fedora au bout d'un moment "'a marche p'us"

      Merci pour ta réponse rapide kursus_hc

      Julien_c'est_bien (y'a pas que Seb)

    • [^] # Re: Mmh

      Posté par . Évalué à 2.

      Bim ça me l'a refait !
      Une fois de plus j'étais dans un terminal-administrateur, j'ai voulu faire un shift+page précédent et là c'est le drame ! Affichage figé.
      Dans tty2 un service gdm restart n'a pas résolu le problème. (comportement identique au changement de runlevel)
      Petite différence, en me logguant dans tty2 j'ai fait un top et gnome-shell ne consommait pas spécialement plus que d'habitude.
      Par contre après le service gdm restart, là il a commencé à gonfler.
      J'ai voulu faire un killall xterminal mais il ne trouvait aucun processus (forcément j'aurais dû faire un killall gnome-terminal-server :-))

      Pour info, ce sont les pilotes libres qui sont installés (Vesa)

      J'avais décoché le paramètre recommandé par I M@N dans dconf mais pas relancé ma session, je ne sais pas si ça avait été pris en compte du coup.

      Julien_c'est_bien (y'a pas que Seb)

  • # animations

    Posté par (page perso) . Évalué à 2.

    tu peux aussi essayer de désactiver les animations de gnome-shell via dconf :
    org > gnome > desktop > interface et décocher enable-animations

    wind0w$ suxX, GNU/Linux roxX!

    • [^] # Re: animations

      Posté par . Évalué à 1.

      C'est fait, merci i M@N

      Julien_c'est_bien (y'a pas que Seb)

  • # Pour débloquer gnome-shell (sans rien perdre de la situation)

    Posté par . Évalué à 1.

    Tu passes en tty et tu lances en tant que user un kill -HUP sur le process gnome-shell (on ne perd rien de la situation en cours => c'est comparable au alt-f2 r) :

    ctrl-alt-f1
    {se logger avec le compte utilisateur qui fige}
    killall -HUP gnome-shell
    ctrl-alt-f7

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.