Forum Linux.slackware après installation depuis dvd officiel, pas de boot sur sda1

Posté par .
Tags : aucun
3
11
juil.
2012

Bonjour à tous ici,

Je viens d'installer depuis le dvd officiel la 13.37. L'installation depuis le dvd s'est correctement terminée, mais le disque ne boote pas. J'ai pourtant revérifié avec cfdisk et j'ai bien sda1 bootable.

Dans le Bios, (Carte Mère ASUS P8H 61 M) j'ai modifié la gestion SATA : De IDE j'ai basculé en AHCI mais le résultat est le même.

Le programme d'installation propose de créer une clé usb bootable, ce que j'ai fait. Je ne peux pas non plus booter sur cette clé qui fonctionne bien, elle est visible dans mon explorateur windows.

Vous aurez sans doute compris, et je ne m'en cache pas que je suis débutant. J'espère vos conseils, merci.

  • # oui et ?

    Posté par (page perso) . Évalué à 5.

    qu'est ce que le pc affiche? n'affiche pas ?

    ce serait pas le bootloader qu'est mal configuré  ?

    • [^] # Re: oui et ?

      Posté par . Évalué à 2.

      bonjour,
      Le Pc affiche sèchement "missing OS"

      J'ai relancé le DVD d'install pour avoir accès au Disque dur
      une fois en #root
      mount /dev/sda1 /mnt
      mount /dev/sdaX /mnt
      toutes les partitions sont montées
      j'ai installé Midnight Commander que je connais et que j'utilise comme éditeur de texte
      mc /etc/lilo.conf
      mc ne s'ouvre pas, pourtant j'ai vérifié je l'ai sélectionné dans les pkg
      Je ne peux donc pas éditer lilo.conf
      Comment puis-je accéder à MC?

      Deuxième point que je ne comprends pas : le boot sur clé USB (reconnue dans le BIOS)
      (boot généré par le programme d'install) ne fonctionne pas. j'ai re créé une clé et cette fois ci le programme d'install dit qu'il ne voit pas de matériel USB connecté…
      Merci en tout cas de vos réponses

      • [^] # Re: oui et ?

        Posté par . Évalué à 1. Dernière modification le 11/07/12 à 15:18.

        En fait tu as monté ta partition / sur /mnt (/dev/sda1), n'oublies pas qu'il faut que tu montes également ton /boot si il est une partition différente dans /mnt/boot.
        La commande qu'il te manque pour pouvoir utiliser ton midnight commander et lancer les commandes sur ton système, c'est justement de passer sur ce système que tu viens de monter avec un chroot : chroot /mnt /bin/bash si tu veux lancer un bash dans le chroot.
        Ensuite comme dis tu suis la procédure pour réinstaller ton lilo sur le mbr une fois que tu as contrôlé son fichier de conf et ça devrait rouler.

        Christophe.

      • [^] # Re: oui et ?

        Posté par (page perso) . Évalué à 4.

        Le Pc affiche sèchement "missing OS"

        C'est bien un problème de chargeur de démarrage. Il faut que tu installe ce programme sur le MBR du disque dur. Je crois que la documentation de Slackware est assez claire http://www.slackbook.org/html/booting.html

        « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

      • [^] # Re: oui et ?

        Posté par . Évalué à 2.

        Salut,
        alors déjà je ne monterai pas ma partition dans /mnt parce que c'est un répertoire utilisé par les scripts d'installation. Je ferais :

        mkdir /linux

        mount /dev/sda1 /linux avec sda1 la partition sur laquelle il y a la racine.

        Ensuite cd /linux puis un chroot ./ (pour les options, voir la page man).

        Tu te retrouves sur le linux que tu as installé et tu peux faire un mount -a (pour avoir tout tes partitions montées).

        Maintenant, il va falloir installer/reconfigurer lilo. Pour ça, tu as liloconfig pour réutiliser les scripts de démarrage ou tu peux utiliser ton éditeur de texte favori.

        En espérant que ça t'aide.

  • # Pitste

    Posté par (page perso) . Évalué à 2.

    la dernière fois que j'ai installé une debian net-inst à partir d'une clé usb, pareil ça bootait pas… en fait grub était installé sur la clé. là avec un dvd c'est louche mais ma solution pourrait fonctionner pour toi, booter sur un livecd/live clé et réinstallation de grub sur le disque dur… ça ressemble à ouvrir une console et lancer grub-install /dev/sda… je te laisse chercher ou demander à d'autres pour les détails

    • [^] # Re: Pitste

      Posté par . Évalué à 2.

      La clé que j'utilise est issue du programme d'install de la slack qui propose de créer une clé bootable.
      Je ne sais pas ce qu'est une "live clé"
      mais merci de ce conseil, je vais chercher.

      • [^] # Re: Pitste

        Posté par (page perso) . Évalué à 1.

        live clé c'est un mot que j'ai inventé là, je crois que c'est liveusb le vrai terme ou un truc du genre, c'est comme un live cd mais en utilisant un cd à la place d'une clé.

        Sinon, pour en revenir à ton problème, le message en dessous demandant si t'as installé lilo est plus pertinent

  • # Lilo

    Posté par . Évalué à 2.

    Plop,

    Normalement, l'installateur de la Slack te propose d'installer Lilo, qui est le chargeur de démarrage. Généralement, il suffit de lui dire de s'installer sur le MBR pour que ça marche.

    Est-ce que tu as bien fait cela ?

    GRUB3 will be Elisp serialized as XML jited to JVM running as Eclipse plugin on a Mac running in a virtual PC in a Xen instance on a 286er.

  • # merci

    Posté par . Évalué à 1.

    merci pour toutes vos réponses, je suis à nouveau devant mon pc et je vais me lancer dans les modifs que vous m'avez proposées. Je vous tiens au courant.

  • # facile

    Posté par . Évalué à 2.

    il faut installer le bootloader (grub ou lilo) sur le MBR, dans ton cas /dev/sda
    alors que toi tu l'as installé sur la partition /dev/sda1

    ton bios ne sait pas booter sur une partition, uniquement sur un disque.

  • # Etat des lieux

    Posté par . Évalué à 3.

    Merci infiniment à vous tous
    j'ai suivi vos conseils
    1 mkdir /linux + mount /dev/sda1 /linux + cd /linux + chroot ./
    mais chroot me renvoie msg d'erreur '/bin/sh' no such file or directory ???
    du coup…. je n'ai pas pu passer à l'étape de configuration de LILO.

    J'ai donc opté pour une option radicale qui s'est avérée efficace puisque j'ai pu lancer
    ma première session. J'ai suivi le programme d'installation sur MBR (merci pour ce conseil tout simple), et hop! ça roule.
    Ceci dit la solution a un goût un peu frustrant car je n'ai pas compris ce qui s'est passé.
    Pourquoi la commande chroot n'a pas fonctionné?
    Bref ça n'est pas bien grave, je vais chercher. J'ai été très agréablement surpris pour un premier post de la rapidité, multiplicité, et pertinence de vos interventions diverses.
    MERCI trois fois MERCI

    • [^] # Re: Etat des lieux

      Posté par . Évalué à 2.

      mkdir /linux
      mount /dev/sda1 /linux
      cd /linux
      chroot ./

      j'avoue n'avoir jamais essayé le chroot ./
      je penses que c'est là que ca deconne
      et qu'il aurait fallu faire

      mkdir /linux
      mount /dev/sda1 /linux
      chroot /linux

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.