Forum Linux.slackware Installation Slackware64 sur RAID0 (ICH9R)

Posté par . Licence CC by-sa
Tags : aucun
0
7
avr.
2013

Bonjour,

J'aimerais savoir de quelles commandes as-t-on besoin pour préparer un volume RAID sur controleur intel ICH9R

dmraid ou mdadm ou aucun des 2 ?

Si je n'utilise aucun des 2, je configure mon volume /dev/md126 avec fdisk ou cfdisk avec 3 partitions

/dev/md126p1 8Go pour le SWAP
/dev/md126p2 40Go pour /
/dev/md126p3 20Go pour /home

le soucis c'est lors du lancement du programme setup dans le menu TARGET

il me détecte /dev/sda2 40Go
et /dev/sda3 20Go

?!?

Pourquoi cette confusion de l'installeur ?.

Merci

  • # Gni?

    Posté par (page perso) . Évalué à 3. Dernière modification le 07/04/13 à 12:06.

    le soucis c'est lors du lancement du programme setup dans le menu TARGET

    C'est quoi? Le RAID, c'est soit matériel, et tu prépares tout dans le BIOS, soit logiciel, et tu fais tout avec diskdrake dans Mageia, (ou mdadm si tu aimes souffrir avec Slackware)

    ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # Normal

    Posté par . Évalué à 4.

    Le contrôleur intel ICH9R ce n'est pas du RAID matériel (fake RAID) donc à priori pas reconnu par Linux en l’absence de modules (pilotes) spécifiques (s'ils existent).

    Donc tu oublies les pseudo fonctionnalités RAID de ta carte mère et tu fait du RAID logiciel avec mdam.

    • [^] # Re: Normal

      Posté par (page perso) . Évalué à 4.

      +1, de plus si la carte mère crame ça va être difficile de récuperer les données alors qu'en raid soft ça juste marche…

      Système - Réseau - Sécurité Open Source

      • [^] # Re: Normal

        Posté par (page perso) . Évalué à 2.

        Oui effectivement c'est plus une carte accélératrice raid qu'un contrôleur raid. Par chance intel faisant bien les choses, sous linux il existe un driver natif dans le kernel.

        Donc en gros tu fais ton raid avec mdadm comme un raid soft et tu te préocupe de rien d'autre à part avoir configuré ton raid dans le pseudo bios dédié (mais j'imagine qu'il l'avait déjà fait).

  • # d'accord

    Posté par . Évalué à 0.

    @José
    J'aurais du dire:
    "le soucis c'est dans le menu TARGET du programme setup"
    Pardon.

    @Bruno
    Ok, même le raid de l'ICH9R n'est pas reconnu par presque toutes les distributions ?
    pourtant c'est de l'Intel.

    Bon Ok alors :) je vais faire du raid logiciel …

  • # Raid 0 veut pas

    Posté par . Évalué à -1.

    J'ai fait du Raid 0 logiciel

    En premier j'ai fait mdadm --create … 3 fois, pour chaque partition en raid 0

    puis LILO a refusé de s'installer, une histoire de version metadata 1.2, alors que lilo veux de 0.9

    j'ai refait mdadm --create … 3 fois avec l'option --metadata=0.9

    j'ai tout réinstallé

    et la LILO signale qu'il ne peut s'installer que sur du Raid …. 1 en boot

    Donc a priori Raid 0 en Boot pour la Slackware, c'est pas possible.

    Je sais pas si vous êtes d'accord ?

    • [^] # Re: Raid 0 veut pas

      Posté par . Évalué à 3.

      utilises grub2 plutot que lilo
      il me semble que c'est plus recent et que ca gere mieux les installations raid.

      sinon je ne comprend pas comment tu fais,
      tu as fait 3 partitions par disque qu'ensuite tu assembles 2 par 2 pour faire 3 volumes en raid0 ?
      plutot que de faire un raid0 avec tes 2 disques durs, que tu partitionnerais ensuite en 3,

      si tu decides de faire comme tu as fait, il te suffit juste de ne pas grouper les /boot en raid0
      en les laissant sur chacune des partitions, tu installes lilo uniquement sur le premier de tes disques.
      le deuxieme /boot ne servant à rien

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.