Forum Linux.slackware [RESOLU] comment activer NetworkManager dans VirtuaBox

Posté par . Licence CC by-sa
Tags : aucun
1
10
jan.
2018

Bonjour,
J'ai installé une machine Slackware avec VirtualBox et je n'ai pas de connexion internet.
L’icône de NetworkManager affiche une croix rouge, et une infobulle annonce qu'il n'est pas lancé et que le réseau est désactivé.
Il y a d'autres machines Linux installées, et si j'ouvre par exemple Mint en même temps, cette dernière a une connexion qui fonctionne.
J'ai essayé diverses commandes trouvées sur le net, mais la plupart ne sont pas reconnues (start networkmanager,etc…)
D'autres ont donné des résultats que je ne sais pas interpréter :

    bash-4.3$ /sbin/ifconfig -a
eth1: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 08:00:27:52:7f:18  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 16  bytes 880 (880.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 16  bytes 880 (880.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

bash-4.3$ /sbin/ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 16  bytes 880 (880.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 16  bytes 880 (880.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

bash-4.3$ /sbin/route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
bash-4.3$ cat /etc/resolv.conf
# Generated by dhcpcd from eth0.dhcp
# /etc/resolv.conf.head can replace this line
nameserver 10.0.2.3
# /etc/resolv.conf.tail can replace this line
bash-4.3$ 
    root@slackbox:~# service networking start
-su: service : commande introuvable
root@slackbox:~# allow-hotplug eth0
-su: allow-hotplug : commande introuvable
root@slackbox:~# iface eth0 inet dhcp
-su: iface : commande introuvable
root@slackbox:~# ifdown eth0
-su: ifdown : commande introuvable
root@slackbox:~# /sbin/ifconfig eth0
eth0: error fetching interface information: Device not found
root@slackbox:~# vim /etc/network/interfaces
root@slackbox:~# ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 16  bytes 880 (880.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 16  bytes 880 (880.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

root@slackbox:~# ifconfig -a
eth1: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 08:00:27:52:7f:18  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 16  bytes 880 (880.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 16  bytes 880 (880.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

root@slackbox:~# iface lo inet loopback
-su: iface : commande introuvable
root@slackbox:~# dhclient wlan0
SIOCSIFADDR: No such device
wlan0: ERROR while getting interface flags: No such device
wlan0: ERROR while getting interface flags: No such device
root@slackbox:~# cat /proc/net/dev
Inter-|   Receive                                                |  Transmit
 face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
    lo:     880      16    0    0    0     0          0         0      880      16    0    0    0     0       0          0
  eth1:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
root@slackbox:~# /etc/init.d/networking restart
-su: /etc/init.d/networking: Aucun fichier ou dossier de ce type
root@slackbox:~# # ifconfig -a 
root@slackbox:~# ifconfig -a 
eth1: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 08:00:27:52:7f:18  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 16  bytes 880 (880.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 16  bytes 880 (880.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
root@slackbox:~# start networkmanager
-su: start : commande introuvable
root@slackbox:~# /etc/rc.d/rc.inet1 eth1_start
root@slackbox:~# 

Si j'essaye de voir ce qui se passe depuis l'interface graphique, c'est vide, mais grisé pour ajouter une connexion :

Titre de l'image

Titre de l'image

Merci d'avance pour votre aide

Edit : désolée, je n'ai pas su utiliser les balises, et pas compris ce que sont et comment sont apparus les liens en début de message

  • # network-manager est-il installé?

    Posté par . Évalué à 2 (+0/-0).

    slack est, il me semble, une distrib assez "brute de décoffrage", et du coup je ne serais pas surpris que network-manager ne soit pas installé.

    Apparemment, il te faut utiliser un outil nommé netconfig, je pense que le man te donnera plus d'infos sur comment il marche, parce que le lien que j'ai trouvé est assez… limité, on va dire, dans ses «explications»…

    • [^] # Re: network-manager est-il installé?

      Posté par . Évalué à 1 (+0/-0).

      Bonjour freem,

      NetworkManager doit être installé, sinon il n'y aurait pas cette infobulle je pense.

      Titre de l'image

      • [^] # Re: network-manager est-il installé?

        Posté par . Évalué à 2 (+0/-0).

        non ca c'est l'icone du network-manager-applet
        il faut aussi installer le service network-manager, ou le demarrer (cf la documentation slackware pour demarrer un service qui serait deja installé)

        • [^] # Re: network-manager est-il installé?

          Posté par . Évalué à 1 (+0/-0).

          Ah ok, mais il doit bien y avoir moyen de voir si le service est installé ou non, comme avec Windows j'imagine.
          Tu pourrais me dire comment ?
          S'il est installé, ça doit pas être sorcier de le démarrer, seulement la doc est en anglais, et moi j'ai 3 mots de vocabulaire qui datent du lycée (et en 2ème langue…)
          Alors si tu as un moment pour faire la recherche, ça serait vraiment sympa de ta part.
          Merci beaucoup :)

    • [^] # Re: network-manager est-il installé?

      Posté par (page perso) . Évalué à 5 (+3/-0).

      NetworkManager est inclus dans Slackware et il est installé par défaut, mais pas démarré.

      Pour le démarrer, il faut rendre le script /etc/rc.d/rc.networkmanager exécutable (chmod 755 /etc/rc.d/rc.networkmanager). NetworkManager sera automatiquement lancé au prochain démarrage. Pour le lancer manuellement sans redémarrer, il suffit d’appeler le script avec start.

      Plus rien de spécifique à Slackware après ça : une fois NetworkManager lancé, le réseau peut être configuré via nm ou via l’applet du bureau, comme sur n’importe quelle autre distribution.

      • [^] # Re: network-manager est-il installé?

        Posté par . Évalué à 2 (+1/-0).

        Merciii gouttgd, c'était ça !!!

        Problème résolu, t'es génial, encore merci :)

        Je te souhaite une excellente journée et à une autre fois peut-être pour profiter de tes conseils avisés ;)

  • # Sans le network manager

    Posté par . Évalué à 2 (+0/-0).

    Tu peux faire (en tant que root) :
    ifconfig eth1 192.168.x.y/24
    Avec x = 0 ou 1 ou autre correspondant à ton adresse de réseau que j'imagine commençant par 192.168 mais c'est à toi de voir. et y = 12 si les 11 premières adresses existent déjà… on se comprend ?
    Puis si cette commande ne génère pas d'erreur, tu peux vérifier ce qu'il en est avec ifconfig eth1
    Ensuite teste l'accès à ta passerelle avec la commande ping :
    ping -c 3 192.168.x.z Mêmes hypothèses et z c'est pas au hasard, c'est le dernier octet de l'adresse du routeur. ( -c 3 te permet 3 tentatives et te rend la main)
    Si ça répond quelque chose comme ça, c'est déjà pas mal :
    64 bytes from 192.168.1.254: icmp_seq=1 ttl=64 time=0.1 ms
    Il te faudra alors ajouter cette route par défaut (route add default gw …) syntaxe complète à trouver sur n'importe quel bon moteur de recherche.
    Il ne manque plus que la résolution dns à faire dans le fichier /etc/resolv.conf après avoir testé par exemple ping 8.8.8.8 (ou 192.168.x.z si tu sais qu'il y a aussi un serveur dns en plus de la fonction routage à cette adresse).
    Et pour ne rien perdre au prochain démarrage, c'est bien dans le fichier /etc/network/interfaces mais là aussi, ton moteur de recherche est ton ami.

    • [^] # Re: Sans le network manager

      Posté par . Évalué à 1 (+0/-0).

      Bonjour,

      Pour le X, ça va, j'ai trouvé.
      Pour le Y, j'ai pioché au milieu avec un 5 (au hasard donc), en supposant qu'il s'agit de choisir la prochaine adresse libre, il y a 2 PC connectés au routeur en filaire et celui-ci en wifi (+ mon smartphone).

      Pour le Z, j'ai cherché dans les paramètres réseau de VirtualBox, j'ai mis 1 (après avoir essayé 255 trouvé je ne sais plus où et qui ne donnait rien).

      Titre de l'image

      J'ai rajouté l'adapter 2 hier pour tester si le problème venait de ce côté là.

      Voilà le résultat des commandes.
      Comme tu peux t'en rendre compte, je n'y connais pas grand chose.
      J'ai installé Slackware parce que je dispose d'un bouquin qui me permet d'apprendre les commandes et qui utilise cette distribution.
      Pour d'autres sujets, je poste dans le forum "débutants" mais puisqu'il existe une section dédiée…

      On dirait que ça ne donne pas ce que tu indiques, mais ça répond au moins quelque chose :)

      root@slackbox:~# ifconfig eth1 192.168.247.5
      root@slackbox:~# ifconfig eth1
      eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
              inet 192.168.247.5  netmask 255.255.255.0  broadcast 192.168.247.255
              inet6 fe80::a00:27ff:fe52:7f18  prefixlen 64  scopeid 0x20<link>
              ether 08:00:27:52:7f:18  txqueuelen 1000  (Ethernet)
              RX packets 130  bytes 12425 (12.1 KiB)
              RX errors 0  dropped 0  overruns 0  frame 0
              TX packets 8  bytes 648 (648.0 B)
              TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
      
      root@slackbox:~# ping -c 3 192.168.247.255
      Do you want to ping broadcast? Then -b
      root@slackbox:~# ping -c 3 192.168.247.1
      
      root@slackbox:~# ping -c 3 192.168.247.1
      PING 192.168.247.1 (192.168.247.1) 56(84) bytes of data.
      From 192.168.247.5 icmp_seq=1 Destination Host Unreachable
      From 192.168.247.5 icmp_seq=2 Destination Host Unreachable
      From 192.168.247.5 icmp_seq=3 Destination Host Unreachable
      
      --- 192.168.247.1 ping statistics ---
      3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2001ms
      pipe 3
      root@slackbox:~# 
      

      Pour la suite, ajouter une route par défaut ne me parle vraiment pas :(

      Il ne manque plus que la résolution dns à faire dans le fichier /etc/resolv.conf après avoir testé par exemple ping 8.8.8.8 (ou 192.168.x.z si tu sais qu'il y a aussi un serveur dns en plus de la fonction routage à cette adresse).

      Un serveur dns en plus de la fonction routage à cette adresse, c'est de l’hébreu pour moi.

      Et pour ne rien perdre au prochain démarrage, c'est bien dans le fichier /etc/network/interfaces mais là aussi, ton moteur de recherche est ton ami.

      Ok, c'est dans ce fichier que ça se passe, mais de là à trouver quoi faire, je ne suis pas arrivée…

      J'ai bien conscience d'être un boulet mais si tu pouvais me mâcher encore un peu le travail, je t'en serais très reconnaissante.

      Mille mercis.

      • [^] # Re: Sans le network manager

        Posté par . Évalué à 2 (+0/-0).

        tu fais des choses bien compliqué pour un si petit probleme

        tu es allé creer un autre reseau (192.168.247.x/24) entre ton PC et ta machine virtuelle (slackbox)
        il faut alors que ton PC soit configuré comme un routeur, pour permettre à la slackbox de communiquer avec ta box internet, au travers d'un NAT, etc

        configure simplement ta machine virtuelle avec une carte reseau en mode NAT (cachée automatiquement derriere ton PC)
        au pire en mode BRIDGE (ou PONT en Francais) en selectionnant la carte reseau qui va bien pour ton PC (carte filaire si le PC cause à ta box par le cable RJ45, ou la carte wifi si le PC est en wifi avec la box)

        dans la VM, tu configures le reseau pour fonctionner en mode DHCP, et roule ma poule.
        en mode bridge, la VM sera alors sur le meme reseau que le PC, la box, ton smartphone, etc

        • [^] # Re: Sans le network manager

          Posté par . Évalué à 1 (+0/-0).

          Bonsoir NeoX,

          J'ai crée #Adapter (192.168.247.x/24)2 parce qu'il n'y avait pas de connexion avec celui d'origine (169.254.95.121/16).
          Habituellement je ne vais jamais dans ces paramètres car ça fonctionne dès le départ.
          Je viens de me remettre sur la première carte. Pas encore supprimé la deuxième.

          J'ai essayé de passer en automatique pour voir si ça changeait quelque chose, il y a eu demande de confirmation avec mot de passe, et maintenant je ne peux plus remettre en manuel.

          Dans l'onglet serveur DHCP à côté de celui pour Adapter, on peut voir qu'il est bien activé.

          Titre de l'image

          L'interface réseau est connectée à ma carte wifi aussi, mais rien à faire, pas de connexion, que ça soit en nat ou en pont.

          Titre de l'image

          • [^] # Re: Sans le network manager

            Posté par . Évalué à 2 (+0/-0).

            tu peux virer les 'host-only adapter' ils ne te servent à rien dans ton cas.

            ta VM est bien configurée, en PONT sur ta carte WIFI,
            j'imagines donc que le PC est connecté à ta box via la carte WIFI.

            la VM elle, sera connectée via sa carte reseau "filaire" au travers de ce pont.
            il faut aller lire la documentation slackware pour voir comment configurer la carte reseau en mode DHCP,

            des posts plus haut parlent de l'outil netconf
            à qui tu vas dire que la carte reseau (eth1 d'apres les captures) sera configurée en mode DHCP

      • [^] # Re: Sans le network manager

        Posté par . Évalué à 3 (+0/-0). Dernière modification le 10/01/18 à 22:38.

        Que t’indique la commande ip route ?

        Quelle est la configuration IP (adresse/masque) de ton « hyperviseur » (ie: l’hôte qui fait tourner VirtualBox) ?

        root@slackbox:~# ifconfig eth1 192.168.247.5
        root@slackbox:~# ifconfig eth1
        eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
                inet 192.168.247.5  netmask 255.255.255.0  broadcast 192.168.247.255
        

        Là tu as attribué une adresse manuellement.

        Je ne connais pas Slackware sur le bout des doigts mais la commande pour faire une requête DHCP (pour se voir attribuer une adresse automatiquement) est peut-être dhclient -v eth1, tu peux essayer, au lieu de faire une attribution manuelle. VirtualBox devrait être configuré pour tenir le rôle de serveur DHCP. Il t’attribuera peut-être aussi une route par défaut, parce qu’il t’en faut une… :)

        Le plus simple serait effectivement d’être en mode « bridge ». Ta VM Slackware serait ainsi sur le même réseau que ton hôte VirtualBox. Le mode bridge revient à faire comme si ta VM était directement connectée à ta box. Le mode VLAN (ce que tu tentes de faire) fonctionne lui comme si ton hôte VirtualBox servait d’intermédiaire entre ta box et ta VM. Du coup le second peut être effectivement plus dur à paramétrer, ton hôte (Windows ?) pouvant bloquer sur le passage… et puis tu devras de toutes façon rediriger chaque port que tu souhaites utiliser si tu veux que les VM soient joignables « depuis l’extérieur ». Les VM entres elles néanmoins devraient pouvoir communiquer sans configuration supplémentaire.

        si j'ouvre par exemple Mint en même temps, cette dernière a une connexion qui fonctionne.

        Regarde comment c’est configuré sous Mint. ip route, ip addr, fichiers dans /etc/network, fichier /etc/resolv.conf, …

        Compare également la configuration des tes deux VM au niveau de VirtualBox.

        Si tu as une autre VM qui fonctionne bien en mode VLAN il n’y a pas trop de raison d’utiliser un bridge. Le VLAN a quand même l’avantage d’isoler hôte et invité(s)…

        Slackware est effectivement « brute de dé-coffrage », je trouve que le terme est bien adapté… Il y a peu de « logiciel autour », assistants de configuration, ou de la configuration déjà faite… Elle s’efforce de n’être « que » la somme des logiciels qui la composent, sans plus… C’est une excellente distribution au demeurant (et la plus ancienne encore en activité…), donc si tu peux réussir à te dépatouiller de ce petit problème et que tu n’en gardes pas un mauvais souvenir il se peut que ça devienne ta distribution favorite, bien que tu sois venu à l’essayer plutôt par hasard.

        Bonne chance.

        • [^] # Re: Sans le network manager

          Posté par . Évalué à 1 (+0/-0).

          Bonjour Marotte et merci pour l'intérêt que tu portes à mon problème.

          Le résultat de la commande ip route :
          root@slackbox:~# ip route
          127.0.0.0/8 dev lo scope link
          192.168.247.0/24 dev eth1 proto kernel scope link src 192.168.247.5

          Je l'utilise actuellement avec un hôte Windows, mais la machine a été également ajoutée depuis l'hôte Mint (je suis en dual-boot Windows 10/Linux Mint) où le problème est identique.
          J'ai aussi Mint en VM pour faire mes essais sans risque pour ma "vrai" Mint.

          La configuration IP de l'hôte actuel :

          Configuration IP de Windows

             Nom de l’hôte . . . . . . . . . . : DESKTOP-LOHERQJ
             Suffixe DNS principal . . . . . . :
             Type de noeud. . . . . . . . . .  : Hybride
             Routage IP activé . . . . . . . . : Non
             Proxy WINS activé . . . . . . . . : Non
          
          Carte Ethernet Ethernet :
          
             Statut du média. . . . . . . . . . . . : Média déconnecté
             Suffixe DNS propre à la connexion. . . :
             Description. . . . . . . . . . . . . . : Realtek PCI GBE Family Controller
             Adresse physique . . . . . . . . . . . : 00-1E-8C-4A-D7-1D
             DHCP activé. . . . . . . . . . . . . . : Oui
             Configuration automatique activée. . . : Oui
          
          Carte Ethernet Ethernet 2 :
          
             Statut du média. . . . . . . . . . . . : Média déconnecté
             Suffixe DNS propre à la connexion. . . :
             Description. . . . . . . . . . . . . . : Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
             Adresse physique . . . . . . . . . . . : 00-00-00-00-00-00
             DHCP activé. . . . . . . . . . . . . . : Oui
             Configuration automatique activée. . . : Oui
          
          Carte Ethernet VirtualBox Host-Only Network :
          
             Suffixe DNS propre à la connexion. . . :
             Description. . . . . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter
             Adresse physique . . . . . . . . . . . : 0A-00-27-00-00-0B
             DHCP activé. . . . . . . . . . . . . . : Oui
             Configuration automatique activée. . . : Oui
             Adresse IPv6 de liaison locale. . . . .: fe80::d992:e9fa:3847:5f79%11(préféré)
             Adresse d’autoconfiguration IPv4 . . . : 169.254.95.121(préféré)
             Masque de sous-réseau. . . . . . . . . : 255.255.0.0
             Passerelle par défaut. . . . . . . . . :
             IAID DHCPv6 . . . . . . . . . . . : 638189607
             DUID de client DHCPv6. . . . . . . . : 00-01-00-01-20-D6-B5-A4-00-1E-8C-4A-D7-1D
             Serveurs DNS. . .  . . . . . . . . . . : fec0:0:0:ffff::1%1
                                                 fec0:0:0:ffff::2%1
                                                 fec0:0:0:ffff::3%1
             NetBIOS sur Tcpip. . . . . . . . . . . : Activé
          
          Carte Ethernet VirtualBox Host-Only Network #2 :
          
             Suffixe DNS propre à la connexion. . . :
             Description. . . . . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter #2
             Adresse physique . . . . . . . . . . . : 0A-00-27-00-00-0C
             DHCP activé. . . . . . . . . . . . . . : Non
             Configuration automatique activée. . . : Oui
             Adresse IPv6 de liaison locale. . . . .: fe80::5581:2e06:887f:ec9e%12(préféré)
             Adresse IPv4. . . . . . . . . . . . . .: 192.168.247.1(préféré)
             Masque de sous-réseau. . . . . . . . . : 255.255.255.0
             Passerelle par défaut. . . . . . . . . :
             IAID DHCPv6 . . . . . . . . . . . : 772407335
             DUID de client DHCPv6. . . . . . . . : 00-01-00-01-20-D6-B5-A4-00-1E-8C-4A-D7-1D
             Serveurs DNS. . .  . . . . . . . . . . : fec0:0:0:ffff::1%1
                                                 fec0:0:0:ffff::2%1
                                                 fec0:0:0:ffff::3%1
             NetBIOS sur Tcpip. . . . . . . . . . . : Activé
          
          Carte réseau sans fil Connexion au réseau local* 2 :
          
             Statut du média. . . . . . . . . . . . : Média déconnecté
             Suffixe DNS propre à la connexion. . . :
             Description. . . . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
             Adresse physique . . . . . . . . . . . : 00-15-AF-50-7E-EC
             DHCP activé. . . . . . . . . . . . . . : Oui
             Configuration automatique activée. . . : Oui
          
          Carte réseau sans fil Wi-Fi :
          
             Suffixe DNS propre à la connexion. . . :
             Description. . . . . . . . . . . . . . : 802.11n Network Adapter
             Adresse physique . . . . . . . . . . . : 00-15-AF-50-7E-EA
             DHCP activé. . . . . . . . . . . . . . : Oui
             Configuration automatique activée. . . : Oui
             Adresse IPv6 de liaison locale. . . . .: fe80::59d0:387b:df9d:996e%2(préféré)
             Adresse IPv4. . . . . . . . . . . . . .: 192.168.0.33(préféré)
             Masque de sous-réseau. . . . . . . . . : 255.255.255.0
             Bail obtenu. . . . . . . . . . . . . . : jeudi 11 janvier 2018 09:33:56
             Bail expirant. . . . . . . . . . . . . : jeudi 11 janvier 2018 21:33:56
             Passerelle par défaut. . . . . . . . . : 192.168.0.254
             Serveur DHCP . . . . . . . . . . . . . : 192.168.0.254
             IAID DHCPv6 . . . . . . . . . . . : 33559983
             DUID de client DHCPv6. . . . . . . . : 00-01-00-01-20-D6-B5-A4-00-1E-8C-4A-D7-1D
             Serveurs DNS. . .  . . . . . . . . . . : 192.168.0.254
             NetBIOS sur Tcpip. . . . . . . . . . . : Activé
          
          Carte Tunnel Teredo Tunneling Pseudo-Interface :
          
             Suffixe DNS propre à la connexion. . . :
             Description. . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
             Adresse physique . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
             DHCP activé. . . . . . . . . . . . . . : Non
             Configuration automatique activée. . . : Oui
             Adresse IPv6. . . . . . . . . . . . . .: 2001:0:9d38:6abd:2c95:3043:3f57:ffde(préféré)
             Adresse IPv6 de liaison locale. . . . .: fe80::2c95:3043:3f57:ffde%6(préféré)
             Passerelle par défaut. . . . . . . . . : ::
             IAID DHCPv6 . . . . . . . . . . . : 385875968
             DUID de client DHCPv6. . . . . . . . : 00-01-00-01-20-D6-B5-A4-00-1E-8C-4A-D7-1D
             NetBIOS sur TCPIP. . . . . . . . . . . : Désactivé
          
          C:\WINDOWS\system32>
          

          La commande dhclient -v eth1 pour attribuer une adresse automatiquement :

          root@slackbox:~# dhclient -v eth1
          Internet Systems Consortium DHCP Client 4.3.4
          Copyright 2004-2016 Internet Systems Consortium.
          All rights reserved.
          For info, please visit https://www.isc.org/software/dhcp/
          
          Listening on LPF/eth1/08:00:27:52:7f:18
          Sending on   LPF/eth1/08:00:27:52:7f:18
          Sending on   Socket/fallback
          DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
          DHCPREQUEST on eth1 to 255.255.255.255 port 67
          DHCPOFFER from 192.168.0.254
          DHCPACK from 192.168.0.254
          bound to 192.168.0.38 -- renewal in 16624 seconds.
          root@slackbox:~# 
          

          … et puis tu devras de toutes façon rediriger chaque port que tu souhaites utiliser si tu veux que les VM soient joignables

          Comment fait-on pour rediriger un port ?

          Configuration avec l'invité Mint, qui fonctionne correctement en VLAN (mode d'accès réseau NAT).

          ma3-mv-mint@ma3mvmint-VirtualBox ~ $ sudo ip route
          [sudo] Mot de passe de ma3-mv-mint : 
          default via 10.0.2.2 dev enp0s3  proto static  metric 100 
          10.0.2.0/24 dev enp0s3  proto kernel  scope link  src 10.0.2.15  metric 100 
          169.254.0.0/16 dev enp0s3  scope link  metric 1000 
          ma3-mv-mint@ma3mvmint-VirtualBox ~ $ 
          
          ma3-mv-mint@ma3mvmint-VirtualBox ~ $ sudo ip addr
          1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
          link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
          inet 127.0.0.1/8 scope host lo
          valid_lft forever preferred_lft forever
          inet6 ::1/128 scope host 
          valid_lft forever preferred_lft forever
          2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
          link/ether 08:00:27:b4:2e:1f brd ff:ff:ff:ff:ff:ff
          inet 10.0.2.15/24 brd 10.0.2.255 scope global dynamic enp0s3
          valid_lft 85228sec preferred_lft 85228sec
          inet6 fe80::2c32:b3b:73fa:2f05/64 scope link 
          valid_lft forever preferred_lft forever
          ma3-mv-mint@ma3mvmint-VirtualBox ~ $ 
          

          Les fichiers dans /etc/network :
          Il y a plusieurs sous-dossiers et je ne sais pas quoi y chercher :

          Titre de l'image

          Les fichiers dans /etc/resolv.conf :
          Là c'est plus simple, il n'y en a qu'un qui n'est pas vide.

          Titre de l'image

          Voilà ce qu'il contient, je dois y rajouter quoi ?

          Titre de l'image
          Comparaison de la configuration des deux VM au niveau de VirtualBox.
          C'est ce que j'avais regardé en premier, mais il n'y a aucune différence.

          Voilà, je pense n'avoir rien oublié.
          J'apprécie beaucoup les explications que tu as fournies :)

          Si tu pouvais interpréter les résultats ça m'aiderait bien, je suis au début de mon "apprentissage" des commandes et tout cela me parait encore bien compliqué.

          Je suis assez persévérante et je ne vais pas me décourager aux premiers obstacles.
          Je sais bien qu'il faut du temps pour apprendre, et il n'est pas impossible du tout que Slackware devienne ma distribution préférée, mais j'ai encore du pain sur la planche :)

          Merci pour ton aide précieuse.

          • [^] # Re: Sans le network manager

            Posté par . Évalué à 3 (+0/-0).

            Le résultat de la commande ip route :

            root@slackbox:~# ip route
            127.0.0.0/8 dev lo scope link
            192.168.247.0/24 dev eth1 proto kernel scope link src 192.168.247.5

            Pas de route par défaut, pas la même configuration que sous Mint.

            Sur l’invité Mint tu n’es pas en mode bridge, et tu as bien une route par défaut :

            default via 10.0.2.2 dev enp0s3 proto static metric 100

            Tu peux voir que tu as une adresse 10.0.2.2 qui est sur un autre réseau, qui est le VLAN Virtualbox (c’est n’est pas une « vraie » interface, c’est pour ça que tu ne la vois pas quand tu listes les interfaces sous Windows).

            Donc tu peux, sous Slackware, ajouter la route par défaut avec la commande (à lancer en root)

            ip route add default via 192.168.247.1 dev eth0

            Sinon, configurer la VM Slackware de la même manière que la VM Mint, puisque que ça fonctionne ?

            Comment fait-on pour rediriger un port ?

            Pour rediriger un port entre une VM Virtualbox et son hôte c’est dans la configuration du réseau virtuel sous Virtualbox que ça se passe, mais tu verras ça plus tard… il faudrait déjà que tu aies un accès à Internet…

            Les fichiers dans /etc/network :
            Il y a plusieurs sous-dossiers et je ne sais pas quoi y chercher :

            C’est le fichier "interfaces" qui nous intéresse en premier lieu.

            Voilà ce qu'il contient, je dois y rajouter quoi ?

            DO NOT EDIT THIS FILE BY HAND - YOUR CHANGES WILL BE OVERWRITTEN

            Sous Linux, dans tous les fichiers de configuration et les scripts, les lignes qui commencent par # ne sont pas destiné au système mais à l’utilisateur lui-même. Ces commentaires sont rarement (pour ne pas dire jamais) traduits, c’est pour ça qu’il faut maîtriser un anglais basique pour utiliser des distributions comme Slackware…

            Donc pour celui-là il ne faut rien y ajouter ;) Comme explique le commentaire, il est « dynamique », le programme resolvconf va venir l‘éditer au besoin. Cela dit, sous Slack c’est bien possible qu’il doive être édité à la main. Il devrait contenir deux (au moins une) lignes pour indiquer un serveur de noms (DNS). Pour tester, tu peux indiquer les serveurs DNS publics de Google en ajoutant ces deux lignes :

            nameserver 8.8.8.8
            nameserver 8.8.4.4

            (il te faut une route par défaut pour commencer de toute façon…)

            Comparaison de la configuration des deux VM au niveau de VirtualBox.
            C'est ce que j'avais regardé en premier, mais il n'y a aucune différence.

            Comment as-tu comparé ? Il y a manifestement une différence de configuration (ta VM est en NAT, ta Slackware en bridge…), essaye de lancer un diff (avec la commande diff) sur les deux fichiers de configuration ? Mets la VM Slackware en NAT déjà, ça devrait fonctionner comme ça au départ… Ou recommence la création de la VM peut-être, voire en clonant celle qui fonctionne ?

            • [^] # Re: Sans le network manager

              Posté par . Évalué à 1 (+0/-0). Dernière modification le 12/01/18 à 09:46.

              Bonjour Marotte et merci pour ta réponse matinale ;)

              J'ai lu attentivement tes explications qui m'ont fait avancer dans ma compréhension des lignes de commades.

              Mais pour la solution, gouttegd l'a donnée hier :
              C'était simplement le NetworkManager qui n'était pas démarré !
              chmod 755 /etc/rc.d/rc.networkmanager

              Et depuis, la connexion fonctionne correctement.
              Le paramétrage du réseau n'était pas en cause, c'est bien pour cela que je ne trouvais pas de différence entre les 2 machines…

              Comment as-tu comparé ? Il y a manifestement une différence de configuration (ta VM est en NAT, ta Slackware en bridge…),

              Pour le mode Bridge, je l'avais temporairement essayé avant la capture, mais j'avais comparé quand elle était en Nat aussi.

              Il me reste une dernière interrogation.
              J'avais changé dans l'onglet Adapter une configuration qui était en mode manuel pour la basculer en automatique.
              J'ai du faire une bêtise car il y a eu un message de sécurité demandant autorisation pour modifier l'hôte.
              Et depuis, pas moyen de remettre en manuel, ça repasse aussitôt en auto.

              Es-ce-que ça va à l'encontre d'une bonne isolation de la machine par rapport à l'hôte ?

              Titre de l'image

              Merci pour ta réponse

              • [^] # Re: Sans le network manager

                Posté par . Évalué à 3 (+0/-0). Dernière modification le 12/01/18 à 20:15.

                J'ai du faire une bêtise car il y a eu un message de sécurité demandant autorisation pour modifier l'hôte.

                Si tu as fait une bêtise ce serait de ne pas avoir lu ou retenu le message de sécurité en question ;) Enfin peut-être que ce dialogue n’avait aucun détail après je ne sais pas…

                C’était un message de VirtualBox ou de Windows ?

                Et depuis, pas moyen de remettre en manuel, ça repasse aussitôt en auto.

                Tu pourrais essayer de désinstaller et réinstaller VirtualBox mais bon, vu que ça marche tu peux plus heureusement te contenter de remercier gouttegd et les développeurs de NetworkManager ! :)

                • [^] # Re: Sans le network manager

                  Posté par . Évalué à 1 (+0/-0).

                  Pas de détails particulier accompagnant ce message qui est du genre :
                  "Voulez-vous autoriser ce logiciel (en l'occurence VirtualBox) à apporter des modifications au système hôte".

                  J'avais bien pensé en dernier recours à désintaller/réinstaller VB, ça n'est pas une affaire d'état, c'est même la solution idéale en cas de complication.

                  Mais j'ai depuis remarqué quelque chose de curieux qui pourrait être plus rapide :
                  Je viens de redémarrer sous Linux (celui qui est installé en dur).
                  J'y ai aussi installé Virtualbox (la même version que celui installé dans Windows bien sûr) et je partage les machines entre les 2 OS.

                  Et bien depuis Linux, il n'y a aucun Adapter d'installé ! Et pourtant ça fonctionne, je m'interroge sur son utilité…
                  D'ailleurs je ne sais pas vraiment ce qu'est un Adapter, j'imagine une carte réseau virtuelle, mais tout cela est confus dans mon esprit.

                  Titre de l'image

                  Donc si je crains pour l'isolation de la machine à cause de ce paramètre, je peux peut-être tout simplement le supprimer dans le VB de Windows aussi, non ?

                  • [^] # Re: Sans le network manager

                    Posté par . Évalué à 3 (+0/-0).

                    je peux peut-être tout simplement le supprimer dans le VB de Windows aussi, non ?

                    Peut-être. Honnêtement je n’en ai aucune idée, ça fait longtemps que je n’ai pas eu à utiliser VB sous Windows et je n’en ai pas sous la main pour tester.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.