Forum Programmation.php Anyterm : utiliser l'authentification des sessions PHP

Posté par .
Tags : aucun
1
27
oct.
2010
Bonjour,

J'ai un serveur web sur lequel des utilisateurs s'authentifient via les sessions PHP.
Aujourd'hui je veux fournir sur ce serveur web un accès shell via Anyterm.
Mais après avoir fait quelques recherches sur le web, je ne trouve pas le moyen d'utiliser pour Anyterm l'authentification déjà effectuée en PHP.
Dans la doc et les tuto d'Anyterm, il n'est question que de l'authentification HTTP faite via Apache.

Mes questions sont :
- Peut-on "bypasser " l'authentification HTTP grace à PHP ?
- Peut-on utiliser PHP pour s'authentifier sur Anyterm ?

a+
  • # Faut chauffer ton éditeur favorie...

    Posté par (page perso) . Évalué à 4.

    - Peut-on "bypasser " l'authentification HTTP grace à PHP ?
    Non ce sont deux couches d'authentification différentes, celle d'apache venant en premier par ailleurs...

    - Peut-on utiliser PHP pour s'authentifier sur Anyterm ?
    Si ce n'est pas implémenté dans le projet _ ce qui est le cas à première vue _ rien ne t'empêche de l'implémenter toi même ! Pas très sorcier....
    => tu repère un fichier inclus partout et tu colles "si pas auth php => page login"
    => tu fait l'inclusion du fichier de code "si pas auth php => page login" partout !

    Fuse : j'en Use et Abuse !

    • [^] # Re: Faut chauffer ton éditeur favorie...

      Posté par . Évalué à 1.

      Anyterm est écrit en C++, et je n'ai pas les connaissances nécessaires.
      Merci quand même.
      • [^] # Re: Faut chauffer ton éditeur favorie...

        Posté par . Évalué à 1.

        la version de développement est disponible sous forme de :
        - module apache (comme la version précédente),
        - daemon (serveur web) qui est interfacable via du reverse-proxy.

        Sinon, il me semble qu'un script php peut faire de l'authentification au même titre que les fameux .htaccess du monde apache. phpmyadmin en est un merveilleux exemple.
        • [^] # Re: Faut chauffer ton éditeur favorie...

          Posté par . Évalué à 1.

          J'utilise la 1.1.29 (version de dev) et le module Apache a été retiré depuis la 1.1.26 [1] , je suis de fait en mode daemon avec reverse-proxy (apache).

          En fait je n'arrive pas à trouver le moyen de dire à Apache d'utiliser l'authentification de session PHP pour le virtualhost du reverse-proxy : je pense que la solution est là... mais comment faire ?!

          [1] http://anyterm.org/1.1/changelog.html
          • [^] # Re: Faut chauffer ton éditeur favorie...

            Posté par (page perso) . Évalué à 3.

            Bon, il y a beau y avoir un démon C++ en backend ( pour pseudo tty la famille et tout ), le rendu est fait via une page html, javascript blablabla ! C'est bien le propos du projet un term dans un browser...

            Pas besoin d'avoir des compétence C++ on fait que du www là !

            1) Tu fais une page php dans un nouveau rep avec un iframe 100% qui tappe la page html...
            2) Tu pose un .htacess dans le répertoire de la page html pour interdire la lecture sauf par le serveur lui-même ( oblige donc à passer par la page php, arf arf arf )
            3) Tu met ton authentification php sur ta page php !

            C'est pas compliqué pourtant !

            Fuse : j'en Use et Abuse !

            • [^] # Re: Faut chauffer ton éditeur favorie...

              Posté par . Évalué à 1.

              Le truc c'est qu'il n'y à pas de page html (pas après compilation). J'ai juste un démon anytermd qui fait serveur web (d'ou le reverse proxy).
              En tout cas je pense que je vais quand même suivre cette piste et voir si je peux embarquer un htaccess dans la compilation ou bricoler un truc dans le genre. Merci pour cette piste.
              • [^] # Re: Faut chauffer ton éditeur favorie...

                Posté par (page perso) . Évalué à 2.

                Je vais peut être avoir l'air insistant et autre....
                Mais que ce soit apache, ngis, tomcat, un netcut, un démon je_sais_pas_quoi qui crache la page web ben on s'en bas le steack non ? La preuve : ton browser ! Explique moi pourquoi un iframe il en aurait à péter de ce qui crache le code ???
                Tu ne vois pas ? Moi non plus....

                Je vais peut être avoir l'air insistant et autre, mais tu devrais virer la conf reverse proxy,
                laisser un pauvre virtualhost (mod_php actif ) et faire ce que je t'ai proposé plus haut...

                Maintenant si tu veux recoder le driver de ta carte son et faire un hack du noyau parce que tu n'a pas trouvé alsamixer vas y ! C'est le genre de délire de newbee dans lequel je me suis embarqué il y a une dizaine d'année, et dans lequel tu es en train de t'embarquer à ton tour à vouloir embarquer du htacces dans le bignou....

                Après une semaine de perdu à faire nawak, genre brancher le frigo sur ton port usb, tu te diras peut être " si j'essayais ce qu'il a dit", et en 1 à 2 heure tout sera plié...

                Ce sera mon dernier post pour te convaincre.

                Fuse : j'en Use et Abuse !

          • [^] # Re: Faut chauffer ton éditeur favorie...

            Posté par . Évalué à 1.

            Ton php, je suppose doit utiliser une base de données et une table pour l'authentification.
            Tu peux modifier la manière dont apache valide son authentification pour taper direct sur la base de données en modifiant /etc/pam.d/apache2.

            Exemple :

            auth required pam_warn.so
            auth required /lib/security/pam_mysql.so verbose=0 user=*** passwd=*** host=127.0.0.1 db=intranet table=user usercolumn=username passwdcolumn=plain_pw crypt=2
            account required pam_debug.so


            En modifiant le pam, tu peux faire tourner beaucoup de chose sur la même authentification (apache, samba, postfix ...)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.