Forum Programmation.ruby rubygems

Posté par .
Tags : aucun
0
25
jan.
2009
Bonjour.
J'ai installer ruby sur ubuntu.
J'ai aussi installer scite qui fonctionne bien, mais par contre je n'arrive pas à démarrer rubygems.
J'arrive à installer des gems avec le terminal.
Quand j'essai d'obtenir la version de rubygems tjrs avec le terminal, nada
J'ai désinstaller rubygems et réinstaller, je l'ai mis jour(version 1.3.1) mais rien à faire, je n'arrive pas à le démarrer ou même créer un raccourci.
Par contre je peut installer des gems avec le terminal sans problème, mais j'aimerai pouvoir me servir de rubygems.
si quelqu'un peut me donner quelques conseils, je vous en remercie.
  • # Gné ?

    Posté par . Évalué à 4.

    gem -v ou éventuellement gem1.8 -v
    Il faut penser a donner les droit root si jamais tu fait un gem install ...

    Mais je suis pas sur de ce dont tu parle, tu dit installer des gems avec le terminal mais pas réussir a lancer rubygem ? Il y a comme une incohérence.
    Et pourquoi un raccourci pour un logiciel en ligne de commande ?
    • [^] # Re: Gné ?

      Posté par . Évalué à 1.

      Salut,

      >Il faut penser a donner les droit root si jamais tu fait un gem install ...
      c'est à dire?
      et pourquoi?

      >Mais je suis pas sur de ce dont tu parle, tu dit installer des gems avec le terminal mais pas réussir a lancer rubygem ? Il y a comme une incohérence.

      Pourquoi une incohérence?
      Je débute avec linux.
      ça marche avec le terminal(pour l'installation des gems), mais j'aimerai plutôt me servir de rubygems pour installer les gems.
      Par contre j'ai installer scite que j'arrive à démarrer avec le terminal mais pas rubygems???
      Normalement, ou ce trouve le setup de rubygems pour pouvoir le lancer?

      Et pourquoi un raccourci pour un logiciel en ligne de commande ?
      Et bien un raccourci que je place sur mon bureau ou dans la barre de lancement rapide pour pouvoir le démarrer dirrectement.
      Ca c'est juste une question d'utilisation ou une façon de faire suivant les personnes.

      Je vais déjà essayer les réponses que tu m'a donner plus haut.
      Je te remercie.
      • [^] # Re: Gné ?

        Posté par . Évalué à 2.

        Il faut penser a donner les droit root si jamais tu fait un gem install ...
        c'est à dire?
        et pourquoi?

        Eh bien installe une gem revien a copier des fichiers dans /var/lib, comme ce sont des librairies partagées il faut les droit d'admin ou bien les installer dans ton répertoire utilisateur moyennant une option dont je ne me souvient plus.
        Pour lancer une commande avec les droits d'admin tu peut utiliser sudo ta_commande ou bien juste su

        ça marche avec le terminal(pour l'installation des gems), mais j'aimerai plutôt me servir de rubygems pour installer les gems.
        rubygems (commande gem) s'utilise en ligne de commande justement. c'est la ou je ne comprend pas ce que tu désigne par rubygem
        • [^] # Re: Gné ?

          Posté par . Évalué à 1.

          Salut Jean B,

          >rubygems (commande gem) s'utilise en ligne de commande justement. c'est la ou je ne comprend pas ce que tu désigne par rubygem

          En fait sur windows, j'ai l'habitude de me servir de rubygems pour installer mes gems(par exemple), donc je voulait garder mon habitude aussi sur ubuntu.

          J'ai lu l'aide hier, il y a quelques explications sur les droits root, mais je te remercie quand même.

          En fait, c'est juste le temps de prendre la main avec ubuntu.
          merci
    • [^] # Re: Gné ?

      Posté par . Évalué à 1.

      Ca y est, j'arrive à obtenir le numéro de version de rubygems avec le terminal
      je ne tapait pas la bonne commande.
      je pense que je devrait finir par trouvé pour le reste.
      merci.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.