Suivi - Comptes utilisateurs Déconnexions intempestives

#291 Posté par . État de l'entrée : corrigée
Tags : aucun
6
10
mar.
2011

Il arrive régulièrement qu'on perde sa session sans raison apparente. Parfois la session dure même très peu de temps (1 ou 2 minutes et t'es déconnecté).

Le plus étrange est que l'on peut continuer à poster dans la tribune mais impossible de poster des commentaires, plusser/moinsser...

  • # Hum....

    Posté par (page perso) . Évalué à 4 (+0/-0).

    Je ne rencontre pas ce problème et je n'ai pas trop d'idées de quoi ça peut venir, donc ça risque d'être compliqué à corriger.

    Quelques questions pour essayer de trouver une piste :

    • Quel navigateur utilises-tu ?
    • Est-ce que tu passes par un proxy ?
    • Est-ce que cela arrive juste quand tu fais une action (poster un commentaire, pertinenter, poster sur la tribune) ou aussi juste en navigant sur le site ?
    • Utilises-tu la version http ou https du site ?
    • Est-ce que tu pourrais noter l'heure à laquelle ça arrive ?
    • [^] # Re: Hum....

      Posté par . Évalué à 3 (+0/-0).

      Quel navigateur utilises-tu ?

      Chrome

      Est-ce que tu passes par un proxy ?

      oui

      Est-ce que cela arrive juste quand tu fais une action (poster un commentaire, pertinenter, poster sur la tribune) ou aussi juste en navigant sur le site ?

      Bonne question. Je me souviens plus, je regarderai la prochaine fois.

      Utilises-tu la version http ou https du site ?

      Il me semble que c'est la version http, mais il m'arrive de browser en https quand je suis un lien donné sur la tribune par exemple.

      Est-ce que tu pourrais noter l'heure à laquelle ça arrive ?

      Will do.

    • [^] # Re: Hum....

      Posté par (page perso) . Évalué à 1 (+0/-0).

      Ça m'est arrivé aussi avec FF4 et sans proxy.

      Ça se produit plutôt lors d'un clic sur un lien de la tribune vers le site. Pour info j'utilise olcc pour mouler.

      Si ça peut aider...

      \_o<

    • [^] # Re: Hum....

      Posté par . Évalué à 1 (+0/-0).

      Beaucoup de monde rencontre ce problème...
      Pour ma part :

      Quel navigateur utilises-tu ?

      Firefox

      Est-ce que tu passes par un proxy ?

      Non

      Est-ce que cela arrive juste quand tu fais une action (poster un commentaire, pertinenter, poster sur la tribune) ou aussi juste en navigant sur le site ?

      Juste en naviguant. Par exemple, le matin je vais sur la tribune, et la zone de texte a disparu !

      Utilises-tu la version http ou https du site ?

      HTTP uniquement, le certificat HTTPS donnant des allergies à mon navigateur...

      Est-ce que tu pourrais noter l'heure à laquelle ça arrive ?

      OK, je mettrai un post-it sur le frigo.

      • [^] # Re: Hum....

        Posté par . Évalué à 1 (+0/-0).

        Tout idem h5n1.
        Firefox 3.6, pas de proxy, juste en naviguant (hier par exemple je lance firefox, je vais sur linuxfr et hop j'étais déconnecté, cookie HS), HTTPS.

        Ce qui est étrange c'est que ça fait des jours que j'ai gardé le même cookie dans onlinecoincoin (olcc) et que je reste connecté. Par contre, quand je vais sur linuxfr, le cookie n'est plus valide. Va comprendre Charles... Il y aurait pas un bronx au niveau expiration des sessions ? Tu te retrouves pas avec des kilotonnes de sessions vides ?

    • [^] # Re: Hum....

      Posté par (page perso) . Évalué à 5 (+0/-0).

      pour ma part ça ne m'arrive jamais ce qui tendrait a prouver que ça n'arrive qu'aux trolleurs et aux mécréants.

      • [^] # Re: Hum....

        Posté par . Évalué à 2 (+0/-0).

        Impossible, ça n'arrive pas à domi.

      • [^] # Re: Hum....

        Posté par . Évalué à 2 (+0/-0).

        Tu m'as cloué l'herbe sous l'évier car j'ai exactement le même problème que toi ici : ça ne m'arrive pas. j'avoue que je suis un peu jaloux d'être blessé pour ponte :/

        « Je vous présente les moines Shaolin : ils recherchent la Tranquillité de l'Esprit et la Paix de l'Âme à travers le Meurtre à Main Nue »

    • [^] # Re: Hum....

      Posté par . Évalué à 1 (+0/-0). Dernière modification le 13/03/11 à 22:00.

      Coucou,

      En guise d'introduction, je souligne que j'utilise chrome pour naviguer sur le site et également chrome pour mouler sur la tribune avec olc² qui est qq part une sorte de proxy. J'ai dû me reconnecter cette nuit je ne sais plus quand, jeudi entre 2h et 4h je dirais, alors que ma session avait été ouverte le même jour que la version en ror de dlfp. Chose intéressante : j'ai perdu ma session et pourtant même pas mal avec olcc, je continue à mouler avec la même valeur de cookie que la session perdue. Là, quand j'ai voulu poster ce commentaire, boum, session reperdue, ça s'est passé à 23:44. J'ai toujours ma session active avec olcc.

      1. le pb m'est arrivé avec chrome
      2. non
      3. la première fois, j'ai remarqué que j'étais déconnecté quand j'ai remarqué que j'avais perdu ma feuille de style en ouvrant un journal ou une news à partir de l'agrégateur liferea ; la seconde fois c'est clairement au moment de répondre justement à tes questions vers 23:44
      4. cette nuit je ne sais pas dans quel contexte mais là ça vient d'arriver quand j'ai voulu répondre et c'était en https que je n'ai pas l'habitude forcément d'utiliser, en tout cas pas volontairement
      5. la première fois, cela a dû arriver dans la nuit de mercredi à jeudi, je me suis aperçu de la connexion cette nuit mais je ne saurai pas dire de quand ça date exactement mais pas d'avant mercredi ; la seconde à l'instant vers 23:44
    • [^] # Re: Hum....

      Posté par . Évalué à 2 (+0/-0).

      Ouais enfin ils te cachent tous quelque chose : ils moulent via olc² qui nécessite d'avoir les cookies HTTP pour effectuer les requêtes. Si tu préfères, olc² se comporte grooso-merdo (lis bien merdo et pas modo) comme un proxy avec un script PHP côté serveur qui effectue lui même la requête sur DLFP, donc avec un IP différente de celle du navigateur côté client.

      Donc grosso-modo (cette fois modo et pas merdo), si tu es aussi tolérant sur le contrôle des sessions que tu ne l'es pour les vérifications lors de l'envoie d'un message sur la tribune, tu vas remarquer que deux IPs utilisent la même sessions et tu as peut-être décidé que c'en était trop fort de café et qu'un culprite devaient être puni ou un truc du genre, non ?

      « Je vous présente les moines Shaolin : ils recherchent la Tranquillité de l'Esprit et la Paix de l'Âme à travers le Meurtre à Main Nue »

      • [^] # Re: Hum....

        Posté par . Évalué à 3 (+0/-0).

        Il me semble que certaines moules qui n'utilisent pas olcc ont aussi le problème.
        De toute manière, si on avait un coincoin moderne pour Gnome, on pourrait mouler "légal". Malheureusement, l'auteur du coincoin en question tient autant ses promesse qu'un politicien...

    • [^] # Re: Hum....

      Posté par . Évalué à 2 (+0/-0).

      • Quel navigateur utilises-tu ?

      Firefox 3.6

      • Est-ce que tu passes par un proxy ?

      Je crois que ca m'arrive aussi bien au bureau (avec proxy) que chez moi (sans proxy)

      • Est-ce que cela arrive juste quand tu fais une action (poster un commentaire, pertinenter, poster sur la tribune) ou aussi juste en navigant sur le site ?

      J'ai l'impression que ca arrive de manière quasi systématique quand je poste sur la tribune puis sur le reste du site puis retour à la tribune.

      • Utilises-tu la version http ou https du site ?

      A priori plutôt http

      • Est-ce que tu pourrais noter l'heure à laquelle ça arrive ?

      Faut regarder les logs de la tribune, mais ca m'est arrivé vers 15h41 aujourd'hui.

      • [^] # Re: Hum....

        Posté par . Évalué à 2 (+0/-0).

        Ca m'est encore arrivé à 15h50 suite à l'écriture de mon commentaire ci-dessus ;)

  • # 2ème lot de questions

    Posté par (page perso) . Évalué à 2 (+0/-0).

    Vu que les premières questions n'ont pas apportées d'éléments de réponses, on va en essayer d'autres :

    • Est-ce que vous bloquez l'envoi du REFERER ?
    • Est-ce qu'olcc envoie bien un REFERER en linuxfr.org ?
    • Si vous ouvrez deux sessions, disons une dans firefox pour naviguer normalement et une dans un autre navigateur qui va servir pour la tribune, est-ce que vous avez encore ce problème de déconnexion ? Pour quelle(s) session(s) : celle de firefox ou celle de la tribune ?
    • [^] # Re: 2ème lot de questions

      Posté par . Évalué à 3 (+0/-0).

      Est-ce que vous bloquez l'envoi du REFERER ?

      non

      Est-ce qu'olcc envoie bien un REFERER en linuxfr.org ?

      je n'utilise pas olcc, mais http://linuxfr.org/board et pourtant j'ai le problème (cf ci-dessus)

      Si vous ouvrez deux session

      j'essaierai ça plus tard

    • [^] # Re: 2ème lot de questions

      Posté par . Évalué à 1 (+0/-0).

      Est-ce que vous bloquez l'envoi du REFERER ?

      Non.

      Est-ce qu'olcc envoie bien un REFERER en linuxfr.org ?

      Je n'utilise pas olcc.

      Si vous ouvrez deux sessions, disons une dans firefox pour naviguer normalement et une dans un autre navigateur qui va servir pour la tribune

      Je ne vais quasiment que sur la tribune, la qualité du site qui l'entoure s'étant notablement détériorée ces derniers temps.

    • [^] # Re: 2ème lot de questions

      Posté par (page perso) . Évalué à 2 (+0/-0).

      Si vous ouvrez deux sessions, disons une dans firefox pour naviguer normalement et une dans un autre navigateur qui va servir pour la tribune, est-ce que vous avez encore ce problème de déconnexion ? Pour quelle(s) session(s) : celle de firefox ou celle de la tribune ?

      Je cherche toujours un volontaire pour tester ça.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.