Journal Zoom sur la récente Debian 5.0.6

Posté par (page perso) .
Tags : aucun
8
23
sept.
2010
Vous l’avez sans doute vu passer, mais je reviens un instant sur la sortie de la nouvelle mise à jour - sortie le 4 septembre dernier - de la Debian Lenny 5.0, l’actuelle version stable . Il s’agit de la 6ème mise à jour pour Lenny.

Cette nouvelle version contient plusieurs corrections de bugs mais aussi des correctifs de sécurité. Si vous ne maintenez pas régulièrement votre machine à jour, la sortie de cette mise à jour représente une bonne occasion de rattraper la situation. Il faut en effet insister sur le fait que les correctifs proposés sont souvent importants.

Voici un choix non exhaustif de quelques paquets qui ont été mis à jour pour des bugs ou failles de sécurité plus ou moins graves :
  • Lighttpd, Postgresql, Bind9, Git-core, le noyau 2.6.26, Lvm2, Openssl, Php5, Phpmyadmin, Squirrelmail, User-mode-linux, Wget et Lftp.
Il ne s’agit donc pas de paquets peu utilisés qu’on pourrait ignorer.

Spécifique à Debian, le paquet debian-archive-keyring a été modifié. En effet la clé de la future version stable Debian « Squeeze » 6.0 a été ajoutée au trousseau des clés de la Lenny.

Côté matériel, le support des contrôleurs 82567LM-4, 82567LM-3, 82567LF-3 et 82583V a été ajouté au pilote de carte réseau e1000e.

Rappelons pour conclure que Lenny continue tranquillement son cycle de vie qui prendra fin un an après la sortie de la nouvelle version stable. Elle sera considérée comme la « vieille stable » une fois que Squeeze l’aura remplacée.
  • # Oui mais …

    Posté par . Évalué à 5.

    On s'en fou … ;) qu'ils release squeeze et que sid reprennent une activité normal je veux kde4.5 dans sid et Amarok 2.3.2 que je puisse lire ma musique sur un disk externe sans qui me rescan tout et que je puisse repasser sur la branche git 4.1 de kdevelop …

    Parce que soit tu as lenny en desktop et dans se cas tu doit être sur un Amstrad CPC 6128 …
    Et si t'es en serveur bhen faut être dingue pour pas être à jour à ce point …

    Bon je dis ça mais en même temps je suis sous Kde 4.5 merci : http://qt-kde.debian.net

    Dire que j'étais passé sous sidux pour kde 4.0 et la bing ! ça recommence juste pour une release majeur comme la dernière fois et la, même sidux enfin aptosid ne peut rien pour moi …

    Les distribs de nos jours passent plus de temps à changer de nom et ce prendre la tête sur des histoires de license (moi je veux que GPL version 2 et moi 3 et moi gnagna MIT …), qu'a faire des trucs pour les vrais gens qui s'en servent. Du coup quand firefox4 sort en beta en français toi ta la beta de Iceweasel 3.6 en anglais dans experimental tu veux les drivers nvidia ta l'impression d'installer Iter dans ton jardin … En plus t'as pas intérêt a prendre la derniere CG à la mode à 400€ car ça marche pas ou si mais comme une 3DFX …
    Et après on se tire sur la nouille (voix de Jean Kevin) "Moui Linux c'est pas prêt pour le desktop" … De toute façon quand il sera prêt pour le desktop cela voudra dire k'on aura droit au virus et autres cochonneries HADOPIennes et je migrerai sous HURD pour jouer à Duke Nukem Forever … *<:o)

    Après: "Linux c'est pour les communistes", il faudrai faire un OS pour anarchistes ou on serai des guedins et on mettrai les blob nvidia / Catalyst direct dans la distro tellement punk qu'on aurai même gardé le logo de Firefox ;)

    Je rêve d'une distrib comme debian (que j'adore quand même et que je n'échangerai pas contre trois barils de winbouze 7) avec apt tout ça mais au fil de l'eau pour power user avec les dernières versions des logiciels rapidement. Je suis sous sid depuis des années et j'ai jamais vraiment rencontré de problèmes insurmontables. Je pensai avoir trouvé avec sidux mais à part des fond d'écran avec des scorpions qui font rebelz j'ai pas vu de grande différence avec sid.

    Bon voila, tout ça c'est un peu second degré, je sais qu'on est pas vendredi mais moi les vendredi j'ai du boulot. Et pas la peine d'aller hacker mon blog pour voler mon CV ;) de toute façon j'en ai pas… de blog …
    • [^] # Re: Oui mais …

      Posté par . Évalué à 7.

      Et sinon tu deales un peu ce qui te reste, ou tu t'es déjà tout envoyé dans le pif?
    • [^] # Re: Oui mais …

      Posté par (page perso) . Évalué à 9.

      On s'en fou … ;) qu'ils release squeeze et que sid reprennent une activité normal je veux kde4.5 dans sid et Amarok 2.3.2 que je puisse lire ma musique sur un disk externe sans qui me rescan tout et que je puisse repasser sur la branche git 4.1 de kdevelop …

      Change de distribution alors, si c'est ça que tu veux, Debian n'est pas fait pour toi, vise plutôt du côté de ArchLinux ou de LFS.

      « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

    • [^] # Re: Oui mais …

      Posté par (page perso) . Évalué à 3.

      C'est de la bonne, j'en veux aussi.
    • [^] # Re: Oui mais …

      Posté par . Évalué à 8.

      Oui, qu'ils releasent vite Squeeze avec un bon correcteur d'orthographe, ça commence à devenir urgent pour certains...

      Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

    • [^] # Re: Oui mais …

      Posté par (page perso) . Évalué à 5.

      tu veux les drivers nvidia ta l'impression d'installer Iter dans ton jardin … En plus t'as pas intérêt a prendre la derniere CG à la mode à 400€ car ça marche pas ou si mais comme une 3DFX …

      Rien ne t'empêche d'installer le dernier ".run" de NVIDIA sur ta Debian Squeeze/Testing ou Sid : Tu es un power-user, donc tu sauras bien relancer le dir ".run"à chaque upgrade du kernel.
      Personnellement, c'est ce que je fais sur les machines que j'installe, et ca marche très bien.

      Du coup quand firefox4 sort en beta en français toi ta la beta de Iceweasel 3.6 en anglais dans experimental

      Là encore, tu peux installer dans ton /usr/local/ le dernier .tgz tout compilé de Mozilla . Ca marche aussi très bien.

      Dans les deux cas, tu dois faire les mises à jours de ces softs à la main. Mais en temps que power-user, tu y arriveras sans problème... ;)
      • [^] # Re: Oui mais …

        Posté par . Évalué à 2.

        Il a pas tort, mais c'est pas une raison de se plaindre. Je suis sur débian Lenny, j'ai un Kernel 2.6.35, les dernier drivers Nvidia et Firefox 3.6.10.
        Pour l'instant, mon seul plantage, c'est compiz qui démarre mal : rien de grave, je lance compiz-icon avec lequel je recharge compiz ou Metacity.
        Sinon, je peu jouer, mater des vidéo et des DVD, aller sur internet (le contraire serait étonnant tout de même...) sans aucun soucis!
      • [^] # Re: Oui mais …

        Posté par . Évalué à 1.


        Rien ne t'empêche d'installer le dernier ".run" de NVIDIA sur ta Debian Squeeze/Testing ou Sid : Tu es un power-user, donc tu sauras bien relancer le dir ".run"à chaque upgrade du kernel.

        Il doit bien exister une méthode qui permettrait d'installer les sources à chaque mise-à-jour du kernel et de recompilier le module en fonction du .run installé, non ?


        Là encore, tu peux installer dans ton /usr/local/ le dernier .tgz tout compilé de Mozilla . Ca marche aussi très bien.

        Même chose dans ce cas, un .deb qui exécute le script ad-hoc pour le télécharger, et faire les modifications nécessaires pour que ça ne ressemble plus qu'à un iceweasel, ce devrait être faisable... à moins que je me trompe bien sur !
        Mais c'est vrai, si la seule obligation de Mozilla n'est que d'offrir un Firefox avec le nom et le logo de la marque pour la version officielle, pourquoi ne pas offrir la version sans le branding en plus ? A moins bien sur que je ne sois pas à jour et qu'il y ait des modifications supplémentaires ...
    • [^] # Re: Oui mais …

      Posté par . Évalué à 2.

      Je rêve d'une distrib comme debian (que j'adore quand même et que je n'échangerai pas contre trois barils de winbouze 7) avec apt tout ça mais au fil de l'eau pour power user avec les dernières versions des logiciels rapidement. Je suis sous sid depuis des années et j'ai jamais vraiment rencontré de problèmes insurmontables. Je pensai avoir trouvé avec sidux mais à part des fond d'écran avec des scorpions qui font rebelz j'ai pas vu de grande différence avec sid.

      CUT (dont le but est d'avoir une testing continuellement utilisable) pourrait répondre à ton problème (rolling release). Il faut voir ce que ça donne à l'avenir.

      http://linuxfr.org/2010/09/12/27377.html
    • [^] # Re: Oui mais … IRL

      Posté par (page perso) . Évalué à 5.

      Hello,

      Parce que soit tu as lenny en desktop et dans se cas tu doit être sur un Amstrad CPC 6128 …
      Je regarde la station de travail de ma femme à la maison... non, ce n'est pas un Amstrad mais un PIV 2,4Ghz qui fonctionne plutôt bien depuis 3 ans sous Lenny. Pourtant, c'est la seule machine dont elle se sert quasi tous les jours et ça lui va plutôt bien.

      Quand Squeeze sera "stable", je m'occuperai de la mise à jour en lui expliquant rapidement ce qui a changé et ce qui la concerne, histoire qu'elle ne soit pas prise au dépourvu. Mais j'ai dans l'idée que ça va durer moins d'une demi-heure car extérieurement, ce seront toujours les mêmes outils qu'elle utilisera.

      Le seul truc qu'elle trouve moyen sous Lenny, c'est parfois les différences entre OpenOffice 2.4 et 3.2 et aussi le fait que sous Iceweasel 3.0, il n'y a pas le + pour ouvrir un onglet qui est présent dans la version 3.5 (personnellement, je n'avais pas vu que ça existait, me contentant de faire un Ctrl+T). Mais cette légère frustration se dissipe bien vite dans le quotidien lorsqu'elle me voit très régulièrement patienter devant mon écran alors que je lui explique que je fais "une mise à jour de testing"...

      Bref, vous l'aurez compris, ma femme n'est pas une hackeuse mais simplement une utilisatrice d'informatique. Ses besoins sont bien cadrés et de toute manière, elle n'a ni le temps ni le goût de creuser sur ces sujets particuliers. Pourtant, elle vous dirait que GNU/Linux est prêt pour le desktop et que c'est très stable, surtout sous Debian.

      Les distribs de nos jours passent plus de temps à changer de nom et ce prendre la tête sur des histoires de license (moi je veux que GPL version 2 et moi 3 et moi gnagna MIT …),
      D'un point de vue purement technique, cela ressemble en effet à une perte de temps. Mais, vous l'aurez compris, du point de vue des valeurs, il est essentiel pour le logiciel "libre" dont la principale différence avec les autres types de logiciels est la liberté de revendiquer ce point particulier et donc d'y consacrer du temps.

      La technique ne fait pas tout; elle a une influence certainement non négligeable mais les 4 libertés en ont tout autant.

      Pour en revenir à ma femme, elle ne saisi pas très bien comment tout cela fonctionne, même si elle sait se servir des outils qui sont à sa disposition. En revanche, elle sait très bien que les logiciels qu'elle utilise sont libres et qu'elle ne risque pas de se retrouver un jour dans une situation délicate vis à vis de l'auteur ou de l'éditeur de ces applications.
      • [^] # Re: Oui mais … IRL

        Posté par (page perso) . Évalué à 5.

        Toute cette tartine juste pour nous dire que tu as une femme...
      • [^] # Re: Oui mais … IRL

        Posté par . Évalué à 3.

        personnellement, je n'avais pas vu que ça existait, me contentant de faire un Ctrl+T
        J'avoue, c'est seulement en testant la bêta 4 que je l'ai remarqué, n'utilisant que très rarement la souris sans mon clavier en main gauche... (et non, ce n'est pas ce que vous croyez... :p)
        • [^] # vimperator

          Posté par . Évalué à 3.

          ce plugin rend iceweasel (3.5.12 chez moi) VI-compatible.
          l'index gauche sur 'g' le le droit sur 'h', il permet en outre de la zone d'écran plus grande,de la complétion de ligne dispo, de minimiser les cycles 'choppe-la-souris-lache-le-clavier' et vice-versa à l'origine de fatigue articulaire (en fait mon poignet droit me remercie).
          De plus les yeux peuvent restés braqués sur l'écran, il faut quand même faire l'effort d'apprendre les raccourcis clavier sur http://vimperator.org/vimperator

          La gestion des onglets est vachement facilité avec ce plugin (pour peu que tu saches te débrouiller avec vim), bon des fois je tappe du jhkllkjj dans les formulaires web pour ne pas être sorti du mode INSERT

          En fait la souris me sert surtout quand je manipule les images ou que je joue avec kwin

          envoyé depuis mon clavier bépo

        • [^] # Re: Oui mais … IRL

          Posté par . Évalué à 3.

          Il me semble qu’on a aussi toujours pu double-cliquer dans l’espace vide à côté des onglets (ok, il faut qu’il en reste).
  • # Bizzarerie dans le Changelog

    Posté par (page perso) . Évalué à 4.

    Au menu des bizarreries qui apparaissent parfois dans les changelog, on s'intéressera au message énigmatique du commit de gmime2.2 du changelog de cette mise à jour http://ftp.debian.org/debian/dists/lenny/ChangeLog :

    gmime2.2 (2.2.22-2+lenny2) stable-security; urgency=high

    * I hate patch systems
    • [^] # Re: Bizzarerie dans le Changelog

      Posté par . Évalué à 6.

      Nan mais le but c'était d'avoir un numéro de version avec uniquement le chiffre 2.

      Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.