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Deuxième de la nouvelle numérotation année.mois, on ne relèvera plus le fait après celle-ci, et on peut dire adieu aux versions avec « l’ancienne numérotation ». Elle est sortie le 22 août 2024. Un petit tour sur ce qui change entre améliorations des performances et de la localisation, meilleure prise en compte du format OOXML, nouvelles fonctions dans Calc, modifications de l’interface notamment dans Writer et réforme des césures.
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Quelques nouveautés en un schéma très inspiré de celui d’Italo Vignoli sur l’annonce de la sortie de la LibreOffice 24.8 (en). 


[image: LibreOffice 24.8 en schéma]


Pas de panique si cela vous semble illisible. C’est une image vectorielle et le contenu des bulles est développé ci-après dans l’ordre du dessin à savoir : le traitement de texte Writer, le logiciel de présentation Impress, l’application de dessin Draw, la gestion des bases de données Base et le tableur Calc. Tout n’est pas entièrement traduit : les fonctionnalités encore en anglais seront données avec une traduction en français.

Avant toute chose : apparition d’un nouveau bouton sur le panneau de démarrage


Cela ne figure pas dans le schéma, mais il y a un nouveau bouton « Faire un don » en bas à gauche de l’écran de démarrage. Il mène à la page de dons de LibreOffice qui propose maintenant plusieurs options : Paypal, carte bancaire, virement SEPA et Liberapay. Cela faisait partie des orientations d’Eliane Domingos pour son mandat de présidente de The Document Foundation, la fondation de droit allemand qui chapeaute le projet LibreOffice.


[image: le bouton d’appel aux dons : deux mains entrelacées en forme de cœur]

Writer entre refonte de la césure et enrichissement du Volet latéral


[image: Ce qui change dans Writer]


Pour commencer : le Volet latéral (qui devrait toujours être affiché).  Pour l’afficher, soit passer par le menu Affichage > Volet latéral soit utiliser la combinaison de touche Ctrl + F5.


La grande nouveauté du Volet latéral : un panneau de recherche. Il est accessible par l’icône tout en bas de la série. Dans l’illustration c’est une loupe, jeu d’icônes Colibre. Selon le thème d’icônes, elle peut aussi représenter des jumelles.


[image: Le panneau de recherche]


Il est possible en passant par le Navigateur, l’icône en forme de boussole dans le Volet latéral, de supprimer des notes de bas de page ou de fin ou des commentaires. Clic droit sur « Commentaires » pour faire apparaître le menu contextuel.


[image: Suppression d’un commentaire]


Toujours au sujet des commentaires, il est possible d’en ajuster la largeur du panneau.


Une nouvelle fonctionnalité du Navigateur : l’insertion de renvois par glisser-déposer. Les options varient en fonction du type de renvoi.

[image: Insertion de renvois à partir du Navigateur, les options]


Quand on trie les titres par ordre alphabétique (clic droit sur la mention Titres dans le Navigateur), ils s’affichent « à plat » les uns au-dessus des autres.


[image: Tri des titres par ordre alphabétique dans le Navigateur]


Une nouveauté : les puces utilisées dans le document peuvent être sélectionnées dans la liste déroulante des puces. 


[image: Ajout d’une puce à la liste]


L’aide au formatage a aussi été améliorée. Il y en a une nouvelle qui encadre le texte sélectionné de crochets, d’accolades ou de guillemets. Mais la fonctionnalité a bénéficié d’un bon toilettage : les marques de formatage ont été modifiées et s’affichent en bleu. L’affichage de ces marques se fait via Outil > Options > LibreOffice Writer > Aides au formatage. Ci-dessous un aperçu de différentes marques de formatage ou « caractères invisibles ».


[image: Différentes marques de formatage ou « caractères invisibles ».]


Pour plus de lisibilité, la mise en évidence des styles ne s’applique plus qu’aux styles utilisés. Pour l’afficher : en bas du panneau Styles du Volet latéral, cocher la case Mise en évidence.


[image: Les styles mis en évidence dans le texte.]


Les options de césure ont été complètement refondues pour devenir entièrement conformes aux spécifications de l’ODF. On peut ainsi exclure un mot de la coupure de mots : Format > Caractère > Position. Il est possible, selon l’exemple des notes de version, de conserver la vérification orthographique et la mise en page. Ce qui n’était pas forcément le cas avec le contournement précédent où il fallait indiquer que la langue du mot était [Aucun]. Et, évidemment, on peut en faire un style de caractère.


[image: Configurer un mot comme ne pouvant être coupé]

Parmi les autres changements de la fonctionnalité : les mots avec traits d’union peuvent être configurés sans césure. La configuration des coupures de mots est plus fine, on peut les interdire en bas de page, en dernière ligne de paragraphe, etc. Cela se configure dans le format ou le style de paragraphe.


[image: Les différentes options de césure]


Pour terminer avec ces notes sur Writer : la compatibilité avec les formats .DOC, .DOCX et .RTF bénéficie de nouvelles améliorations, notamment pour les notes de fin basées sur des sections.

Impress : mise à jour directe, navigation et internationalisation


[image: Les nouveautés d’Impress qui dont développées ci-dessous]


Il devient possible de saisir les notes et de les afficher dans le mode d’affichage normal, Affichage > Note Pane (panneau des notes), elles s’afficheront en dessous de la diapositive.


[image: Cocher la case « Note Pane », les notes s’affichent en dessous de la diapositive.]


Une barre de défilement est apparue à droite de la fenêtre en mode d’affichage « Normal ». Cela rend possible la navigation entre les diapositives, avec l’avantage qu’on peut les faire défiler avec leurs notes. Auparavant, il fallait obligatoirement passer par le Volet diapo.


[image: La nouvelle barre de défilement]


Une nouvelle option figure dans Diaporama > Paramètres du diaporama : « Édition de diaporama en mode direct ». Le diaporama peut ainsi être mis à jour en cours de présentation. La case est cochée par défaut.


[image: Édition de diaporama en mode direct]


Une amélioration ergonomique bienvenue. Quand on travaille sur une boite de texte, la barre d’outils Formatage de texte s’affiche à la place de la barre d’outils Dessin.


[image: La barre d’outils Formatage affichée en deuxième ligne]


Le menu Diapo > Naviguer s’enrichit d’une nouvelle ligne  : « Go to slide » (aller à la diapo) qui ouvre une boite de dialogue pour atteindre sur une diapositive spécifique. Cette ligne figure aussi dans Draw.


[image: Pour atteindre une diapositive rapidement dans Impress ou dans Draw].


En vrac : les fichiers PPTX utilisant de nombreuses formes personnalisées s’ouvrent plus rapidement, les modèles de présentation fournis par la communauté indonésienne ont été retravaillés pour être mieux internationalisés et les rendre accessibles d’autres systèmes d’écriture. Pour finir, il est possible de configurer le nombre par défaut de diapositives en ligne en mode Trieuse de diapos. Ce nombre est fixé à quatre par défaut. Cela fait partie de la configuration avancée de LibreOffice : Outils > Option > LibreOffice > Avancé > Ouvrir la configuration avancée. Chercher la référence SorterSlidesPerRow et changer la valeur. Ici elle est fixée à 4.


[image: Configuration du nombre de diapositives par ligne]

Draw : des couches mises en évidence


[image: Les améliorations dans Draw traitées dans le corps du texte]


Outre la navigation par page, équivalente à celle indiquée pour la navigation entre diapos dans Impress, les modèles de mosaïque sont pris en charge lors de l’import de fichier PDF. Et aussi, le survol des onglets des couches met en évidence les objets qu’elles contiennent.


Accessoirement (vraiment ?), il y a un bug d’affichage dans Draw et dans Impress concernant les unités de la taille et de la position des objets : la valeur est en pouces, et il n’y a pas moyen de changer ça (ou je n’ai pas trouvé). Le symbole du système international n’apparaît pas. Mais on peut saisir les valeurs sous cette forme : « 10 cm » et ça fonctionne. On peut imaginer que la prochaine mise à jour corrige le tir.

Base : Firebird et connexion MS Access


[image: Amélioration dans Base en schéma, les trois bulles sont développées dans le texte]


Petit rappel : le module de base de données Base est ce qu’on appelle un « frontal » qui permet d’accéder aux données. Il lui faut donc une connexion à un moteur de base de données. Par défaut, les bases de données créées dans Base le sont avec une connexion intégrée à Firebird. Mais on peut configurer d’autres connexions. Dans les versions les plus anciennes de LibreOffice, par exemple, la connexion intégrée était connectée avec HSQLDB. Avec cette version il est possible de configurer une base avec une connexion aux fichiers mdb de MS Access. Il faudra utiliser le fournisseur de données ACE.OLEDB.12.0.


Dans Firebird, les données s’enregistrent maintenant automatiquement et un bug qui provoquait une perte de données lors de la mise à jour de données a été corrigé, bug tdf#117513.

Calc : plus de fonctions, de la sensibilité à la casse et plus d’accessibilité


[image: Les nouveautés de Calc développées dans le corps du texte]


Cette version de Calc voit arriver neuf nouvelles fonctions, elles ont toutes leur page d’aide en anglais sauf LET : 

    • FILTER : filtre une plage de données ou une liste à partir de conditions spécifiques,

    • RANDARRAY : génère une liste de nombres aléatoires entre deux limites,

    • SEQUENCE : génère une liste de nombres séquentiels dans un tableau,

    • SORT : trie le contenu d’une plage ou d’une liste,

    • SORTBY : trie le contenu d’une plage ou d’une liste en fonction des valeurs d’une plage ou d’une liste correspondants, 

    • UNIQUE : renvoie la liste des valeurs uniques d’une plage ou d’une liste de valeurs, 

    • XLOOKUP : RECHERCHEX en français, permet notamment de croiser les informations de deux tableaux,

    • LET : assigne des noms aux résultats des calculs,

    • XMATCH : recherche une valeur dans un tableau à une dimension et renvoie la position relative de l’élément.


L’Autofiltre, Données ou Maj + Ctrl + L, se voit ajouter une case à cocher « Lock » (bloquer). Elle empêche la perte d’une sélection non applicable lors d’une recherche.


[image: La nouvelle case à cocher « Lock » est à droite de la case de la case pour tout sélectionner.]


La validité des données, cette fonctionnalité qui permet de s’assurer que les données saisies correspondent à des critères définis, est devenue sensible à la casse. On y accède via Données > Validité. Il faut cocher la case « Case sensitive » (sensible à la casse).


[image: La nouvelle case à cocher dans la boite de dialogue]


Un autre ajout bien utile : dans le menu Feuille > Insérer des cellules, la boite de dialogue qui s’ouvre permet d’ajouter plusieurs lignes ou colonnes. Dans l’exemple on va ajouter quatre lignes.


[image: La boite dialogue Insérer des cellules]


Et aussi, sans ordre particulier :



	amélioration du copier-coller entre Calc et Google Sheets,

	le rafraichissement des cellules modifiées a été optimisé,

	sélection de plages de feuilles lors de l’export en PDF,

	les formats des cellules de tables dynamiques au format OOXML sont conservées à l’import à l’export,

	le curseur de la cellule est mieux accessible des personnes qui ont des troubles de perception des couleurs.1





Puisqu’on parle de couleur : on peut mettre en valeur l’arrière-plan des cellules actives : Outils > Options > LibreOffice Calc > Affichage > Edit Cell Highlighting (mettre en valeur la cellule active). Pour ce dernier point, je n’ai pas trouvé comment cela fonctionnait une fois la case cochée.

Postface conclusive


Cette présentation des nouveautés et changements de la très efficace suite bureautique libre n’est évidemment pas du tout exhaustive. Les notes de version portent aussi sur : Math, le noyau général, les filtres, les diagrammes, l’aide, la localisation, etc. Elles sont intégralement traduites en français.


Par ailleurs, Italo Vignoli dans la note de blog annonciatrice de la sortie (en) traite aussi du nombre de commits avec un diagramme, de la migration depuis des suites bureautiques propriétaires vers LibreOffice ou encore des configurations minimum pour installer la 24.8.


Cette dépêche est une version en grande partie ré-écrite de mon article sur la sortie de LibreOffice 24.8 et s’appuie sur les notes de versions. Certaines tournures du texte des notes de version en ont été reprises littéralement. Et, hum, le dessin avec les bulles des fonctionnalités des applications a été fait avec Inkscape (la force de l’habitude).


Un grand merci à celles et ceux qui font de LibreOffice une suite bureautique si terriblement efficace.







	
D’où le « personnes dyschromatopsiques » des schémas qui tenait mieux dans les bulles. ↩
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