Journal Galeon et Epiphany avec Mozilla 1.7.3 sous Linux Slackware 10.0

Posté par .
Tags : aucun
0
23
sept.
2004
Suite à la mise à jour de Mozilla 1.7.2 vers Mozilla 1.7.3, Galeon et Epiphany ne sont plus disponibles sous Linux Slackware 10.0 et ont été retiré de Slackware-current (la branche de développement de Linux Slackware). La raison est qu'il semblerait que des changements dans le code source de Mozilla 1.7.3 ait cassé la compatibilité de manière assez désagréable entre version mineure de Mozilla.

Bref, si vous souhaitez compiler l'un de ces deux navigateurs sous Linux Slackware 10.0 avec Mozilla 1.7.3, la solution existe. Pour Galeon 1.3.17, il suffit de passer l'option --with-mozilla-snapshot=1.7.2 au script ./configure. Pour Epiphany 1.2.9 , il suffit d'utiliser un patch disponible sur Internet [1].

[1] http://mail.gnome.org/archives/epiphany-list/2004-September/msg0003(...)
  • # Note

    Posté par . Évalué à 2.

    D'ailleurs, j'ai mis "pour Linux Slackware 10.0" car ces deux logiciels ont été supprimés de Linux Slackware, mais les solutions fonctionnent évidemment sous toutes les distributions Linux utilisant Mozilla 1.7.3. Ça paraît évident, mais des fois que quelqu'un en ferait la remarque ... :)

    « Je vous présente les moines Shaolin : ils recherchent la Tranquillité de l'Esprit et la Paix de l'Âme à travers le Meurtre à Main Nue »

  • # Dropline Gnome

    Posté par . Évalué à 2.

    A noter pour ceux qui utilisent dropline gnome, epiphany reste dispo (et le sera probablement à la sortie de dropline gnome 2.8).
    • [^] # Re: Dropline Gnome

      Posté par . Évalué à 1.

      oui , mais alors il devra apporté son mozilla
      la j'ai gnome2.8 installer avec garnome ,mais compiler avant le passage 1.7.2 -> 1.7.3
      et bien epiphany est cassé
      question il ne trouve pas mozilla_five_home:-(
  • # c'est triste

    Posté par . Évalué à 2.

    Ca casse rien du tout il suffit de se renseigner un minimum. D'ailleurs les info données ci-dessus permettent de les compiler.

    C'est de la mauvaise volonté.

    Ca ampute Gnome de son naviguateur par défaut. Pas cool.

    Sur la 10: c'est une mise à jour de sécu qui casse le système en empechant d'utiliser galeon et epiphany c'est pas top.

    D'accord de jeter epi et gal mais dans la current mais pas dans la 10 !!! Car la 10 est sorti avec ces naviguateurs et c'est n'importe quoi de les jeter en cours de route (cours de support quoi )

    et que firefox va plutot remplacer mozilla que epiphany et galeon. et qu'est ce qu'il fout la encore netscape !!!

    bordel c'est quoi ces choix de m**** ... Voilà fallait que je le dise :-)
    • [^] # Re: c'est triste

      Posté par . Évalué à 2.

      > Ca casse rien du tout il suffit de se renseigner un minimum. D'ailleurs les info données ci-dessus permettent de les compiler.

      Entièrement d'accord, si j'ai pu trouver ces informations lors de mes recherches, Patrick Volkerding aurait pu lui aussi les trouver. À cet effet, j'ai pris soin de lui envoyer un message pour lui fournir ces informations.

      > D'accord de jeter epi et gal mais dans la current mais pas dans la 10 !!! Car la 10 est sorti avec ces naviguateurs et c'est n'importe quoi de les jeter en cours de route (cours de support quoi )

      Rien à redire, c'est exactement ce que je reproche à ce changement. J'ai précisé dans mon message qu'il fallait au moins continuer de founir Epiphany et Galeon sous Linux Slackware 10.0 : j'utilise personnellement Galeon et ça m'a embêté de voir que la mise à jour m'empêchait de continuer à l'utiliser !

      > et que firefox va plutot remplacer mozilla que epiphany et galeon. et qu'est ce qu'il fout la encore netscape !!!

      C'est vrai que la présence de ce Netscape vieillisant est contestée depuis longtemps. Mais il a *enfin* été mis en pasture/ récemment dans Slackware-current.

      « Je vous présente les moines Shaolin : ils recherchent la Tranquillité de l'Esprit et la Paix de l'Âme à travers le Meurtre à Main Nue »

      • [^] # Re: c'est triste

        Posté par . Évalué à 2.

        on peut maintenant compiler epiphany avec firefox
        http://mail.gnome.org/archives/epiphany-list/2004-September/msg0004(...)
      • [^] # Re: c'est triste

        Posté par . Évalué à 2.

        C'est pas la peine de s'énerver et de mailer P Volkerding pour ça. ça ne concerne que la version de developpement (slackware-current), c'est normal que ce genre de choses arrivent. Il n'a peut-être pas eu le temps de tester le workaround et a preferé retiré epiphany et galeon en attendant. Il a une vie privée aussi ;)

        Quand on ne veut pas avoir ce genre de problèmes, on utilise la version stable ;)
        • [^] # Re: c'est triste

          Posté par . Évalué à 2.

          > C'est pas la peine de s'énerver

          Euh ... Je me suis énervé ? Je ne crois pas !

          > ça ne concerne que la version de developpement (...) (« La différence entre la théorie est la pratique, c'est qu'en théorie, il n'y a pas de différence »)

          Désolé mais tu te trompes sur deux points : non seulement ça concerne aussi Linux Slackware 10.0 et en plus j'utilise précisément Linux Slackware 10.0. Et justement, depuis la mise à jour de sécurité vers Mozilla 1.7.3 [1], Galeon et Epiphany ont été retirés de Linux Slackware 10.0. Il me semble pourtant que le journal le précise sans ambigüité.

          [1] http://www.slackware.com/security/viewer.php?l=slackware-security&a(...)

          « Je vous présente les moines Shaolin : ils recherchent la Tranquillité de l'Esprit et la Paix de l'Âme à travers le Meurtre à Main Nue »

  • # Un poil plus d'infos pour Galeon

    Posté par . Évalué à 2.

    Le mail http://article.gmane.org/gmane.comp.web.galeon.devel/2250(...) explique pourquoi ça compile pas, et redonne le workaround qu'a déjà donné linuce.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.