Forum général.test cryptage a l’installation d'Archlinux [Résolu]

Posté par . Licence CC by-sa
Tags : aucun
0
3
mai
2015

Bonjour ou bonsoir à tous ;-)

Je me présente François Hollande … président de la république .. lol

Non je plaisante _^ … ben quoi un peux d'humour bidon c'est bien :-P

plus sérieusement je me présente : Saturne.fr j'ai 20 ans et mon boulot et couvreur _^

Comme beaucoup ici, je suis passionné d'informatique
J'aime jouer avec l'ordi ;-)


bon alors j'ai un projet en ce moment :
d'installer Archlinux
L’installation en soi me pose pas de problème

mais je bloque sur le cryptage de l’installation
J'aimerais crypter Archlinux à l'installation

en suivant les instructions de ce site

http://mart-e.be/post/2013/01/14/archlinux-avec-luks-et-lvm-sur-un-ssd/

bref en arrivant à la ligne :

<# cryptsetup --cipher aes-cbc-essiv:256 --key-size 256 --hash sha256
--iter-time 1000 --use-random --verify-passphrase luksFormat /dev/sda2>


pour ma part j'ai fait un boot dans une clée USB bootable, j'y installerais grub 2 normalement dans le futur je pourrais booter dessus, et rentré le mot de passe pour rentré dans le disque crypter, et ensuite lancer le système ( je verrais plus tard )
ce chapitre _^

pour le moment, je suis au chapitre Grand 1 lol …

donc je veux crypter une partition de 250Go (sda1) de mon HDD 500Go
que j'ai partitionner avec cfisk

mais quand je tape la commande :

<# cryptsetup --cipher aes-cbc-essiv:256 --key-size 256 --hash sha256
--iter-time 1000 --use-random --verify-passphrase luksFormat /dev/sda1>

il me dit sa :

<[ 7257.313898] device-mapper: table: 254:1: crypt: Error creating IV
device-mapper: reload ioctl on failed: no such file or directory Failed to setup dm_crypt key mapping for device /dev/sda1. check that kernel supports aes-cbc-essiv:256 cipher (check syslog for more info).>

avait vous une solution ?

si le noyau ne supporte pas AES-CBC -essiv : 256 chiffrement !

qu'elle chiffrement je doit donc utilisé ?


PS : je fait l’installation en virtualBox mais j'utilise un DD physique et non un DD virtuel …
PS2: je ne sais pas ou posté mon problème alors je le poste ici en Général … comme je fait un test XD
PS3 : pardon pour les faute d’orthographe ! lol

un grand merci pour l'aide que vous m'apporterez

Cordialement Saturne.Fr

  • # --cipher aes-cbc-essiv:sha256

    Posté par (page perso) . Évalué à 4.

    mais quand je tape la commande :

    # cryptsetup --cipher aes-cbc-essiv:256 --key-size 256 --hash sha256 --iter-time 1000 --use-random --verify-passphrase luksFormat /dev/sda1
    

    il me dit sa :

    [ 7257.313898] device-mapper: table: 254:1: crypt: Error creating IV
    device-mapper: reload ioctl on failed: no such file or directory Failed to setup dm_crypt key mapping for device /dev/sda1. check that kernel supports aes-cbc-essiv:256 cipher (check syslog for more info).>
    

    L’algorithme aes-cbc-essiv:256 n’existe pas (c’est une erreur de l’auteur du billet de blog que tu cites). Fais cryptsetup --help pour avoir la liste des algorithmes possibles. Ici, tu veux probablement aes-cbc-essiv:sha256.

  • # faire dans l'autre sens

    Posté par . Évalué à 2.

    là tout de suite, tu veux crypter une partition, comme si c'etait la partition contenant les données.
    hors, ce qu'il convient de faire, c'est crypter la partition systeme sur laquelle sera installé ton OS (linux)

    et ca, normalement, l'installeur doit le proposer comme une option d'installation.

    PS : je n'ai jamais installé de archlinux, c'est peut-etre plus compliqué qu'avec les autres distribs ;)

  • # reponse

    Posté par . Évalué à 1.

    Merci ;-)

    Effectivement il me manquer " SHA "

    oui je me doute que c'est plus compliqué :-P
    mais qui ne tente rien n'a rien lol

    est je pense que sa ira
    je continue mon projet je suis en bonne vois :-)

    ce poste est résolu

    merci a tous ;-)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.