Forum général.cherche-logiciel Initier une connexion SSH à l'envers

Posté par (page perso) .
Tags : aucun
3
14
août
2008
Bonjour,

je cherche un moyen d'avoir temporairement un accès ssh sur une machine distante qui ne peut pas être tapée depuis l'exterieur mais qui peut voir le monde exterieur quand même.

L'idée est que je souhaite initier ma connexion depuis la-dite machine vers ma machine personnelle, et qu'en suite je pourrai taper mes commandes depuis ma machine personnelle pour qu'elles s'executent sur la machine dans le lan.

J'ai déjà songé à faire un programme, relativement simple à faire si on est peu regardant sur la sécurité, mais si un vrai truc existe déjà c'est mieux quand même :)

Merci !
  • # SSH, c'est possible !

    Posté par . Évalué à 10.

    Tout est faisable en utilisant que ssh : cf option -R dans le man

    Etape 1 sur machine du boulot :

    ssh -R 2222:localhost:22 mezigue@home.org

    Là on crée une connection ssh qui en plus de la session classique écoute sur le port 2222 de home.org et renvoie le tout sur localhost:22, cad un ssh local sur boulot.

    Etape 2 : rentrer chez soi et taper sur home :

    ssh -p 2222 login_boulot@localhost

    Et zou ça ressort direct sur boulot:22


    Et si la connection de l'étape 1 tombe ? plus rien ? Que nenni, en utilisant autossh. Ce dernier lance une connection ssh et si elle tombe, la relance. Et avec un agent-ssh, c'est que du bonheur !

    Par ex : autossh -M 0 -f -g -N -R 2222:localhost:22 mezigue@home.org

    Attention au -g, bien lire les man de ssh et autossh avant de lancer ça directement.



    PS : et avec corkscrew pour initier la connection ssh dans un tunnel HTTPS à travers un proxy, c'est encore meilleur ;-)
    • [^] # Re: SSH, c'est possible !

      Posté par (page perso) . Évalué à 1.

      Trop bien merci, c'est exactement ce que je cherchais.

      Parcontre, je n'ai pas encore la machine sous les yeux, juste un poste windows+putty et ma machine maison.

      J'ai quand même voulu testé, donc j'ai bien vu l'option remote dans putty, j'ai ouvert 2222:localhost:80, et sur ma machine maison j'ai tappé telnet localhost 2222. La connexion passe....

      ... Mais j'ai voulu ensuite faire un GET / HTTP/1.1, et là il ne se passe rien !

      Après quelques secondes la connexion avec le port 2222 coupe, et me coupe à nouveau dans les pattes dès que j'essais de m'y reconnecter avec telnet.

      Une idée de ce que j'ai loupé ? J'ai bien verifié je n'ai pas inversé les ports !
      • [^] # Re: SSH, c'est possible !

        Posté par . Évalué à 2.

        bizarre... Essaye de mettre un netcat en écoute à la place du serveur web (ou sur un autre port) pour voir si déjà ça arrive bien.

        Peut-être que putty a des options particulières, je ne sais pas je n'ai utilisé que ssh en ligne de commande.
        • [^] # Re: SSH, c'est possible !

          Posté par (page perso) . Évalué à 1.

          Beh c'est un poste windows, donc le netcat c'est pas évident :)

          Sinon putty a l'air de faire son boulot, en tout cas netstat voit bien mon port ouvert coté serveur dès que j'instancie la connexion

          J'ai tenté autre chose, mais ca donne le même résultat :
          j'ai ouvert 2 consoles putty tappant mon serveur ssh maison.

          Sur l'une d'elle j'ai ouvert un nc -l 3333
          Sur l'autre j'ai lancé un ssh avec ssh -R 2222:127.0.0.1:3333 127.0.0.1 puis j'ai enchainé sur un telnet 127.0.0.1 3333

          La connexion se fait mais se perd aussitôt. Netcat reste totalement muet

          Une idée :-/ ?
  • # zarbi

    Posté par (page perso) . Évalué à 1.

    c'est vraiment bizarre, j'ai tenté de tout faire en local sur ma machine maison. Ouverture d'un tunnel remote 2222 -> vers 443 (mon port ssh) puis connection ssh vers 2222, ca marche....

    Pourquoi quand je met un serveur web ca ne marche plus... ca c'est la grande question :/
    • [^] # Re: zarbi

      Posté par . Évalué à 1.

      Le port 443 est celui réservé pour les connexions sécurisées https. Donc il se peut que ton serveur web écoute sur ce port en plus du port 80.
      • [^] # Re: zarbi

        Posté par (page perso) . Évalué à 1.

        non non, la seule chose dont je suis sûr c'est que seul mon serveur ssh est configuré pour écouter sur le port 443, et que mon serveur web n'écoute que sur le 80 ! D'ailleurs, le premier serveur web que j'utilisais n'était même pas sur la même machine

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.