Forum général.général Konqueror ne valide pas les certificats SSL quand la connexion est mauvaise

Posté par . Licence CC by-sa
Tags :
4
6
oct.
2014

Bonsoir,

je ne sais pas par ou commencer pour investiguer le bug suivant :
quand ma connexion est lente (<30kbit/s, merci free) et que je tente de naviguer en HTTPS avec Konqueror (avec Webkit), je me prend plein de cecrtificat invalides à longueur de la navigation, même sur des sites grands public (c'est pas des certificat auto signé donc).
En revanche, si le débit est bon, pas de problème.
J'ai comparé les certificats dans les deux situations, et effectivement, les sha1 sont différents.

Je ne note pas le problème sous Firefox (mais je l'utilise peu).

Suis-je victime d'une attaque de type Man In The Middle ? Ca me semble peu probable.

Une idée pour avancer ?

  • # openssl

    Posté par (page perso) . Évalué à 4.

    Mon réflexe quand il s'agit de déboguer des problèmes de type certificats SSL est le suivant :

    openssl s_client -connect linuxfr.org:443 -showcerts
    

    Note : tu peux vouloir jouer les options -CApath/-CAfile (cf. -help).

    Debian Consultant @ DEBAMAX

  • # plusieurs etapes

    Posté par . Évalué à 3.

    1°) pourquoi la connexion est lente
    2°) si les sha1 sont differents, c'est que tu ne recois pas les memes certificats,
    eventuellement le certificat est tronquée quand la connexion est lente, mais ca me semble etonnant que le navigateur accepte un certificat "partiel"

    tu as des reglages de proxy ? vpn ?

    • [^] # Re: plusieurs etapes

      Posté par . Évalué à 1.

      pourquoi la connexion est lente
      

      Quand c'est le cas, un tracepath s'arrete à un routeur de la métropole. De préférence aux heures de pointes.

      Le problème est le même quelquesoit ma configuration proxy/vpn, avec ou sans

  • # et ce que par hasard

    Posté par . Évalué à 2.

    Lorsque la connexion est lente tu ne passerai pas par un proxy filtrant faisant du DPI (ce qui pourrait expliquer la lenteur)?

    Il ne faut pas décorner les boeufs avant d'avoir semé le vent

    • [^] # Re: et ce que par hasard

      Posté par . Évalué à 1.

      Je n'ai pas mit en place de proxy.
      J'ai pensé au DPI, mais j'ai le même problème avec plusieurs VPN.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.