Forum général.général Network Manager Applet Ubuntu Intrepid Ibex - Wired network, Device unmanaged

Posté par .
Tags : aucun
1
6
déc.
2008
Bonjour a tous,

Je vous pris de bien vouloir m'excuser pour le titre en anglais mais mon OS est en anglais...


je ne voulais pas passer a la version de 8.10 de kubuntu, parce que je voulais garder mon KDE3.5. Et finalement, après avoir lu plein d'articles, blogs, forums, clavardages et autres ventant les mérites du nouveau noyau qui a un meilleurs support wifi (point avec lequel j'ai toujours eu des problèmes), le nouveau gimp [...], j'ai étais faible et j'ai craqué. Cependant, je suis passe a Ubuntu, parce que kde4, je suis toujours pas prêt.
Ce qui m'amène est finalement assez amusant. Je n'ai plus trop de problème avec ma connexion wifi mais je ne peux plus me connecter avec le filaire 0_o. Ça fait deux jours que je me bats et rien a faire. C'est donc tout naturellement que je viens demander de l'aide sur mon forum préféré (<= le fayot).
Ici, un screenshot de ce que me dit le Network Manager Applet : http://olivierlemaire.wordpress.com/2008/12/06/network-manag(...)

Ici des informations qui seront sans doute utiles:


~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:1b:63:9f:f3:86
inet addr:192.168.1.50 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:31 errors:0 dropped:0 overruns:0 frame:0
TX packets:31 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2303 (2.3 KB) TX bytes:2303 (2.3 KB)

wlan0 Link encap:Ethernet HWaddr 00:1c:b3:c2:99:18
inet addr:192.168.2.85 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::21c:b3ff:fec2:9918/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:16598 errors:0 dropped:0 overruns:0 frame:0
TX packets:18348 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14087269 (14.0 MB) TX bytes:3644646 (3.6 MB)

wmaster0 Link encap:UNSPEC HWaddr 00-1C-B3-C2-99-18-39-31-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


~$ sudo nano /etc/network/interfaces

auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

auto eth0
iface eth0 inet static
address 192.168.1.50
netmask 255.255.255.0
gateway 192.168.1.1
mtu 1500


Merci d'avance pour votre aide...

Olivier
  • # network manager et /etc/network/interfaces => conflit

    Posté par . Évalué à 3.

    va vite mettre ta config reseau en mode "roaming" (dans le panneau de configuration) afin de vider le /etc/networking/interfaces

    ensuite seulement tu pourras utiliser le network-manager
    • [^] # Re: network manager et /etc/network/interfaces => conflit

      Posté par . Évalué à 2.

      Salut NeoX,
      Est ce je pourrais te demander, s'il te plait, de préciser un peu...
      Merci

      - Dans la vie, il faut toujours se fier aux apparences. Quand un homme a un bec de canard, des ailes de canard et des pattes de canards, c’est un canard. C’est vrai aussi pour les petits merdeux.

      • [^] # Re: network manager et /etc/network/interfaces => conflit

        Posté par . Évalué à 2.

        je crois que si eth0 est paramétré dans /etc/network/interfaces il ne sera pas pris en compte par NetworkManager… donc commente les lignes :

        auto eth0
        iface eth0 inet static
        address 192.168.1.50
        netmask 255.255.255.0
        gateway 192.168.1.1
        mtu 1500
        • [^] # Re: network manager et /etc/network/interfaces => conflit

          Posté par . Évalué à 1.

          Oui, mais ceci avait fait parce que sinon mon mtu se met a 64 au lieu de 1500 sans prévenir. Je vais quand même essayer pour voir

          - Dans la vie, il faut toujours se fier aux apparences. Quand un homme a un bec de canard, des ailes de canard et des pattes de canards, c’est un canard. C’est vrai aussi pour les petits merdeux.

      • [^] # Re: network manager et /etc/network/interfaces => conflit

        Posté par . Évalué à 3.

        bn tu vas dans le KDEControlCenter, dans la gestion des reseaux

        et tu met tout en automatique (DHCP)
        si besoin et si l'option est là mettre en mode "roaming" qui delegue ensuite la gestion de la carte reseau à NetworkManager.

        ensuite rien ne t'empeche de faire une configuration avec une IP fixe avec network-manager
        chez moi, en faisant clic gauche sur le network manager puis VPN -> Configuration VPN
        (d'ailleurs c'est une erreur de traduction puisqu'on regle aussi les reseaux lan, wifi, 3G)
        • [^] # Re: network manager et /etc/network/interfaces => conflit

          Posté par . Évalué à 1.

          On doit être tout prés de la vérité. J'ai tout vire ce qu'il y avait dans le fichiers /etc/network/interfaces sauf
          auto lo
          iface lo inet loopback

          J'ai passe dans /etc/NetworkManager/nm-system-settings.conf managed a true. le DHCP en mode automatique. Tout a l'air de bien se passer, sauf que le mtu repasse toujours a 64...Du coup il faut que je fasse sudo ifconfig eth0 mtu 1492 pour pouvoir me connecter...pas le top, mais bon...a défaut de mieux.

          - Dans la vie, il faut toujours se fier aux apparences. Quand un homme a un bec de canard, des ailes de canard et des pattes de canards, c’est un canard. C’est vrai aussi pour les petits merdeux.

          • [^] # Re: network manager et /etc/network/interfaces => conflit

            Posté par . Évalué à 2.

            regarde de l'autre coté du cable reseau, si ca se trouve l'appareil (switch ou box) te pose souci et t'oblige à avoir un MTU de 64

            soit dit en passant ca semble super faible et je ne vois pas de raison de se voir proposer un MTU de 64

            essaie aussi avec un liveCD savoir si c'est l'autre coté du cable qui continue de proposer 64, ou si ce ne serait pas un autre parametre dans ta config
            • [^] # Re: network manager et /etc/network/interfaces => conflit

              Posté par . Évalué à 1.

              Ça c'était une bonne idée.
              J'ai donc reboote sur un liveCD et j'ai regarde les fichiers, le ifconfig et tous les trucs avec lesquels on bricole depuis le début.
              En effet, le mtu est aussi a 64 lorsque je suis sous liveCD. Par conséquent on pourrait en déduire que c'est le routeur qui est pas gentil avec moi...comme je sais pas trop ce que je dois faire et que en plus c'est pas mon matos...

              - Dans la vie, il faut toujours se fier aux apparences. Quand un homme a un bec de canard, des ailes de canard et des pattes de canards, c’est un canard. C’est vrai aussi pour les petits merdeux.

              • [^] # Re: network manager et /etc/network/interfaces => conflit

                Posté par . Évalué à 3.

                peux-tu nous copier/coller la sortie de ton ifconfig ?
                • [^] # Re: network manager et /etc/network/interfaces => conflit

                  Posté par . Évalué à 1.

                  eth0 Link encap:Ethernet HWaddr 00:1b:63:9f:f3:86
                  UP BROADCAST RUNNING MULTICAST MTU:64 Metric:1
                  RX packets:16 errors:0 dropped:43 overruns:0 frame:43
                  TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
                  collisions:0 txqueuelen:1000
                  RX bytes:1824 (1.8 KB) TX bytes:1907 (1.9 KB)
                  Interrupt:17

                  lo Link encap:Local Loopback
                  inet addr:127.0.0.1 Mask:255.0.0.0
                  inet6 addr: ::1/128 Scope:Host
                  UP LOOPBACK RUNNING MTU:16436 Metric:1
                  RX packets:134 errors:0 dropped:0 overruns:0 frame:0
                  TX packets:134 errors:0 dropped:0 overruns:0 carrier:0
                  collisions:0 txqueuelen:0
                  RX bytes:4824 (4.8 KB) TX bytes:4824 (4.8 KB)

                  wlan0 Link encap:Ethernet HWaddr 00:1c:b3:c2:99:18
                  inet addr:192.168.2.85 Bcast:192.168.2.255 Mask:255.255.255.0
                  inet6 addr: fe80::21c:b3ff:fec2:9918/64 Scope:Link
                  UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
                  RX packets:3742 errors:0 dropped:0 overruns:0 frame:0
                  TX packets:3763 errors:0 dropped:0 overruns:0 carrier:0
                  collisions:0 txqueuelen:1000
                  RX bytes:3205792 (3.2 MB) TX bytes:630300 (630.3 KB)

                  wmaster0 Link encap:UNSPEC HWaddr 00-1C-B3-C2-99-18-39-31-00-00-00-00-00-00-00-00
                  UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
                  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
                  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
                  collisions:0 txqueuelen:1000
                  RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

                  - Dans la vie, il faut toujours se fier aux apparences. Quand un homme a un bec de canard, des ailes de canard et des pattes de canards, c’est un canard. C’est vrai aussi pour les petits merdeux.

                  • [^] # Re: network manager et /etc/network/interfaces => conflit

                    Posté par . Évalué à 2.

                    eth0 Link encap:Ethernet HWaddr 00:1b:63:9f:f3:86
                    UP BROADCAST RUNNING MULTICAST MTU:64 Metric:1

                    RX packets:16 errors:0 dropped:43 overruns:0 frame:43
                    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
                    collisions:0 txqueuelen:1000
                    RX bytes:1824 (1.8 KB) TX bytes:1907 (1.9 KB)
                    Interrupt:17


                    tu es en DHCP, tu n'as pas branché le cable
                    => tu n'obtiens pas d'adresse IP sur eth0, et donc le MTU se met au mini

                    ce qui ne t'empeche pas d'utiliser le wifi
                    wlan0 Link encap:Ethernet HWaddr 00:1c:b3:c2:99:18
                    inet addr:192.168.2.85 Bcast:192.168.2.255 Mask:255.255.255.0

                    inet6 addr: fe80::21c:b3ff:fec2:9918/64 Scope:Link
                    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
                    RX packets:3742 errors:0 dropped:0 overruns:0 frame:0
                    TX packets:3763 errors:0 dropped:0 overruns:0 carrier:0
                    collisions:0 txqueuelen:1000
                    RX bytes:3205792 (3.2 MB) TX bytes:630300 (630.3 KB)


                    pour moi je dirais que tout va bien
                    • [^] # Re: network manager et /etc/network/interfaces => conflit

                      Posté par . Évalué à 1.

                      bin si il est branché mon câble..!!??

                      - Dans la vie, il faut toujours se fier aux apparences. Quand un homme a un bec de canard, des ailes de canard et des pattes de canards, c’est un canard. C’est vrai aussi pour les petits merdeux.

  • # more /etc/NetworkManager/nm-system-settings.conf

    Posté par (page perso) . Évalué à 2.

    [main]
    plugins=ifupdown,keyfile

    [ifupdown]
    managed=true


    Salut,
    vérifie ce fichier, mon interface ifupdown était passée en managed=false suite à la mise à jour.

    Az'
    • [^] # Re: more /etc/NetworkManager/nm-system-settings.conf

      Posté par . Évalué à 1.

      Salut a tous et merci pour votre aide.
      Le problème n'est toujours pas réglé mais j'ai l'impression que nous sommes en bonne voie. Ce qui a été fait:
      #/etc/network/interfaces
      auto lo
      iface lo inet loopback


      #/etc/NetworkManager/nm-system-settings.conf
      [main]
      plugins=ifupdown,keyfile

      [ifupdown]
      managed=true


      Ce qui reste a faire:
      comprendre pourquoi le mtu de eth0 repasse a 64 alors qu'une valeur aux alentours de 1500 serait (a ce qu'on dit) beaucoup plus raisonnable.

      Par ailleurs, comment est ce qu'on détermine la taille du MTU ou la valeur qui doit lui être attribuée. pourquoi c'est pas fait automatiquement..??

      Olivier

      - Dans la vie, il faut toujours se fier aux apparences. Quand un homme a un bec de canard, des ailes de canard et des pattes de canards, c’est un canard. C’est vrai aussi pour les petits merdeux.

      • [^] # Re: more /etc/NetworkManager/nm-system-settings.conf

        Posté par (page perso) . Évalué à 1.

        contrairement à ce qui a été dit, personnellement j'ai
        auto eth0
        iface eth0 inet dhcp

        en plus dans mon fichier interfaces
      • [^] # Re: more /etc/NetworkManager/nm-system-settings.conf

        Posté par . Évalué à 2.

        chez moi le MTU est reglé sur "automatique" dans la configuration du network-manager.

        et il est de 1500 quand je fais un ifconfig

        sachant que le MTU est (à ma connaissance) négocié entre les 2 appareils (ton PC, ta box)
        il te faut peut-etre regarder du coté de ton switch/box pour savoir si cela ne viendrait pas d'ici...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.