Forum général.général postfix

Posté par .
Tags : aucun
-1
5
nov.
2008
Bonjour,

Ma config : Ubuntu 8.04 Desktop Edition

Cette machine heberge un site internet, avec une ip publique fixe et un nom de domaine
J'ai installé un serveur de mail Postfix, en suivant la documentation ubuntu.

J'ai créer un utilisateur 'contact' pour l'adresse contact@mondomaine.fr
Il fonctionne, j'ai fait des tests.

Pour configurer mon client (en suivant la doc ), thunderbird, j'ai renseigné les champ pop et smtp de sorte:
serveur pop : ip du serveur
serveur smtp : ip du serveur

Mais qu'en est t-il des prefixes pop et smtp habituels ?
  • # ?

    Posté par (page perso) . Évalué à 3.

    Mais qu'en est t-il des prefixes pop et smtp habituels ?

    Tu veux parler de smtp.wanadoo.fr et pop.wanadoo.fr par exemple?

    Si c'est ça, et bien il s'agit de serveur (ou du moins de noms DNS) distincts. Mais dans une utilisation comme la tienne, je ne vois pas l'intérêt d'avoir un nom DNS par service (noms qui peuvent viser la même machine).

    Si tu mets ton nom de domaine (si ce n'est pas uniquement une redirection web), tu devrais avoir le même résultat qu'en mettant l'@ip pour chaque service (smtp et pop).
    • [^] # Re: ?

      Posté par . Évalué à 1.

      les préfixes smt et pop ne servent qu'à distinguer plus facilement des serveurs en lieu et place de leur adresse IP.
      Dans ton cas précis si tu souhaites avoir smtp.tamachine.tld il te faudra tout simplement mettre en place un serveur dns et si tu veux utiliser ces noms partout sur le net au lieu de ton réseau local il faudra enregistrer ton nom de domaine, quoique s'il ne s'agit que de toi une petite modif du fichier host devrait suffire.
      • [^] # Re: ?

        Posté par . Évalué à 0.

        Et bien j'ai un domaine , j'ai installé un serveur DNS, bind9 Voici mon fichier de zone, j'ai ajouté pop et smtp, même si a prioris c'est pas indispensable :
        $TTL 86400
        think-thanks.fr. IN SOA ns26180.ovh.net. admin.think-thanks.fr. (
                             
                2008110401 ; serial
                    21600 ; refresh after 6 hours
                    3600 ; retry after 1 hour
                    604800 ; expires after 1 week
                    86400 ) ; minimum TTL of 1 day
        
        think-thanks.fr.    IN      MX      10   ns26180.ovh.net.
        
        think-thanks.fr.         IN      A            91.121.71.81
        www                     IN      CNAME        think-thanks.fr.
        think-thanks.fr.     IN    NS         ns26180.ovh.net.
        think-thanks.fr.     IN     NS         ns.kimsufi.com.
        pop             IN     CNAME          think-thanks.fr. // Pour seveur pop3
        smtp             IN     CNAME          think-thanks.fr. // Pour le serveur smtp Postfix
        
        A partir de ça , puis-je configurer une boite mail de l'exterieur (du serveur) pour recevoir les mails de contact@think-thanks.fr ?
        • [^] # Re: ?

          Posté par (page perso) . Évalué à 3.

          A partir de ça , puis-je configurer une boite mail de l'extérieur (du serveur) pour recevoir les mails de contact@think-thanks.fr ?

          Tu entends quoi par "boite mail"?

          Tu as déjà une boite "contact@think-thanks.fr" non?

          Si c'est pour l'utiliser depuis un autre ordinateur et bien il suffit de configurer le CLIENT mail avec ce compte pour qu'il aille chercher/envoyer les message directement sur *.think-thanks.fr

          serveur pop3: pop.think-thanks.fr
          serveur smtp: smtp.think-thanks.fr

          Tout ça à condition que le serveur écoute sur des ports réseau ouverts (si NAT ou firewall) et qu'il accepte les requêtes du client (par défaut Postfix ne doit écouter que lui-même et peut être le réseau local).

          Si ça se trouve je réponds à coté de la plaque aussi...
          • [^] # Re: ?

            Posté par . Évalué à 1.

            merci, c'est une piste, J'ai installé un client mail, thunderbird, avec les paramètres : serveur pop3: pop.think-thanks.fr serveur smtp: smtp.think-thanks.fr et lorsque je fait "Relever" j'ai le message suivant : "Could not connect to the serveur think-thanks.fr; the connection was refused" donc il faut que le serveur accepte, mais comment le configurer (quels fichier etc ....? )
            • [^] # Re: ?

              Posté par . Évalué à 2.

              houla c'est pas gagné

              1°) il te faut un serveur POP3 pour repondre à un client POP3
              postfix ne joue que le role du bureau de poste (MTA), pas le stockage des emails

              2°) il faut que ta machine laisse entrer les connections POP3 ou IMAP (selon le serveur de mail que tu aura choisis)

              3°) il faut que le parefeu (ou ta box) laisse entrer les connections vers POP3/IMAP

              4°) repeter 2° et 3° mais pour le service SMTP qui lui est assuré par postfix
              • [^] # Re: ?

                Posté par . Évalué à 1.

                Je suppose que tes serveur pop ou Imap sont déja configurés sinon ça servira à rien la config du dns.

                mais vérifies que tes ports sont bien en écoute en faisant :

                $ nmap ip_de_ta_machine

                ou je pense que ça aussi ça devrait suffire (mais je préfère le nmap) sur ton serveur tu fais

                $ netstat -ntlp


                Et aussi dans la config de tes clients fais attention à décocher l'option de connexion sécurisée pour tes serveurs smtp et pop si tu n'as pas mis ssl en place.
                • [^] # postfix + courier-imap + sasl

                  Posté par . Évalué à 1.

                  J'ai quelque soucis avec les fichiers de configuration : suite à l'installation de sasl, je ne parvient pas à envoyer des mail , depuis un client (thunderbird) 1) je saisi un message test 2) J'envoie, il me demande d'accepter un certificat, je l'accepte 3) il demande un mot de passe, je rentre celui de la boite mail 4) message d'erreur : Voici le message d'erreur du client : "le message ne peut être envoyé à cause d'un échecde connexion au serveur SMTP 91.121.71.81....." Voici mes fichiers de configuration : 1) postconf -n
                  postconf -n
                  alias_database = hash:/etc/aliases
                  alias_maps = hash:/etc/aliases
                  append_dot_mydomain = no
                  biff = no
                  broken_sasl_auth_clients = yes
                  config_directory = /etc/postfix
                  delay_warning_time = 4h
                  home_mailbox = Maildir/
                  inet_interfaces = all
                  inet_protocols = ipv4
                  mail_owner = postfix
                  mail_spool_directory = /var/spool/mail
                  mailbox_size_limit = 0
                  mydestination = ns26180.ovh.net, think-thanks.fr, localhost.ovh.net, , localhost
                  myhostname = ns26180.ovh.net
                  mynetworks = 91.121.71.0/24, 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
                  myorigin = /etc/mailname
                  readme_directory = no
                  recipient_delimiter = +
                  relayhost = 
                  setgid_group = postdrop
                  smtp_tls_note_starttls_offer = yes
                  smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
                  smtp_use_tls = yes
                  smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
                  smtpd_helo_restrictions = reject_invalid_hostname
                  smtpd_recipient_limit = 100
                  smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unknown_sender_domain, reject_unknown_client, reject_rbl_client zen.spamhaus.org, reject_rbl_client bl.spamcop.net, reject_rbl_client cbl.abuseat.org, reject_rbl_client list.dsbl.org, permit
                  smtpd_sasl_auth_enable = yes
                  smtpd_sasl_local_domain = $myhostname
                  smtpd_sasl_security_options = noanonymous
                  smtpd_sender_restrictions = reject_unknown_address
                  smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
                  smtpd_tls_auth_only = no
                  smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
                  smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
                  smtpd_tls_loglevel = 1
                  smtpd_tls_received_header = yes
                  smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
                  smtpd_tls_session_cache_timeout = 3600s
                  smtpd_use_tls = yes
                  tls_random_source = dev:/dev/urandom
                  
                  
                  2)/etc/postfix/sasl/smtpd.conf
                  pwcheck_method: saslauthd
                  mech_list: plain login
                  #/etc/init.d/postfix reload
                  
                  3)modifié dans /etc/default/saslauthd
                  MECHANISMS="pam"
                  PARAMS="-r"
                  OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
                  
                  voilà , qu'en pensez vous ? merci ?
  • # je vois plusieurs points

    Posté par . Évalué à 2.

    je vois plusieurs points qui pourraient t'emepcher d'envoyer du mail depuis ton client en passant par ton serveur :


    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_helo_restrictions = reject_invalid_hostname
    smtpd_recipient_limit = 100
    smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unknown_sender_domain, reject_unknown_client, reject_rbl_client zen.spamhaus.org, reject_rbl_client bl.spamcop.net, reject_rbl_client cbl.abuseat.org, reject_rbl_client list.dsbl.org, permit
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain = $myhostname
    smtpd_sasl_security_options = noanonymous
    smtpd_sender_restrictions = reject_unknown_address


    le premier dit que si la machine n'est pas valide à la premiere etape (helo) alors elle est refusée
    en gros tu as une machine sans dns, sans fqdn ou le dns ne correspond pas à l'ip ou l'inverse

    le 2e si l'adresse de l'emetteur n'est pas connu
    en gros si ton domaine gere think-tank.com
    l'emetteur de l'email doit evidemment etre user@think-tank.com
    et user doit exister
    • [^] # Re: je vois plusieurs points

      Posté par . Évalué à 1.

      Merci, J'ai du nouveau , desormais lorsque je clique sur "envoi" sur Thunderbird , il me demande le mot de passe, je le rentre , et il me renvoit une fenetre de saisie de mot de passe, et ce en boucle, à chaque fois . Voici mon fichier de log :
      Nov 12 10:05:32 ns26180 postfix/smtpd[12615]: Anonymous TLS connection established from ns26180.ovh.net[91.121.71.81]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
      Nov 12 10:05:37 ns26180 postfix/smtpd[12615]: warning: SASL authentication failure: Password verification failed
      Nov 12 10:05:37 ns26180 postfix/smtpd[12615]: warning: ns26180.ovh.net[91.121.71.81]: SASL PLAIN authentication failed: authentication failure
      Nov 12 10:05:39 ns26180 postfix/smtpd[12615]: warning: ns26180.ovh.net[91.121.71.81]: SASL LOGIN authentication failed: authentication failure
      Nov 12 10:05:41 ns26180 postfix/smtpd[12615]: disconnect from ns26180.ovh.net[91.121.71.81]
      Nov 12 10:08:56 ns26180 postfix/master[11168]: terminating on signal 15
      Nov 12 10:08:59 ns26180 postfix/master[12856]: daemon started -- version 2.5.1, configuration /etc/postfix
      Nov 12 10:09:06 ns26180 postfix/smtpd[12920]: connect from ns26180.ovh.net[91.121.71.81]
      Nov 12 10:09:06 ns26180 postfix/smtpd[12920]: setting up TLS connection from ns26180.ovh.net[91.121.71.81]
      Nov 12 10:09:07 ns26180 postfix/smtpd[12920]: Anonymous TLS connection established from ns26180.ovh.net[91.121.71.81]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
      Nov 12 10:09:12 ns26180 postfix/smtpd[12920]: warning: SASL authentication failure: Password verification failed
      Nov 12 10:09:12 ns26180 postfix/smtpd[12920]: warning: ns26180.ovh.net[91.121.71.81]: SASL PLAIN authentication failed: authentication failure
      Nov 12 10:09:14 ns26180 postfix/smtpd[12920]: warning: ns26180.ovh.net[91.121.71.81]: SASL LOGIN authentication failed: authentication failure
      
      Le mot de passe pour le serveur smtp est bien identique à celui de la boite mail ? Pourquoi me renvoit-il une demande d'authentification en boucle ?
      • [^] # Re: je vois plusieurs points

        Posté par . Évalué à 2.

        cela semble venir de la methode pour s'echanger les mots de passe (plain, login...)

        je sais que dans ma configuration j'ai ajouté une option pour accepter les clients "bancales"


        # secure SMTP setting
        smtpd_sasl_auth_enable = yes
        smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination

        smtpd_sasl_type = dovecot
        smtpd_sasl_path = private/auth
        broken_sasl_auth_clients = yes

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.