Forum Linux.debian/ubuntu [ubuntun] Autofs et montage des clés usb ne fonctionne plus

Posté par .
Tags : aucun
5
8
juil.
2009
Bonjour

Je suis sous la dernière ubuntu, jaunty, et j'ai installé autofs pour pouvoir monter automatiquement mes partages samba, ceci fonctionne très bien, mais depuis, les clés usb ne se montent plus automatiquement. Je précise que les clés se montaient normalement dans /media et j'ai configuré autofs pour qu'il monte dans /smb.

Les CDROM se montent toujours, j'ai l'impression que c'est hal qui ne remontent plus les évènements jusqu'à la couche gnome qui créé le point de montage.

Donc, j'attends avec impatience votre aide, j'aimerais autant me passer de mount/umount à chaque montage de clé. Ou alors, s'il est possible de passer par autofs (auto.removable), comment faire, je n'arrive pas à trouver de doc clair qui reproduise le comportement par défaut (rajoute un point de la liste des volumes de nautilus, charge le programme par défaut pour le "support photos" par exemple,...)

Techniquement, j'ai essayé avec

pmount /dev/sdc1:
Erreur : le périphérique /dev/sdc1 n'est pas amovible

alors que sdc1 est bien une partition removable (clé usb, ou lecteur de carte sd,...)

par contre,
sudo mount /dev/sdc1 /media/disk

marche très bien

Quand je mets ma clé, le dmesg me dit

Code:

[313598.169178] sd 10:0:0:0: [sdc] 15523840 512-byte hardware sectors: (7.94 GB/7.40 GiB)
[313598.175174] sd 10:0:0:0: [sdc] Write Protect is off
[313598.175178] sd 10:0:0:0: [sdc] Mode Sense: 03 00 00 00
[313598.175181] sd 10:0:0:0: [sdc] Assuming drive cache: write through
[313598.180185] sd 10:0:0:0: [sdc] 15523840 512-byte hardware sectors: (7.94 GB/7.40 GiB)
[313598.185167] sd 10:0:0:0: [sdc] Write Protect is off
[313598.185170] sd 10:0:0:0: [sdc] Mode Sense: 03 00 00 00
[313598.185173] sd 10:0:0:0: [sdc] Assuming drive cache: write through

Plus aucun signe de hal, pourtant il est bien lancé. Dans les vieux log, je vois

daemon.log.0:Jul 4 11:27:21 paro hald: mounted /dev/sdc1 on behalf of uid 1000
...
daemon.log.0:Jul 3 09:04:14 paro hald: unmounted /dev/sdc1 from '/media/disk-1' on behalf of uid 0

Hal est bien lancé, meme en le relançant ça ne change rien.

Comment debugger/tracer hal? Comment récupérer les évènements udev/hal/?

Plus généralement, la gestion des mount automatique à beaucoup changé ces denieres années (entre mount, supermount, autofs, pmount,...). Est ce qu'il y a un document clair et a jour sur le fonctionnement sur ubuntu jaunty quelque part? (genre "kernel -> udev -> hal -> gnome-truc-machin", et surtout, comment tracer ces évènements dans les log?

Merci

Gaetan
  • # raté...

    Posté par . Évalué à 3.

    bon, dsl, j'ai posté un journal au lieu d'un forum et je l'ai fait 2 fois...
    • [^] # Re: raté...

      Posté par . Évalué à 1.

      personne n'a une petite idée ou une doc hal?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.