Forum Linux.débutant Error Libmount

Posté par . Licence CC by-sa
Tags : aucun
0
15
sept.
2017

Bonjour à tous. Je chercje à installer GBLIB 2.54 mais quand je lance l'installation par : ./configure --prefix=/usr --with-pcre=system && make

Je reçois comme erreur :

checking for mnt_unref_table in -lmount… no
configure: error: *** Could not find libmount

J'ai vu que je pouvais faire un

sudo apt-get install libmount-dev

Mais cela m'indique que j'ai déjà la derniere version de libmount. Alors ça se mord la queue et je ne sais pas quoi faire. Merci pour votre aide.

  • # pourquoi?

    Posté par . Évalué à 1 (+0/-1).

    Pourquoi tu veux installer glib? Et pourquoi tu penses qu'apt se trompe quand il te dit que libmount-dev est deja installee?

  • # config.log

    Posté par (page perso) . Évalué à 2 (+1/-0).

    Cette fonction est dans libmount1 depuis la version 2.24.2 d'util-linux, qui était déjà dans Debian 8 (2.25.2 même). Ce n'est donc probablement pas un problème de version insuffisante de libmount-dev/libmount1.

    Tu devrais avoir un config.log avec les commandes qui ont été lancées pour tester la présence de cette fonction, et il devrait y avoir plus de détails à propos de cette erreur.

    Debian Consultant @ DEBAMAX

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.