Forum Linux.débutant haut parleurs sur port USB, muets?

Posté par . Licence CC by-sa
Tags : aucun
2
4
mar.
2014

bonjour,
j'ai acheté des petits haut-parleurs qui se branchent sur port USB, mais qui sont muets …
les anciens marchaient bien, donc le problème est là.
je fais la commande:

~$ lsusb
Bus 001 Device 009: ID 074d:a504 Micronas GmbH

mais je ne sais pas quel pilote chercher chez Micronas…
y a t-il une commande qui me permette d'en savoir plus?

la commande

$ pacmd list-sinks

me donne

card: 9
module: 30
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "USB Audio"
alsa.id = "USB Audio"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "2"
alsa.card_name = "QSB"
alsa.long_card_name = "SoundScience-TRLQ QSB at usb-0000:00:1d.0-1.3, full speed"
alsa.driver_name = "snd_usb_audio"
device.bus_path = "pci-0000:00:1d.0-usb-0:1.3:1.0"
sysfs.path = "/devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.0/sound/card2"
udev.id = "usb-SoundScience-TRLQ_QSB-00-QSB"
device.bus = "usb"
device.vendor.id = "074d"
device.vendor.name = "Micronas GmbH"
device.product.id = "a504"
device.product.name = "QSB"
device.serial = "SoundScience-TRLQ_QSB"
device.string = "hw:2"
device.buffering.buffer_size = "352800"
device.buffering.fragment_size = "176400"
device.access_mode = "mmap+timer"
device.profile.name = "analog-stereo"
device.profile.description = "Stéréo analogique"
device.description = "QSB Stéréo analogique"
alsa.mixer_name = "USB Mixer"
alsa.components = "USB074d:a504"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-usb"

est-ce que je peux exploiter ces infos?

y a t-il une autre solution?

merci d'avance

:)

  • # pacmd

    Posté par . Évalué à 7.

    • [^] # Re: pacmd

      Posté par . Évalué à 5.

      Juste merci.
      C'est tellement rare les posteurs qui (re)viennent donner leur solution.

      • [^] # Re: pacmd

        Posté par . Évalué à 3.

        en meme temps ca tombait sous le sens non ?

        des haut-parleurs USB = une nouvelle carte son

        donc faut changer les reglages pour que la sortie se fasse sur la nouvelle carte son.

        c'est la meme idée quand on veut passer du son de la carte audio ordinaire, à la carte video/HDMI, etc

  • # pacmd

    Posté par . Évalué à 1.

    et à chaque fois que j'ouvre mon ordi, il me faut rentrer cette commande
    ( pour résumer le lien, voici la commande: )

    pacmd set-default-sink "alsa_output.usb-SoundScience-TRLQ_QSB-00-QSB.analog-stereo"

    y a t-il un moyen de le faire une bonne fois pour toute?

  • # barre des taches

    Posté par . Évalué à 1.

    j'ai trouvé comment éviter de rentrer à chaque fois la commande:
    par l'icone audio dans la barre des taches ( chez moi dans Xfce: sound settings )

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.