Forum Linux.débutant Linux très long à démarrer (débutant)

Posté par .
Tags : aucun
1
13
mai
2010
Bonjour,
 Je ne suis pas sur linux depuis très longtemps, et j'ai un problème avec ma distribution (Ubuntu). En effet, depuis la mise à jour vers la dernière version (10.04), le démarrage est beaucoup plus lent qu'avant.
 Quand je regarde le dmesg, j'ai un trou énorme, peut-être est-ce de là que vient le problème :
[ 11.530444] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[ 35.953938] Adding 1953116k swap on /dev/sda3. Priority:-1 extents:1 across:1953116k

(/dev/sdb est le lecteur de carte sd de mon macbook pro)

Je ne sais pas si c'est lié, mais je n'ai pas accès aux terminaux virtuels (tty1, tty2...), car ctrl-alt-fn-Fx ne fait rien, et quand je vais sur tty1 avec chvt 1 je vois le message de bienvenue sur tty1 tout en bas de l'écran et rien d'autre...
  • # Es- tu sûr de l'étape qui est la plus longue ?

    Posté par (page perso) . Évalué à 4.

    Tout est dans le titre : C'est la recherche de sdb qui est longue ? Ou est-ce l'activation du swap ?

    J'ai eu exactement le même problème avec une de mes machine, et j'ai dus modifier les scripts d'init pour trouver à quel moment je perdais 30s. Le coupable était le swap.

    La raison exact, c'est que j'avais déplacé mon swap, et que ma distrib (Debian Squeeze/Testing) avait mémorisé le vielle emplacement de celui-ci dans un quelconque fichier de conf du /etc (probablement dans les fichiers liés à l'hibernation(*)). L'information était utilisé par le mécanisme d'init, lors de mise à jours du kernel.

    Bref, fait un "grep -ri '/dev/[sh]d' /etc", et recherche quelque chose en rapport avec un fichier de swap. Et si tu as moins de chance, l'information est codé avec une UUID : "grep -ri 'uuid' /etc"

    (*) Rappel : Sous Linux, par défaut le swap est utilisé pour stocker les données de l'hibernation / suspend to disque. Contrairement à Windows, qui les stocke dans un fichier à part. Or, au boot il est primordial pour le kernel de trouver le swap, afin de restaurer l'éventuel état d'hibernation.
  • # Format de swap

    Posté par . Évalué à 2.

    Salut,

    Si le problème vient bien de la swap :
    Vérifie déjà si ton /etc/fstab indique la bonne partition de swap.
    Compare avec le retour de # fdisk -l

    Tu peux également essayer de refaire ta partition de swap.
    # swapoff /dev/sdxx
    # mkswap /dev/sdxx


    et tu redémarres.


    Si c'est la détection de ton disque dur par contre là j'ai pas trop d'idée, à part tester un autre kernel.
    • [^] # Re: Format de swap

      Posté par . Évalué à 2.

      Merci, j'ai fait ce que tu demandais.
      Mais mon démarrage est toujours aussi long. Maintenant, j'ai
      [ 8.010611] EXT3-fs: mounted filesystem with ordered data mode.
      [ 35.196751] Adding 1953116k swap on /dev/sda3. Priority:-1 extents:1 across:1953116k
      • [^] # Re: Format de swap

        Posté par . Évalué à 2.

        Ça ressemble beaucoup à un timeout, et il est bien possible que cela vienne de l'un de tes drives SCSI. Essaie d'afficher les messages. Jette un œil au contenu de /var/log/messages et /var/log/boot.log (s'il existe) à la même date…
        • [^] # Re: Format de swap

          Posté par . Évalué à 2.

          Je suis allé sur /var/log/messages, et je vois également le long trou où rien ne se passe pendant le démarrage, mais pas de timeout. Aidez-moi s'il vous plait!
          • [^] # Kernel

            Posté par . Évalué à 1.

            A part essayer un autre kernel je vois pas trop. (un PPA d'ubuntu en fournit des précompilés)

            Tu peux mettre une carte dans ton lecteur sdb et tester le démarrage ?
            • [^] # Toujours pas...

              Posté par . Évalué à 1.

              J'ai essayé. Malheureusement:
              dmesg:

              [ 6.614657] sdb: sdb1
              [ 6.619647] sd 6:0:0:0: [sdb] Assuming drive cache: write through
              [ 6.619651] sd 6:0:0:0: [sdb] Attached SCSI removable disk
              [ 8.488080] kjournald starting. Commit interval 5 seconds
              [ 8.488094] EXT3-fs: mounted filesystem with ordered data mode.
              [ 35.055188] udev: starting version 151
              [ 35.063068] Adding 1953116k swap on /dev/sda3. Priority:-1 extents:1 across:1953116k

              debug:

              May 15 11:50:28 macbook-pro kernel: [ 2.220220] ieee1394: Host added: ID:BUS[0-00:1023] GUID[60fb42fffef83f54]
              May 15 11:50:28 macbook-pro kernel: [ 6.425436] usb-storage: device scan complete
              May 15 11:50:28 macbook-pro kernel: [ 6.610655] sd 6:0:0:0: [sdb] Mode Sense: 03 00 00 00
              May 15 11:50:28 macbook-pro kernel: [ 35.173841] lib80211_crypt: registered algorithm 'NULL'
              May 15 11:50:28 macbook-pro kernel: [ 35.308482] wl 0000:03:00.0: setting latency timer to 64


              Sinon, j'ai installé bootchart, mais je ne sais pas vraiment interpréter les résultats. Si vous y comprenez quelquechose : [http://amorphose.net46.net/perso/macbook-pro-lucid-20100515-(...)]

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.