Forum Linux.débutant Mises à jours sous Linux - Ubuntu

Posté par . Licence CC by-sa
Tags : aucun
3
29
nov.
2015

Bonjour à tous,

Débutante totale sous linux, un ami m'a installé Ubuntu.
Pour les mises à jours, j'ai le gestionnaire de mises à jours qui s'ouvre régulièrement pour me proposer des mises à jours.

Que faire ?
Dans la mesure où je suis débutante et que je n'y comprends pas grand chose, faut-il à chaque fois faire les mises à jour ?

Autre question,

Y a-t-il un moyen de contourner le problème de l'inexistence de mises à jours d'Adobe sous Linux ?

D'avance merci pour vos réponses,

Delphine

  • # Oui

    Posté par (page perso) . Évalué à 2.

    Il faut absolument faire toutes les mises à jour au plus vite. C'est une meilleure sécurité qu'un anti-virus.
    Un anti-virus cherche à bloquer une application malveillante mais seulement lorsqu'elle est connue. Une mise à jour empêche une application malveillante de s'installer.

    Concernant Adobe, si vous parlez de flash celui-ci est bien mis à jour. C'est une version plus ancienne, spécifique à Linux, mais les bugs de sécurité sont corrigés. Pour les autres applications Adobe vous trouverez des équivalents sous Ubuntu tout aussi efficaces.

    • [^] # Re: Oui

      Posté par . Évalué à 3.

      Pour les autres applications Adobe vous trouverez des équivalents sous Ubuntu tout aussi efficaces.

      Tous aussi efficace ce n’est pas toujours vrai. Concernant le format PDF, le support de certaines des dernières fonctionnalités développées par Adobe est parfois absent chez les équivalents libres.

      Une mise à jour empêche une application malveillante d’utiliser une faille connue également, en la bouchant…

      • [^] # Re: Oui

        Posté par . Évalué à 1.

        Merci. Mises à jours effectuées. Je parle d'Adobe flash mais a priori c'est bien ça qui bug…

        • [^] # Re: Oui

          Posté par . Évalué à 2.

          ça qui bug

          C’est à dire ? Flash ne fonctionne pas ou bien tu as juste un message lors des mises à jour ?

          • [^] # Re: Oui

            Posté par . Évalué à 1.

            Excuse moi marotte, en fait j'ai donné la réponse détaillée ci-dessous en dessous de ton long message.
            A priori vu la réponse que j'ai eu, c'est mort.
            J'avais essayé d'installer Chrome mais ça ne change rien.
            Donc va falloir que je continue à utiliser windows si je veux pouvoir suivre mes cours… c'est quand même rageant.

            Delphine

  • # Mises à jour

    Posté par . Évalué à 2.

    Il y a deux types de mises à jour.

    Dans ton cas il s’agit probablement des mises à jour dites « de sécurité » qui ne concernent que la correction de problèmes logiciels importants (failles de sécurité potentielles bien souvent), tu dois les faire le plus régulièrement possible, il est déconseillé de les repousser (parce que tu n’as pas le temps par exemple) plus de quelques jours.

    Ensuite il y a les mises à jour vers une version suivante du système. Il est possible que tu es un jour un message t’invitant à le faire. À ce moment tu auras le choix et ne devra pas systématiquement l’effectuer. Tu devrais aviser selon tes prérogatives… cette mise à jour est plus importante et changera plus de chose sur ton système.

    Tu seras par contre obligé de faire ce « saut de version » à partir d’un certain moment car bien évidemment toutes les versions ne peuvent pas durer éternellement…

    Tu peux aller lire la page Wikipédia consacrée aux versions d’Ubuntu, notamment le tableau récapitulatif.

    Dans les paramètres des mises à jour tu peux aller voir comment c’est configuré chez toi. La configuration par défaut est probablement OK, ne change rien si tu n’es pas sûre de ce que tu fais.

    À priori tu utilises la version 14.04 LTS ou bien peut-être la 15.10… C’est bien préciser la version qu’on utilise, surtout pour une question concernant les mises à jour ;)

    Pour ce qui est de Adobe. Tu parles du plugin flash utilisé dans le navigateur ou bien du lecteur pour les PDF (Adobe Reader) ? Pour le premier tu n’as pas à t’en soucier (il y aura une mise à jour de sécurité si c’est nécessaire) et pour le deuxième, sous Ubuntu c’est un autre programme qui est utilisé par défaut pour lire ce type de fichier mais Adobe Reader peut être installé si besoin.

    • [^] # Re: Mises à jour

      Posté par . Évalué à 1.

      Merci beaucoup.
      Donc en effet, j'ai déjà effectué une mise à niveau il y a quelques mois pour la dernière version, la 15.10 je pense. Un ami m'a expliqué que parfois il faut attendre un peu avant de faire la mise à niveau pour être sure que la nouvelle version soit traduite en français, est-ce vrai ?

      Pour les mises à jour de sécurité, je les fais régulièrement, donc ça correspond à ce que vous dites, je suis rassurée.

      Dans les paramètres des mises à jour tu peux aller voir comment c’est configuré chez toi. La configuration par défaut est probablement OK, ne change rien si tu n’es pas sûre de ce que tu fais.

      Alors là je ne vois pas trop de quoi tu parles… en effet je ne suis pas du tout sure de ce que je fais. ;)

      Pour Adobe, je parle d'Adobe flash en effet. En ce moment je n'arrive pas à me connecter à une plateforme en ligne à cause d'Adobe, voilà la page sur laquelle je tombe à chaque fois :

      Capture d'écran mise à jour Adobe flash

      et là je ne vois pas trop quoi faire. J'avais essayé une fois de faire la mise à jour en choisissant YUM pour Linux dans le menu déroulant, et une autre fois APT pour Ubuntu 10.04… si ça se trouve c'était le truc à ne pas faire…
      Enfin en tout cas, ça ne marche pas.

      Merci à vous pour vos réponses.

      • [^] # Re: Mises à jour

        Posté par . Évalué à 4.

        le probleme de flash et des sites qui l'utilisent…

        certains plateformes utilisent flash et demandent une version superieure à la version N (on est à la version 19)
        mais Adobe ne fournit plus, pour linux, de version au dela de la version 11.

        au choix :
        - bannir l'usage de ce site qui pourrait utiliser HTML5 (se plaindre au developpeur du site)
        - se plaindre aupres d'Adobe pour qu'il continue de developper Flash pour les systemes "alternatifs" comme Linux.

        • [^] # Re: Mises à jour

          Posté par . Évalué à 2.

          Bonjour Neox et merci pour ta réponse.
          C'est bien ce que je craignais…
          Je ne peux malheureusement pas bannir l'usage du site en question puisqu'il s'agit de mon organisme de formation. En revanche je pourrais leur en toucher un mot.

          Pour me plaindre auprès d'Adobe, là par contre ce serait avec plaisir !!! :) Mais ça doit pas être facile de les joindre…

          • [^] # Re: Mises à jour

            Posté par (page perso) . Évalué à 2.

            « Je ne peux malheureusement pas bannir l'usage du site en question puisqu'il s'agit de mon organisme de formation. »

            Utilisent-ils Adobe connect ? Si oui leur suggérer de déployer Big Blue Button.

            • [^] # Re: Mises à jour

              Posté par . Évalué à 2.

              Je leur ai proposé hier, voici leur réponse :

              "La solution Big Blue Button a été envisagée ainsi que la plupart des solutions dites Open Source. Le principal inconvénient de ces solutions réside dans l'instabilité de l'application."

              Sous-entendu quand on se connecte à 30 dessus en même temps (parfois jusqu'à 60), ça foire.

              • [^] # Re: Mises à jour

                Posté par (page perso) . Évalué à 2.

                Eux prétendent être en très nette progression. Mais je n'ai pas d'expérience sur le sujet.

              • [^] # Re: Mises à jour

                Posté par . Évalué à 3.

                leur repondre que se priver d'un auditoire car flash n'est pas supporté partout n'est pas ideal

                • [^] # Re: Mises à jour

                  Posté par . Évalué à 2.

                  On me propose de me connecter d'une tablette ou d'un Ipad (je n'ai ni l'un ni l'autre :) ou de faire une partition linux / windows (ce que je n'ai pas envie de faire).
                  Je vais donc continuer à me connecter avec le PC de mon homme, mais c'est pas cool…

                  • [^] # Re: Mises à jour

                    Posté par . Évalué à 3.

                    demande a etre remboursé de cet organisme de formation qui ne fournit pas une plateforme multisupport.

                    • [^] # Re: Mises à jour

                      Posté par (page perso) . Évalué à 2.

                      Ce serait un peu comme attaquer un fabriquant de GPS pour vente liée car il faut widows pour profiter des mises à jour cartographiques à vie vendue avec l'appareil ; ou porter plainte contre le ministère de l'éducation nationale pour ses accords avec Micozsoft ; ou encore charger des moulins à vents. Avec un peu de chance les historiens apprécieront le geste dans quelques siècles. Mais c'est bien le maximum que cela puisse apporter.

                      • [^] # Re: Mises à jour

                        Posté par . Évalué à 3.

                        je n'achete pas le GPS si je sais par avance qu'il ne fonctionnera pas sur ma machine,
                        je me fais rembourser un produit que je ne peux pas utiliser.

                        nos impots paient l'education nationale et si l'on n'est pas d'accord avec ce qui est signé, cela passe par des courriers à nos ministres, voire par les urnes.

                        si l'on ne fait rien, ce n'est pas pret de changer,
                        et si personne ne se plaint, ce centre de formation continuera, pensant que flash est LA solution.
                        en meme temps si ca marche sur une tablette c'est que cela n'utilise pas flash ou qu'il y a une application dédiée.

                        • [^] # Re: Mises à jour

                          Posté par . Évalué à 3.

                          Je pense que c'est un autre débat…
                          J'aime cette formation et je vais donc m'arranger pour continuer à la suivre.
                          C'est un petit centre qui a deux ans à peine, et je leur ai fait part du problème, ils m'ont écouté et répondu je pense que c'est déjà ça (d'autres ne répondraient même pas ou m'auraient rigolé à la gueule).

                        • [^] # Re: Mises à jour

                          Posté par (page perso) . Évalué à 2.

                          « Je n’achète pas le GPS si je sais par avance qu'il ne fonctionnera pas sur ma machine,
                          je me fais rembourser un produit que je ne peux pas utiliser. »

                          Le fabriquant ne fait pas état de ces choses sur la boîte de son produit. Et, pour autant que je sache, aucun fabriquant de GPS matériel n'offre une alternative.

                          « nos impôts paient l’éducation nationale et si l'on n'est pas d'accord avec ce qui est signé, cela passe par des courriers à nos ministres, voire par les urnes. »

                          Urnes où il faut choisir entre des caciques n'ayant généralement pas la plus traitre idée de ce qu'est un logiciel libre. Et le sauraient-ils que de toutes façons les pressions sont telles sur les partis que tous entretiendrons la dépendance aux poisons du logiciel privateur quand ils arriveront au pouvoir.

                          Tout cela, non pas pour dire qu'il ne faille rien faire ; mais simplement pour remarquer qu'il est malheureusement parfois indispensable de transiger ; crois-je. Et par exemple, c'est ainsi avec beaucoup de regrets et à mon corps défendant que j'ai cessé d'envoyer des courriels d'insultes ou de récriminations aux abrutis envoyant des fichiers en formats non-ouverts collègues sans lire leurs documents.

      • [^] # Re: Mises à jour

        Posté par . Évalué à 2.

        j'ai déjà effectué une mise à niveau il y a quelques mois pour la dernière version, la 15.10 je pense. Un ami m'a expliqué que parfois il faut attendre un peu avant de faire la mise à niveau pour être sure que la nouvelle version soit traduite en français, est-ce vrai ?

        Plus ou moins, de manière générale quand on migre tôt on a toujours un risque d’« essuyer les plâtres » comme on dit.

        La 15.10 est la dernière version stable non LTS, son support (mises à jour de sécurité) s’arrêtera en juillet 2016, à ce moment là tu devras forcément encore changer de version, en 16.04 LTS (qui sortira en mars 2016). Puis en octobre 2016 tu auras à nouveau le choix entre : 1- rester sur la 16.04 ou 2- passer en 16.10…

        J’ai l’air d’insister mais ce principe de LTS (Long Term Support) me paraît assez important. Ça peut être chiant de devoir mettre à niveau tous les six mois, sauter de version LTS en version LTS te permet de ne faire ce saut que tous les deux ans et de conserver la même version de tes logiciels pendant ce laps de temps…

        Pour flash c’est vraiment compliqué… Toute l’histoire ici.

        L’article dit que tu peux installer Chrome (le navigateur made by Google) qui dispose d’une version plus récente de ce greffon. C’est à essayer… Tu peux même peut-être utiliser Chromium, c’est la version libre de Google Chrome, qui est disponible dans la logithèque Ubuntu.

        À tous hasard, le plugin est bien installé ? Tu peux voir la liste des plugins installés en tapant about:plugins dans la barre d’adresse de Firefox. Si ce n’est pas le cas le package à installer s’appelle libflashplugin-installer
        ```

        • [^] # Re: Mises à jour

          Posté par . Évalué à 1.

          La 15.10 est la dernière version stable non LTS, son support (mises à jour de sécurité) s’arrêtera en juillet 2016, à ce moment là tu devras forcément encore changer de version, en 16.04 LTS (qui sortira en mars 2016). Puis en octobre 2016 tu auras à nouveau le choix entre : 1- rester sur la 16.04 ou 2- passer en 16.10…

          J’ai l’air d’insister mais ce principe de LTS (Long Term Support) me paraît assez important. Ça peut être chiant de devoir mettre à niveau tous les six mois, sauter de version LTS en version LTS te permet de ne faire ce saut que tous les deux ans et de conserver la même version de tes logiciels pendant ce laps de temps…

          Tes explications me semblent vraiment très claires, je t'en remercie.

          L’article dit que tu peux installer Chrome (le navigateur made by Google) qui dispose d’une version plus récente de ce greffon. C’est à essayer… Tu peux même peut-être utiliser Chromium, c’est la version libre de Google Chrome, qui est disponible dans la logithèque Ubuntu.

          Alors j'avais installé Chromium sur ton conseil dans mon dernier post, et ça n'a pas marché malheureusement. J'avais le même message qu'avant (copie d'écran dans mon premier message sur cette page).

          À tous hasard, le plugin est bien installé ? Tu peux voir la liste des plugins installés en tapant about:plugins dans la barre d’adresse de Firefox. Si ce n’est pas le cas le package à installer s’appelle libflashplugin-installer

          Vérification faite à l'instant, le plugin est bien installé. Merci pour le truc "about:plugins" que je ne connaissais pas.

          • [^] # Re: Mises à jour

            Posté par . Évalué à 3.

            Alors j'avais installé Chromium sur ton conseil dans mon dernier post, et ça n'a pas marché malheureusement. J'avais le même message qu'avant (copie d'écran dans mon premier message sur cette page).

            la page sur laquelle tu atteris c'est la page pour telecharger flash.
            dans ton cas il est censé etre deja installé

            si le site de la formation ne detecte pas ta version de flash, c'est qu'il est mal codé et demande une version tres speciale.

            à tout hasard, c'est quoi comme site, qu'on fasse un essai de notre coté ?

  • # Salles de cours

    Posté par . Évalué à 1.

    Du coup il me vient encore une question : connaissez-vous des plateformes qui permettent de suivre des cours audio en groupe, avec un prof qui parle et les élèves qui peuvent interagir à l'écrit ou par audio en temps réel (de type openmeetings) et qui n'utilisent pas Adobe Flash ?

    D'avance merci,

    Delphine

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.