Forum Linux.débutant Rsync en panne ? avec l'option A ?

Posté par (page perso) .
Tags : aucun
1
11
déc.
2009
Bonjour à tous,

sur Etch

J'utilise rsync fréquemment pour mes sauvegardes.

Depuis hier, j'essaie en vain la commande suivante, [ avec et sans --dry-run ]


rsync -aHAv --dry-run /home/eric/ /home/backup/eric/


qui tantôt d'emblée, tantôt après un début de travail de 2, 3 ou 15 mn "plante" avec le message suivant:


*** glibc detected *** double free or corruption (fasttop): 0x080b0970 ***
rsync: connection unexpectedly closed (524 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(453) [sender=2.6.9]

( les nombres et numéro varient )

J' ai d'abord cru que mon disque dur externe (eSATA en usb2) était trop pour mon vieux PC ( et sa déja vieille Debian ), mais une autre tentative sur un autre ( vieux) disque interne [monté sur /home/backup] a donné le même résultat.

J'ai donc réinstallé rsync ( apritude reinstall rsync )
en vain.

j'ai essayé sans l' option "A" et cela semble fonctionner (c'est en cours )

Mes partitions concernées sont toutes XFS, sur LVM (sources) ou non ( disque externe ), et je pensai que l'option"A" de rsync permettait la sauvegarde des "ACL" .


QUESTIONS EN FORME DE CONCLUSION:

- Ou bien je me trompe sur les ACL ou sur ce que fait l'option "A" de rsync.

- Ou bien un dysfonctionnement autre ...
  • # Problème de pointeurs

    Posté par (page perso) . Évalué à 5.

    Récemment j'ai eu un problème qui me semble similaire avec un de mes programmes : il fonctionnait « parfaitement » avec les anciennes versions de la libc et les nouvelles versions le faisait planter avec ce genre de message d'erreur. Après d'intenses recherche, j'ai fini par trouver une corruption de mémoire dans le programme.
    Des recherches sur le net m'avait montré que d'autres avait rencontré le même genre de soucis avec d'autres applications lors de modernisation de la libc. Conclusion : il n'est pas impossible qu'il y ai un truc pas net dans la gestion mémoire de rsync.
  • # MALLOC_CHECK_

    Posté par . Évalué à 2.

    Essaie de relancer ton rsync avec la variable d'environnement MALLOC_CHECK_=1
    Si tu as le temps, tu peux recompiler rsync avec les informations de debug, et le lancer sous Valgrind.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.