Forum Linux.embarqué fonera 2.0n question généraliste

Posté par (page perso) . Licence CC by-sa
Tags :
1
5
sept.
2014

Bonjour,

J'ai installé privoxy+ dansguardian sur une fonera 2.0n firmware fon dev (2.3.7.1).
Le tout marche. Un youporn.com me renvoie l'accès est interdit.

Maintenant plusieurs choses:

  • faut t-il que je configure dansguardian plus finement? Car un test dansguardian (http://easy.open.and.free.fr/TinyDansguard/test.html) se charge normalement.

  • j'aimerais bloquer tout le traffic et autoriser juste le http et https et ssh. Pour l'instant j'ai ceci dans /etc/conf/firewall (je vous épargne etc/firewall.fon et etc/firewall.user est vide:

config 'defaults'
        option 'syn_flood' '1'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'

    config 'zone'
        option 'name' 'wannet'
        option 'input' 'REJECT'
        option 'output' 'REJECT'
        option 'forward' 'REJECT'

    config 'zone' 'lan'
        option 'name' 'lan'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'

    config 'zone'
        option 'name' 'wan'
        option 'input' 'REJECT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'
        option 'masq' '1'

    config 'zone'
        option 'name' 'hotspotwifi'
        option 'input' 'REJECT'
        option 'output' 'REJECT'
        option 'forward' 'REJECT'

    config 'zone'
        option 'name' 'hotspot'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'

    config 'forwarding'
        option 'src' 'lan'
        option 'dest' 'wan'

    config 'forwarding'
        option 'src' 'hotspot'
        option 'dest' 'wan'

    config 'include'
        option 'path' '/etc/firewall.fon'

    config 'include'
        option 'path' '/etc/firewall.user'

    config 'zone' 'vpn'
        option 'input' 'ACCEPT'
        option 'forward' 'REJECT'
        option 'name' 'vpn'
        option 'output' 'ACCEPT'

    config 'redirect' 'cfg164a43'
        option 'src' 'wan'
        option 'proto' 'tcpudp'
        option 'src_dport' '9100'
        option 'dest_ip' '192.168.1.22'
        option 'dest_port' '9100'

    config 'redirect' 'cfg18ff16'
        option 'src' 'wan'
    config 'redirect' 'cfg18ff16'      
            option 'src' 'wan'     
            option 'proto' 'tcp'    
            option 'src_dport' '80'  
            option 'dest_ip' '192.168.1.22'
            option 'dest_port' '80'  

    config 'redirect'                
    option proto 'tcp'                     
    option target 'DNAT'             
    option dest 'lan'               
    option _name 'transparent-proxy for HTTP'
    option src 'lan'          
    option dest_port '8080'     
    option src_dport '80'          
    option dest_ip '192.168.10.1'          
    option src_dip '!192.168.10.1'
  • j'aimerais afficher un message d'avertissement sur les limitations d'utilisation. J'ai regardé la variable "proxy-info-url" du fichier de configuration de privoxy, mais je suis à la rue non?

  • peut-on limiter le débit d'un interface réseaux?

  • enfin la fonera est connecté à internet depuis l'interface wifi sur la livebox. Et, je n'ai pas accès à ssh à travers la livebox en réseaux local. J'ai partagé ssh sur le wan dans luci.

  • # Quelle horreur !!!

    Posté par . Évalué à 2. Dernière modification le 05/09/14 à 17:43.

    j'aimerais bloquer tout le traffic et autoriser juste le http et https et ssh. Pour l'instant j'ai ceci dans /etc/conf/firewall (je vous épargne etc/firewall.fon et etc/firewall.user est vide:

    Les proxies "nazis" c'est pas bien

    • [^] # Re: Quelle horreur !!!

      Posté par (page perso) . Évalué à 1.

      Malin!

      Non mais je rajouterais imap tousssa.
      Je veux éviter le p2p. Adieu le téléchargement de la dernière iso linux en torrent.
      C'est déjà assez koul de partager la connexion.

      Il y a bien l'article de sieur Imil mais le filtrage est pas géré par iptables.

      Je n'ai pas beaucoup avancé.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.