Forum Linux.mandriva activer dma du lecteur de cdrom ?

Posté par .
Tags : aucun
0
25
mar.
2006
Bonjour

le dma de mon lecteur de cdrom n'est pas activé

hdparm /dev/hdc
me renvoie


IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
HDIO_GETGEO failed: Invalid argument


j'ai tenté de passer using dma en saisissant

hdparm -d 1 /dev/hdc

je reçois alors


/dev/hdc:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)


comment faire pour faire en sorte que l'opération soit permise ?
merci
  • # patcher le noyau...

    Posté par (page perso) . Évalué à 1.

    C'est quoi ta machine ? un portable ? Et ton contrôleur IDE ? Ça te le fait que sur le CD-Rom ou le disque dur aussi ?

    J'ai le même problème avec mon Acer TM4150LMi (quelques autres portables ont aussi ce problème). Je l'ai temporairement résolu en appliquant un patch sur le noyau 2.6.10... enfin c'est une longue histoire : http://www.linuxquestions.org/questions/showthread.php?s=&am(...)

    En espérant que pour toi il ne s'agisse pas de ça...
  • # sudo ?

    Posté par . Évalué à 1.

    Il faut être root il me semble pour toucher à cela.

    Donc :
    sudo hdparm -d 1 /dev/hdc
    • [^] # Re: sudo ?

      Posté par . Évalué à 1.

      ça c'est sur :)
      de toute façon hdparm ne passe pas en utilisateur lambda
      le pb est ailleurs et un peu plus compliqué , vois-tu... j'ai trouvé ma réponse (voir ci-dessus)
  • # Driver controler

    Posté par . Évalué à 1.

    Bien souvent ce problème vient du kernel qui ne retrouve pas le driver lié au controleur IDE. Si tu utilise un noyau "maison", vérifie que le driver est bien sélectionner dans tes options, sinon, essaye de mettre a jour ton noyau, ton contrôleur a peut-être été ajouter dans les dernières version...

    En espérant etre utile.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.