Forum Linux.mandriva DVD::Rip sur Mdk 10.1 == crash immediat

Posté par .
Tags : aucun
0
7
jan.
2005
quelqu'un a t il réussi a faire marcher DVD::Rip sur mandrake 10.1 ?

J'ai recupéré et installé les package plf necessaires en plus de Video-DVDRip-0.51.4-1plf . C'est ok , toutes les dépendances sont satisfaites mais le soft ne démare pas :
$ dvdrip -d 3
--- START ------------------------------------
2810: Sun Jan 2 15:20:49 2005 - DEBUG LEVEL 3
2810: TRACE IN : Video::DVDRip::GUI::Main::start (-> )
("")
2810: TRACE IN : Video::DVDRip::GUI::Main::build (-> Video::DVDRip::GUI::Main::start)
("")
2810: TRACE IN : Video::DVDRip::GUI::Main::create_window (-> Video::DVDRip::GUI::Main::build)
("")
2810: TRACE IN : Video::DVDRip::GUI::Main::create_window_box (-> Video::DVDRip::GUI::Main::build)
("")
2810: TRACE IN : Video::DVDRip::GUI::Main::create_menubar (-> Video::DVDRip::GUI::Main::build)
("")
Segmentation fault

Il me semble que c'est un pb lié a GTk utilisé par DVD::Rip et GTK 2 installé par defaut sur Mdk10.1 mais je n'en suis pas sûr. GTK et GTK2 sont installés sur la machine.

Les gars de dvd::rip n'ont pas pu m'aider. ils pensent que c'est un pur problème mandrake.

Any Hint ?

merci
  • # j'ai trouvé moi meme

    Posté par . Évalué à 3.

    c'est un probleme de locales . Il faut lancer :
    $ LC_ALL=C /usr/bin/dvdrip
    • [^] # Re: j'ai trouvé moi meme

      Posté par (page perso) . Évalué à 1.

      Argh ! ce ne serait que ça !
      Pour ma part j'ai viré les packages perl-gtk et perl-gtk-gdkpixbuf croyant qu'ils étaient bogués, et j'ai installé le tarball de perl-gtk-0.7008 (pas moyen de compiler le 0.7009). Et là plus de segmentation fault avec dvd::rip 0.52.0 (dont je signale la sortie, c'est la dernière version stable).

      http://www.funix.org mettez un manchot dans votre PC

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.