Forum Linux.mandriva Mandriva ne démarre plus : Kernel nokmsboot quiet resume [ RESOLU ]

Posté par . Licence CC by-sa
0
30
oct.
2014

Bonjour à tous,

Mon Mandriva ne démarre plus.
Au démarrage j'ai bien mon Grub; si je choisi Mandriva il me met :

kernel (hd0,5)/boot/vmlinux  BOOT_IMAGE=linux root=UUID=58ca98af-250e-4454-99db-2cfa1f78614a nokmsboot logo.nologo quiet resume=UUID=9dc5b72b-d4bd-41a3-8345-c60cc8f688bf splash=silent vga=788
[linux-bzImage, setup=0x4200, size=0x342d90]
initrd (hd0,5)/boot/initrd.img

Et là plus rien…

il ne démarre pas !

Que puis je-faire ?

Merci par avance pour votre aide.

Gaël

  • # aucun message ?

    Posté par (page perso) . Évalué à 2.

    Rien ne se passe ?

    Ecran noir ? le hdd travaille ?

    Tu peux enlever quiet pour tester.

    Système - Réseau - Sécurité Open Source

    • [^] # Re: aucun message ?

      Posté par . Évalué à 1.

      Non l'écran affiche ce message et il ne se passe plus rien. je peux attendre, il ne se passe rien.

      Enlever quiet ? mais comment ? je n'ai pas la main, je n'ai même pas de prompt ??

      • [^] # Re: aucun message ?

        Posté par . Évalué à 1.

        De mémoire quand tu sélectionne la ligne mandriva dans grub, si tu appuie sur la lettre E de ton clavier tu peut editer la ligne de commande.
        Supprimer aussi "splash=silent" ou remplace le par "splash=verbose" pour avoir le maximum d'info

        • [^] # Re: aucun message ?

          Posté par . Évalué à 2.

          si tu as fait des mises à jour recemment, c'est peut-etre l'option nokmsboot qu'il faut virer pour permettre de faire un demarrage avec KMS (Kernel Mode Settings)

          • [^] # Re: aucun message ?

            Posté par . Évalué à 1.

            Bonjour,

            Avec Verbose et en supprimant nokmsboot, Mandriva démarre.

            Mais je suis obligé de faire cela a chaque démarrage.

            Sinon, j'imagine que tout ce qui est affiché à l'écran, grâce au mode verbose, durant le démarrage doit être sauvegardé dans un fichier log, mais ou le trouver ?

            Merci pour vos réponses, je peux déjà redémarrer Mandriva manuellement donc.

            Mais que faire pour stabiliser ce problème ?

            Bien cordialement
            ```

            • [^] # Re: aucun message ?

              Posté par (page perso) . Évalué à 2.

              bootlog ?

              Système - Réseau - Sécurité Open Source

            • [^] # Re: aucun message ?

              Posté par . Évalué à 0.

              Tout ce qui est affiché dans la phase de démarrage du noyau est accessible par la commande dmesg
              Ensuite c'est dans le systeme de fichier log standard (/var/log/) que tu trouveras le reste.

              Il faut que tu modifie la configuration de grub (je suppose que c'est une version 2 que tu as d'installé, il faut vérifier ca avec la commande grub-install --version)
              Ensuite soit tu utilise https://launchpad.net/grub-customizer pour faire la config
              Soit tu modifie le fichier /boot/grub/grub.cfg manuellement (mais cette modification sera perdu lors de la prochaine invocation de update-grub)

            • [^] # Re: aucun message ?

              Posté par . Évalué à 2.

              si cela fonctionne en virant le nokmsboot seulement
              tu peux faire en sorte de le rendre definitif en modifiant le fichier de configuration de grub.

              sous debian/ubuntu c'est dans /etc/default/grub
              j'imagine qu'il doit y avoir un fichier similaire sous mandriva

              • [^] # Re: aucun message ?

                Posté par . Évalué à 1.

                En fait je n'ai pas de dossier ni de fichier Grub dans etc/default/ sous mandriva.

                Donc je retire kmsboot à chaque démarrage.

                Quelqu'un serait-il comment faire sous Mandriva ?

                sinon en démarrant Linux je me suis rendu compte qu'il ne s'arrète plus. Enfin, si j'ai mis "verbose" il indique "system halted" mais il ne coupe pas l'alimentation (Je suis donc obligé de l'éteindre en gardant le bouton enfoncé).

                Si vous aviez des idées ou des pistes, j'en serais ravi !

                Merci par avance.

                • [^] # Re: aucun message ?

                  Posté par . Évalué à 2.

                  pour l'option de boot, faut chercher sur les forum mandriva/mageia

                  Enfin, si j'ai mis "verbose" il indique "system halted" mais il ne coupe pas l'alimentation (Je suis donc obligé de l'éteindre en gardant le bouton enfoncé).

                  ca c'est souvent un probleme d'ACPI (gestion d'energie) qui est mal interprété par le fabricant de la machine,
                  du coup la demande d'arret n'est pas prise en compte par l'alimentation.

                  la aussi, il y des options de boot sur le theme de l'ACPI à tester.

                  • [^] # Re: aucun message ?

                    Posté par . Évalué à 1.

                    J'ai trouvé comment changer le soptions de boot : je suis allé dans "configurer votre ordinateur", "démarrage" puis "configurer le démarrage système". là j'ai pu modifier les options de boot etretirer le "nokmsboot" qui empéchait le démarrage.

                    Par contre pour l'arret de l'ordinateur qui ne s'arrête plus, là je n'ai pas trouvé comment faire.

  • # SOLUTION TROUVEE

    Posté par . Évalué à 1.

    Finalement ça marche aussi pour l'arret.

    Merci à tous pour vos réponses

    SOLUTION TROUVEE :

    Lors du démarrage, dans le Grub choisir de définir les options de boot (il est indiqué en bas de l'écran comment y acceder)

    Dans les options de boot, retirer l'option "Nokmsboot" puis démarrer.

    Après le démarrage, dans le centre de contrôle de mandriva, choisir "démarrage" et "configurer le démarrage du système"

    pour l'option de démarrage Linux, faire "modifier". La nouvelle fenêtre permet de modifier les informations transmises au noyau. Retirer "nokmsboot".

    Voilà. Merci à tous

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.