Forum Linux.mandriva problème enigmail

Posté par .
Tags : aucun
0
16
jan.
2012

Salut à tous,
Alors voila, suite à un changement de version d'OS de mandiva 2009.1 vers mandriva 2010.2,
et donc changement de version de Thunderbird+enigmail, je n'arrive plus a déchiffrer les messages :
quand je clique sur un message chiffré, j'ai un bandeau rose dans lequel il est ecrit :
"Erreur - le déchiffrement a échoué; cliquez sur l'icône représentant une clef pour plus de détails "
si je clique sur détail j'ai "/usr/bin/gpg --charset utf8 --batch --no-tty --status-fd 2 --decrypt --use-agent
gpg: annulé par l'utilisateur
gpg: chiffré avec une clé de 1024 bits ELG-E, ID XXXXXXX, créée le 2004-03-21
« XXXXXX yyyyyyyy@truc.machin.chose »
gpg: le déchiffrement par clé publique a échoué: mauvaise phrase de passe
gpg: le déchiffrement a échoué: la clé secrète n'est pas disponible"
Il ne me demande même plus de rentrer mon pass !
Pourtant dans mon trousseau et visible depuis thunderbird , j'ai bien présentes ma clé publique et ma clé privée.
Je sèche complètement, alors une bonne ame pour me sortir de là ?
Une précision, ca le fait avec le rpm de thunderbird de la distro ainsi qu'avec la version 8 que j'ai installée en espérant que ça aille mieux et avec enigmail1.3.4.
Je n'ai pas de besoin imprérieu de tout chiffrer, mais pas parcequ'on à rien à cacher qu'on doit tout montrer...

  • # mise à jour qui à mis à jour un certificat qqpart

    Posté par . Évalué à 2.

    et comme le certificat sert à verifier les identités

    non ?

    ou alors pas le meme support de lang (utf-8 depuis le debut ?)

    • [^] # Re: mise à jour qui à mis à jour un certificat qqpart

      Posté par . Évalué à 0.

      Par rapport au certificat : de ce que je comprends (pas grand chose il est vrai) ca repose sur la génération d'une paire de clé publique/privée, il n'y a pas de certificat qui entre en jeu la dedans.
      Pour la question de la locale, je n'ai pas fait attention si il y a eu un changement. je vais voir de ce cote si j'arrive à trouver quelque chose.

  • # first by hand

    Posté par . Évalué à 2.

    1 - Tu sauvegardes le mail dans un fichier (ou tu copie/colle la source)
    2 - gpg --decrypt < fichier.eml

    • [^] # Re: first by hand

      Posté par . Évalué à 0.

      Merci pour le tuyau, effectivement dans un premier temps
      ca va me dépanner. J'essaie ce soir.
      Merci pour l'astuce, je me disais bien qu'il y avait moyen de
      faire à la main mais je ne voyais pas trop comment.

      • [^] # Re: first by hand

        Posté par . Évalué à 0.

        Bon, je viens de faire l'essai à la main et j'ai exactement le meme message d'erreur ! ca vient donc de gpg et pas de enigmail et pareil a aucun moment ça me demande le mot de passe.
        ci dessous la copie de ce que j'ai en console :
        [olivier@localhost ~]$ gpg --decrypt < message.eml

        Vous avez besoin d'une phrase de passe pour déverrouiller la
        clé secrète pour l'utilisateur: « yyyy »
        clé de 1024 bits ELG-E, ID zzzzz, créée le 2004-03-21 (ID clé principale kkkkk)

        gpg: annulé par l'utilisateur
        gpg: chiffré avec une clé de 1024 bits ELG-E, ID 649363C2, créée le 2004-03-21
        « yyyy xxxx@zzzzz »
        gpg: le déchiffrement par clé publique a échoué: mauvaise phrase de passe
        gpg: le déchiffrement a échoué: la clé secrète n'est pas disponible
        [olivier@localhost ~]$

        Des idées ???
        Merci pour votre aide !

        • [^] # Re: first by hand

          Posté par . Évalué à 2.

          man gpg

          bon ok, y a du monde et pas mal de ligne à lire
          http://linux.die.net/man/1/gpg

          mais y a surement une option pour lui dire d'utiliser une clef avec mot de passe
          et non pas un clef avec passphrase

          sinon dans les options j'ai vu une histoire d'import entre une version recente et une version precedente (<0.9.6) si ca se trouve tu es dans un cas similaire

          • [^] # Re: first by hand

            Posté par . Évalué à 0.

            Bon en bidouillant dans les fichiers de config gpg.conf, ça marche en ligne de commande, mais pas dans thunderbird+enigmail. Ca resoud partiellement mon probleme, il ne faut pas que le mail chiffré ait de pièce jointe car en ligne de commande tout apparait à l'écran : le corps du message et le contenu de la piece jointe...

          • [^] # Re: first by hand

            Posté par . Évalué à 0.

            Je progresse MAIS...

            en affichant la console de deboggage de enigmail j'ai :
            enigmail> /usr/bin/gpg --charset utf8 --batch --no-tty --status-fd 2 --decrypt --use-agent
            gpg: annulé par l'utilisateur
            On voit qu'il y a un paquet d'option en plus de celles que je fais en ligne de commande. Apres les avoir virees une par une, il semblerait que ce soit l'option --batch qui pose pb.
            La question quelle option modifier dans enigmail???

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.