Forum Linux.suse Pas de double boot

Posté par . Licence CC by-sa
Tags : aucun
0
2
déc.
2016

Bonjour ou bonsoir,

Sur mon pc, j'ai installé opensuse 42.2 à côté de win7 sur un second disque dur. Je n'ai pas de double boot, j'ai quand même accès à mes 2 OS par l'intermédiaire du bios. Comment l'installer?
Merci d'avance.

PC tour
Win 7 pack 1 64 bits
AMD FX 8320 3500 mghz 8 cores
16 Go mémoire corsaire
Carte mère Asus M5A99FX Pro R2.0
Carte graphique sapphire Nitro radeon R9 380X
DD samsung SSD EVO 250G SATA
DD Sata 160G

  • # pas besoin

    Posté par . Évalué à 2.

    si tu y as acces directement par le bios, avec la touche F2 ou F8 qui permet de choisir sur quel disque tu demarres,
    c'est deja un "double boot"

    si maintenant tu veux quand meme installer grub (note qu'il a quand meme du s'installer de lui meme sur l'un des deux disques durs,

    et bien il suffit de faire generalement grub-install /dev/sda
    si tu veux que le "double boot" soit installer sur le premier disque (enfin au sens linux du terme)
    ou bien /dev/sdb si tu veux qu'il soit installer sur le 2e disque.

    ensuite tu regles le bios pour demarrer sur celui qui contient grub,
    et tu n'as alors plus besoin de passer par la touche F2/F8 de ton bios

  • # Salut ou salut

    Posté par . Évalué à 2. Dernière modification le 03/12/16 à 11:55.

    Comme dit NeoX, si tu as deux disques tu peux déjà te servir du menu de boot du BIOS pour booter sur l’un ou l’autre. Pourquoi ça ne te convient pas ?

    Il y a peut-être une raison, je me pose vraiment la question.

    • [^] # Re: Salut ou salut

      Posté par . Évalué à 1.

      Bien sur, j'ai un double boot et, à l'usage c'est aussi pratique que le grub. Vous avez tous deux raison, je vais rester comme ça.
      Merci pour votre contribution.

      • [^] # Re: Salut ou salut

        Posté par . Évalué à 3.

        il est d'ailleurs probablement que tu ais quand meme le "grub" d'installer sur le disque linux,
        j'ai pas relu l'historique, mais tu as surement fait l'installation de linux en ayant debranché le disque windows)

        tu as donc un disque :
        - windows only
        et
        un disque
        - grub + linux

        mais comme le grub n'avait pas vu le disque windows, il ne s'affiche pas lors du demarrage sur le 2e disque puisqu'il ne te proposerait alors que le linux

        • [^] # Re: Salut ou salut

          Posté par . Évalué à 1.

          Pas du tout, depuis le début j'ai des problèmes avec cette carte mère et de m'adresser à Asus ne m'a guère renseigner. Depuis, j'ai été obligé de refaire le pc à zéro, en effet je ne pouvais plus aller sur win ou linux.
          c'est quand même un mystère, j'ai eu d'autres carte mère Asus et c'est la 1ère qui pose des problèmes.
          Je vien de réinstaller win7 mais je ne sais pas si je vais pouvoir réinstaller Linux (Mint ou Opensuse ou Magéia).

          J'ai fais une clé usb bootable, je la branche sur le pc, celui-ci démarre dessus mais quand je veux installer cet OS, j'ai le message suivant:
          "Le microcode de ce système a démarré l'installation en mode UEFI mais il semble exister d'autres systèmes d'exploitation qui utilisent le mode de compatibilité BIOS.
          Si vous poursuivez l'action en mode UEFI, il peut être difficile de redémarrer ces systèmes d'exploitation.
          Si vous souhaitez conserver la possibilité de démarrer les autres système installés, vous ne devriez pas forcer l'installation en mode UEFI."

          J'ai cherché dans le bios mais aucune modification n'est efficace. J'ai désactivé le démarrage rapide, désactivé le secureboot, en vain.
          Pourriez-vous me donner la solution?
          C'est vraiment la galère, en fin de compte, le problème n'est pas du tout résolu.

          • [^] # Re: Salut ou salut

            Posté par . Évalué à 2.

            "Le microcode de ce système a démarré l'installation en mode UEFI mais il semble exister d'autres systèmes d'exploitation qui utilisent le mode de compatibilité BIOS.

            J’en déduis que ton Windows est installé en mode de compatibilité BIOS.

            Il faut démarrer ton installation en mode de compatibilité BIOS :

            Régler le démarrage en mode EFI ou classique

            Certains ordinateurs récents (2011 et +) permettent de régler le démarrage soit en mode classique (=mode BIOS) soit en mode UEFI. La manière d'effectuer ce réglage varie selon les ordinateurs, mais généralement ce réglage se situe dans l'onglet "Boot order" du BIOS/UEFI (il faut généralement appuyer sur une touche à l'allumage du PC pour y accéder, voir ce tutoriel).

            Remarque: certains BIOS permettent de régler séparément le mode de démarrage sur CD et celui sur disque dur.

            Par exemple, ci-dessous:

            la ligne "UEFI Hitachi" permet de démarrer sur le disque dur en mode EFI,
            la ligne "P1: Hitachi" permet de démarrer sur le disque dur en mode classique (non-EFI),
            la ligne "P3: DVD" permet de démarrer sur le CD Ubuntu en mode classique
            la ligne "UEFI: USB" permet de démarrer sur le liveUSB Ubuntu en mode EFI

            https://doc.ubuntu-fr.org/uefi

            À priori tu peux choisir ça dans le menu de boot du PC… Bon courage.

          • [^] # Re: Salut ou salut

            Posté par . Évalué à 2.

            "Le microcode de ce système a démarré l'installation en mode UEFI mais il semble exister d'autres systèmes d'exploitation qui utilisent le mode de compatibilité BIOS.
            Si vous poursuivez l'action en mode UEFI, il peut être difficile de redémarrer ces systèmes d'exploitation.
            Si vous souhaitez conserver la possibilité de démarrer les autres système installés, vous ne devriez pas forcer l'installation en mode UEFI."

            ca c'est probablement parce que tu demarres un linux EFI
            qui va tenter d'installer un GRUB en mode EFI
            alors que le windows est installé en mode BIOS.

            le mieux est peut-etre alors de configurer dans ton "bios" (enfin dans les reglages de la carte mere)
            de tout mettre en EFI, ou tout mettre en mode LEGACY/BIOS

            puis de reinstaller tes OS, sans plus rien toucher à ce reglage.

            • [^] # Re: Salut ou salut

              Posté par . Évalué à 2.

              puis de reinstaller tes OS, sans plus rien toucher à ce reglage.

              À priori son Windows est déjà installé sans EFI, pas besoin de le réinstaller, il faut forcer le boot de la clé en mode de compatibilité BIOS. Enfin à priori hein…

  • # re-re-re

    Posté par . Évalué à 1.

    Bonjour,
    j'ai suivi vos commentaires mais rien n'a été efficace, j'ai réinstallé win 7 et je constate qu'il n'est pas "tamponné" UEFI. Je tente tout à l'heure un installation de Linux Mint xfce.
    Je vous tiens au courant.

    • [^] # Re: re-re-re

      Posté par . Évalué à 1.

      Comme d'hab, une fois installé, pas moyen de retrouver et win et Linux. J'ai remis une fois de plus le bios à zéro, je l'ai flashé. J'ai réinstaller win 7, je pense que j'ai une incompréhension totale avec l'UEFI ( win est "tamponné" UEFI). Je ne sais quels réglages faire pour installer Linux.

      J'ai toujours ce même message posté plus haut alors que je mets en démarrage "autre SE", je désactive "démarrage rapide", j'ai aussi testé avec le "secure boot".
      Au secours.

      • [^] # Re: re-re-re

        Posté par . Évalué à 2.

        Comme d'hab, une fois installé, pas moyen de retrouver et win et Linux.

        Quand tu installes Linux il détecte bien la présence du Windows ? Normalement il doit te proposer soit d’installer à la place, soit à côté…

      • [^] # Re: re-re-re

        Posté par . Évalué à 2.

        win est "tamponné" UEFI

        Je dirais que s’il ne l’était pas la première fois et qu’il l’est la deuxième ça a justement un rapport avec ce qui est configuré dans ton "BIOS" quand tu installes.

      • [^] # Re: re-re-re

        Posté par . Évalué à 2.

        comprendre ce qu'on fait.

        dans le BIOS Asus, il y a un reglage du mode de demarrage :
        - EFI
        - CSM forcé
        - CSM auto (qui va alors choisir entre EFI et CSM)

        si tu te mets en EFI, tous les systemes devront etre etre EFI, ton windows, ton linux…
        en mode CSM forcé, tous les systemes seront alors en mode BIOS
        en mode CSM Auto, il va tenter de demarré en EFI, s'il ne peut pas il va passer en mode CSM

        de ce que tu dis, je penses que tu es en mode CSM AUTO
        du coup, si ton media d'installation windows ne peut pas booter en EFI pour s'intaller, il s'est peut-etre installé en mode CSM (bios compatible)
        mais quand tu bootes ton media d'installation linux, il arrive à demarrer en EFI, et de met le message d'avertissement que tu cites.

        si tu veux demarrer ton installation linux en mode 'BIOS' il faut au choix :
        - mettre ton bios en mode CSM Forcé
        ou
        - choisir le boot qui n'est pas EFI dans le choix du peripherique de boot.

        • [^] # Re: re-re-re

          Posté par . Évalué à 2.

          Çà y est, j'ai enfin débloqué ma vision du bios, et ce grâce à vos commentaires. C'est pénible quelques fois de se buter intellectuellement sans s'en rendre compte. Merci.

          • [^] # Re: re-re-re

            Posté par . Évalué à 2.

            de rien, si ca a pu aider à mieux apprehender la bete, c'est deja ca de gagner :D

            • [^] # Re: re-re-re

              Posté par . Évalué à 1.

              C'est règlé, j'ai tout réinstallé sans problème. Cet aspect des choses est résolu.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.