Forum Programmation.web installer une "vieille" extension Firefox dans Firefox 4

Posté par .
Tags :
6
15
mar.
2011

un gros soucis quand une version majeure (ou même mineure) de Firefox sort, c'est que quelques unes de vos extensions favorites sont marquées comme obsolètes, alors que vous sentez pertinement que pour telle ou telle raison elle marchera très bien (par exemple vous avez son code source sous les yeux et elle ne casse pas 3 pattes à un canard, ou encore il y a beaucoup de xul/javascript et très peu de binaire)

typiquement, votre extension favorite datant de : Updated November 13, 2009

sera estampillée : Works with Firefox 2.0 - 3.7a1pre

vous l'aurez compris, son auteur l'a un peu oubliée ou abandonnée

lire la page http://kb.mozillazine.org/Extensions.checkCompatibility vous proposera de créer la clé extensions.checkCompatibility.4 de type boolean avec une valeur de false

toutes ne marcheront pas (changements d'API XPCOM...) mais par exemple JSView marche chez moi maintenant \o/

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.