Suivi - Suivi Affichage des caractères spéciaux (sous Win32)

#180 Posté par . État de l'entrée : invalide
3
23
fév.
2011

Chez moi (cf: Chromium sous Archlinux) l'affichage du site est parfait… par contre au boulot je suis obligé d'utiliser Windows Xp et avec Chrome (même soucis si je bascule sur l'obsolète IE) j'ai un problème d'affichage avec certains caractères spéciaux.

Par exemple, les espaces insécables ne s'affichent pas correctement mais je vois à la place un petit rectangle vide :

Aperçu

Une piste peut-être…

Si j'affiche la source de la page html, les espaces insécables sont aussi représentés par des rectangles.

  • # Problème de polices

    Posté par (page perso) . Évalué à 4 (+0/-0).

    Je n'ai pas windows, donc ça ne va pas être facile de corriger ça. Je me demande si ce n'est pas un problème de polices.

    Est-ce que tu pourrais copier-coller ce texte dans un éditeur et essayer plusieurs polices ?

    • [^] # Re: Problème de polices

      Posté par (page perso) . Évalué à 3 (+0/-0).

      oui, c'est un souci des polices disponibles par défaut sur windows qui ne contiennent pas l'ensemble des caractères.

      La police Calibri ne fait plus apparaître ce souci qui est flagrant avec le Arial par défaut... Éventuellement proposer une CSS adaptée aux manques de windows ? (demander à aKa de faire passer la demande si elle serait financée par Microsoft :D).

      • [^] # Re: Problème de polices

        Posté par . Évalué à 1 (+0/-0).

        Sur mon poste avec Calibri j'ai toujours des rectangles mais avec des "?" dedans!

        Titre de l'image

        Ce qui est étrange c'est que lorsque je tape des espaces insécables sous Windows ils s'affichent bien!

        • [^] # Re: Problème de polices

          Posté par . Évalué à 2 (+0/-0).

          Ce qui est étrange c'est que lorsque je tape des espaces insécables sous Windows ils s'affichent bien!
          

          C'est probablement parce qu'il s'agit d'espaces insécables fines. En effet, en typographie française, on met une espace fine insécable devant « ; », « ? », « ! », alors que l'on met une espace insécable demi-cadratin devant « : ». Voici un exemple :

          Intitulé de la liste :

          • item 1 ;
          • item 2 ;
          • item 3 :
            • sous-item 3.1,
            • sous-item 3.2,
            • sous-item 3.2 ;
          • dernier item.
  • # Et maintenant ?

    Posté par (page perso) . Évalué à 2 (+0/-0).

    La police par défaut est maintenant sans-serif. Est-ce que le problème se pose encore ?

  • # Mobiles

    Posté par (page perso) . Évalué à 3 (+0/-0).

    Plusieurs personnes ont également remonté ce problème sur les mobiles. La raison semble être les espaces fines insécables. Je pense que je vais remplacer ces caractères par des espaces insécables  .

    • [^] # Re: Mobiles

      Posté par (page perso) . Évalué à 3 (+0/-0).

      Proposition de Victor :

      Est-ce qu'on ne pourrait pas embarquer une police de caractères dans la CSS, au moins pour Windows ? CSS permet ça, mais je ne connais pas la syntaxe.

      • [^] # Re: Mobiles

        Posté par . Évalué à 2 (+0/-0).

        Euh, tu es sérieux quand tu dis que tu vas appauvrir la mise en forme du texte pour que LinuxFr soit compatible Windows XP ?!
        Pitié, trouvons leur un hack qui ne pénalise pas ceux qui ont un système qui fonctionne correctement !

        • [^] # Re: Mobiles

          Posté par (page perso) . Évalué à 2 (+0/-0).

          Oui, je suis sérieux quand je dis que je vais restreindre les caractères spéciaux utilisées pour que LinuxFr.org puisse s'afficher correctement sur différents systèmes, dont Android (un Linux) et Windows XP, et certains navigateurs en mode texte sous Linux.

    • [^] # Re: Mobiles

      Posté par . Évalué à 1 (+0/-0).

      problème chez moi également :

      • windows XP et FF4
      • N97 (WebKit 525)

      Je pense que je vais remplacer ces caractères par des espaces insécables  .

      Ca serait cool merci.

      => http://www.valeryxavierlentz.eu/index.php?post/L-espace-fine-insecable-sur-le-web-ce-n-est-pas-pour-demain

      • [^] # Re: Mobiles

        Posté par . Évalué à 1 (+0/-0).

        en fait c'est un problème unicode, la police par défaut de windows n'est pas
        complète et ne contient pas le caractère utilisé ... donc il ne s'affiche
        pas ...

        tu peux le passer en html thinsp au lieu de nbsp
        (ça correspond au quart de cadratin ou espace fine insécable)

      • [^] # Re: Mobiles

        Posté par . Évalué à 2 (+0/-0).

        Sur le N97 tu peux utiliser Opera Mobile. Tu n'auras pas ce problème, et c'est un navigateur d'un autre niveau que la grosse daube inutilisable livrée par défaut (pas de cache : rechargement lors d'un retour à la page précédente ! Pas d'onglets : impossible d'ouvrir plus d'une page à la fois !).

        • [^] # Re: Mobiles

          Posté par . Évalué à 1 (+0/-0).

          Tu oublies la killer-feature du navigateur intégré du N97 : un lecteur de flux RSS !
          Malgré toute sa technologie, Opera ne fournit pas cette simple fonctionnalité :(

  • # Autre entrée du suivi sur le sujet

    Posté par (page perso) . Évalué à 2 (+0/-0).

  • # Je ferme

    Posté par (page perso) . Évalué à 3 (+0/-0).

    Je ferme cette entrée. On n'utilise quasiment plus l'espace insécable fine (le caractère qui posait problème) maintenant que des espaces insécables normales sont insérées automatiquement.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.