Journal xserver arrache les poils

Posté par (page perso) .
Tags : aucun
0
7
déc.
2003
J'ai décidé de me reposer un peu de toutes ces années consacrées à wmhdplop et j'ai essayé (sans trop y croire) de compiler le xserver de freedesktop [1]..

..suivage des instructions pour le téléchargement + compilation [2] .. ça passe sans un wanring, nickel.

cd /opt/fdo/bin ; chmod u+s *
export LD_LIBRARY_PATH=/opt/fdo/lib
export DISPLAY=:2.0
/opt/fdo/bin/Xvesa -mode 0x0124 -mouse /dev/input/mouse0,3 +bs :2.0 & wmaker

une fois le bouzin démarré, il suffit de taper /opt/fdo/bin/xcompmgr

et oila: http://hules.free.fr/xserver.png(...) <- y'a la transparence des fenetres + des ombres! Par contre par j'ai encore compris comment démarrer Xati..
Pour prendre les screenshots, il vaut mieux utiliser xwd car imagemagick ne chope pas la transparence.

En tout cas c'est impressionnant, keith packard et ses copains n'ont pas perdu leur temps à troller ou a enfiler des perles.

[1] http://xserver.freedesktop.org/Software/xserver(...)
[2] http://xserver.freedesktop.org/Software/XserverInstallGuide(...)
  • # Re: xserver arrache les poils

    Posté par . Évalué à 7.

    Est-ce que c'est rapide ?
    Est-ce que les applications ralentissent lorsque tu déplaces des fenêtres ?
    Quelle configuration as-tu ?
    Est-ce que ça arrive à la cheville des performances de MacOSX ?
    • [^] # Re: xserver arrache les poils

      Posté par (page perso) . Évalué à 9.

      Je l'ai essayé il y a quelque temps :
      j'ai un xp2000+, 256mo et une geforce 2 mx

      C'est joli mais c'est lent : le déplacement des fenêtres est loin d'être fluide. J'avais pas lancé grand chose d'autres que des xterms donc je ne saurais pas dire si ça ralenti beaucoup mais bon, une fois le code optimisé (et les drivers itou) ça donnera certainement quelque chose de sympa :).

      Autant la transparence n'apporte pas grand chose sur des applis classique (mais on a assez trollé sur le sujet ;), autant les ombres apportent beaucoup AMHA quand on a plusieurs fenêtres qui se superposent : ça donne vraiment du "relief".
      • [^] # Re: xserver arrache les poils

        Posté par (page perso) . Évalué à 8.

        ouais effectivement c'est lent. Xvesa -shadow est presque supportable, mais sinon même le Xati se traine. Bon, il doit trainer beaucoup de code de debug, et les drivers sont sans doute pas encore finalisés, mais ça m'a fait globalement une super impression pour un truc que je ne pensais même pas arriver à compiler
    • [^] # Re: xserver arrache les poils

      Posté par (page perso) . Évalué à 3.

      Calmos, c'est que le debut. C'est du vesa, coté acceleration c'est pas encore ca, et je sais pas si c'est toujours le cas mais la version que j'avais testé c'etait genre 60hz maxi :)
  • # Tiens... un toulousain

    Posté par (page perso) . Évalué à 3.

    Le "LFBO" de ta dock-app t'a trahi ;-))

    Bon OK, ch'ui fatigue et je dis que des *&(*&%^^$#.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.