Forum Astuces.divers [X-Window] Polices écrasées sous Mozilla

Posté par .
Tags : aucun
0
14
nov.
2004

Dans certaines circonstances, l'affichage des polices par Mozilla est corrompu. Des lignes de texte sont illisibles, comme écrasées dans le sens de la hauteur. Elles sont de nouveau lisible après une sélection du texte ou un défilement page par page.
Je n'ai jamais rencontré le problème avec d'autres logiciels (aterm ou nedit en particulier).



Ce n'est pas un problème de carte vidéo ou de pilote (j'ai une Matrox G550, et le problème est identique avec une nVidia gForce2) comme soupçonné au départ.



Il s'agit en fait d'un problème du gestionnaire de polices de X (XFree ou Xorg) ou du moteur d'affichage de Mozilla, qui gère mal les résolutions de l'écran comprises entre 75 et 100 dpi.
J'ai un écran 17" en 1152x864, ce qui correspond à 91 dpi.



Pour résoudre le problème, il suffit d'imposer la résolution au serveur X grâce à l'option "-dpi 75".



Avec startx, ça donne "startx -- -dpi 75", avec xdm, il faut ajouter l'option dans le fichier /etc/X11/xdm/Xservers (soit ":0 local /usr/X11R6/bin/X -dpi 75").



Certaines applications ont besoin de la résolution réelle, il faudra la leur indiquer dans les préférences (cas de Gimp).

  • # Une autre solution:

    Posté par (page perso) . Évalué à  1 .

    Je connais le probleme mais je ne connaissait pas la cause exacte,
    Ma solution: lancer mozilla/firefox/galeon depuis une session gnome
    ca me reglait le probleme.
    • [^] # Re: Une autre solution:

      Posté par . Évalué à  2 .

      Pour ma part, c'est du même genre : utilisateur de E, je fais tourner gnome-settings-daemon en arrière plan et le tour est joué.
  • # Et avec KDE ?

    Posté par . Évalué à  1 .

    Quel est le fichier à modifier pour KDE ?
    J'ai fait la modif sur le fichier donné pour xdm, mais nada, ça n'a rien changé...
  • # Une solution très simple

    Posté par . Évalué à  1 .

    J'ai exactement le même problème, depuis très longtemps, et, tout comme Benoit, je ne connaissais pas l'origine.

    Récemment, lors d'une n-ième recherche sur google, je suis tombe sur l'astuce de VoixOff et sur la page suivante:
    http://www.mozilla.org/unix/dpi.html(...)

    Cette page donne la même solution que celle proposée par VoixOff, mais elle propose aussi une manière de ne changer que le dpi de mozilla, en allant sur about:config et, dans le champ
    browser.display.screen_resolution
    mettre la valeur désirée. J'ai mis 96 et ça marche parfaitement.

    Voilà !

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.